Bruit - retour en arrière - puis Ok - UPnP Tidal

Bonjour,

En phase de test d’Audirvana 3.5 (dernière version) j’ai un problème avec 1 appareil qui m’embête beaucoup.

Source Tidal - Abonnement Master

  • MacBook Pro en USB : Ok
  • Chromecast Audio en UPnP avec BubbleUPnP : Ok
  • SMSL DP3 en UPnP direct : PROBLEME

Je vois quelques personnes ici qui peuvent être concernées par le même problème.

Description du problème sur SMSL DP3 :

Après plusieurs essais, j’ai tenté de réduire la configuration d’Audirvana aux 2 flux dont j’ai besoin :

  • en 16/44 ou 24/44
    Lancement du stream (un peu rapide, il me semble par rapport à celui à travers Bubble)
    Le son passe bien
    En fonction du débit, pause à 5 ou 6 secondes environ pour le 16 bits et 10 ou 11 secondes pour le 24 bits. Ensuite la musique reprend

  • en 24/48
    Lancement du stream (idem)
    Le son passe
    à 3 secondes environ, émission d’un bruit blanc
    ce son dure 3 seconde
    La lecture reprend alors normalement

Lecture Gapless Ok (ou presque)
On retrouve le problème à la lecture de la piste suivante.

Dans le meilleur des cas il n’y a PAS de bruit, mais alors à 10/11s le son s’arrête et reprend quelques secondes plus tôt (entre 3 et 6 s plus tôt).

Il y a donc bien un problème de buffer quelque part.
Ou une commande d’attente qui n’est pas bien comprise…

Je précise

  • que d’autres lecteurs UPnP (exemple mConnect) fonctionnent parfaitement (en FLAC)
  • que le flux qui démarre avant problème est bien identifié dans un conteneur WAV au débit Audirvana

Entre 2010 et 2012 j’ai pas mal travaillé sur le problème d’Airplay.
Faisant fonctionner RaopX (Airtunes1) en plein débit avec un buffer
Et câblant en interne le mac avec soundflower, Qjack etc.

Bref tout ce qu’Audirvana fait aujourd’hui avec maintenant une bonne ergonomie que je salue et qui est agréable intégrant en plus les services de son HD.

Le problème vient, il me semble, du buffer et de sa lecture.
Il me semble que l’horloge du streamer fonctionne de manière synchrone avec les flux entrants. Donc si la déclaration du flux n’est pas bonne il peut se passer quelque chose.
Ce n’est pas le seul à fonctionner comme ça, je pense que vous devez rencontrer le problème ailleurs.

Peut-être faut-il une tempo au départ de la piste. Je suis prêt à attendre 3 à 5 secondes avant lancement si ça règle les problèmes de déclaration, input du flux et calage de l’horloge.

Peut-être y a-t-il une astuce que je n’ai pas vue.
J’ai essayé de mettre un temps au Bridge pour le changement de flux, ça ne fonctionne pas.
J’ai essayé de réduire le buffer. Il me semble que ça joue, un petit buffer est mieux.

Bref, je sais l’intérêt de la porteuse plein débit et je constate qu’Audirvana en UPnP va encore plus loin que ce qu’on faisait sur Airplay. La restitution est bonne, mais le bug actuel me freine.

Cordialement,
n.d.b

DEBUG

Audirvana Mac Version 3.5.33 (3563)
macOS 10.15.4 with 8192MB RAM

Version d’essai utilisant une licence de démo

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 0 folders
iTunes/Music library synchronization: not synchronized
Library database path: /Users/NdB/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Preferred device: SMSL DP3 Model UID:HiBy Music SMSL DP3 UID:uuid:HiByMusic-e2ccd3a9-29f8-479e-a

Selected device:
UPnP device at http://10.0.1.132:49152/description.xml
ID 0x0 SMSL DP3 Manufacturer:HiBy Music
Model UID:HiBy Music SMSL DP3 UID:uuid:HiByMusic-e2ccd3a9-29f8-479e-a

2 available sample rates up to 48000Hz
44100
48000
Volume control: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to MQA Decoder
DSD capability: DSD via PCM 1.1
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
UPnP/DLNA supported protocols:
http-get::audio/mpeg:
http-get::audio/wav:
DLNA 1.5: No
Gapless playback: Yes
Missing events workaround: No
Can play native DSD: No
Number of channels: 2
Use as stereo device only: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x0 0 channels starting at 0
4 virtual formats:
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 44.1kHz
2 ch Non-mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Non-mixable linear PCM Interleaved 24 little endian Signed Integer 48kHz

0 physical formats

Current device transportInfo:
CurrentTransportState: STOPPED
CurrentTransportStatus: OK
CurrentSpeed: 1
Current device MediaInfo:
NrTracks: 1
MediaDuration:
CurrentURI:
CurrentURIMetadata:
nextURI:
nextURIMetadata:
PlayMedium: NETWORK
RecordMedium: NOT_IMPLEMENTED
WriteStatus: NOT_IMPLEMENTED

Bonjour @n.d.b, merci pour votre message et votre description de votre problème très précis. Avez-vous vérifié si votre firmware de DAC est à jour? En effet, il est possible que le fabriquant du DP3 ai corrigé ce problème. Si ce n’est pas le cas il faut les contacter car cela veut dire qu’il y a un problème d’implémentation sur leur module UPnP pour les logiciels UPnP media renderer.

J’ai tout vérifié.

*Parenthèse : *
Et pour tout dire j’ai même mis un autre firmware alternatif (qui ne change rien au DNLA/UPnP) mais qui vire la diaphonie du SMSL DP3. Ce petit lecteur devient alors extraordinaire branché en AES/EBU. Je ne comprends pas que Qobuz ait pu lui donner un Qobuzissime avec autant de diaphonie (volontaire, réglage constructeur, au moins 20%…). A ce niveau ça s’entend directement à l’écoute, c’est insupportable, on n’est pas du tout dans le subtil.
A ceux qui liront ce message, un russe (Pogoo) a mis au point le firmware avec 0% de diaphonie, bravo à lui.

Donc pour revenir au problème :

  • si je mets le plus petit buffer Audirvana, j’ai alors un arrêt à environ 3 secondes et reprise de lecture à 6 secondes
  • si j’augmente le buffer, alors à la place du blanc de lecture, j’ai un bruit blanc, ça crache.
  • et si j’augmente la résolution de piste, j’ai en plus le problème décrit plus haut, à savoir un retour en arrière de la lecture peu après le changement de piste. Ce problème est décalé vers 10/11s.

Sans connaitre votre fonctionnement, j’ai l’intuition que ça pourrait être dû aux horloges de certains Streamer/DAC qui se synchronisent sur le flux (en wifi). C’est peut-être ce mode de fonctionnement récent qui vous pose problème avec certains appareils. Mais je ne comprends pas ce blanc ou bruit ou retour arrière (gestion de votre porteuse plein débit??).
La piste commence sa lecture correctement avec le bon tag (WAV dans le cas d’Audirvana) et puis ça bug avant de reprendre normalement.

Autre piste. Comme mentionné plus haut, je suis surpris du départ si rapide du flux en lecture si je compare ce que j’ai avec la Chromecast Audio par BubbleUPnP (toujours en utilisant Audirvana). Ca me fait penser à une commande que vous devez envoyer, peut-être une attente de synchronisation d’horloge avant de démarrer la lecture. Dans ce cas Bubble répond, mais pas le SMSL DP3 qui lui démarre et se trouve donc en conflit à un moment. Possible ?

J’ai déjà entendu dans “l’intervalle du bug” (les 3 secondes de blanc, bruit ou retour arrière) un autre flux provenant d’une piste précédente. Ce serait peut-être la relecture de votre “porteuse” ?? Vous mettez un bruit blanc en porteuse au départ ? (et pas des 0 ?) En fait le bruit, le blanc ou un morceau de piste seraient dans le flux de porteuse non ?

Si je compare avec un flux Airplay (application Tidal directe par exemple), on voit bien que le DP3 a un buffer interne puisqu’il démarre avec retard (entre 1 et 3 secondes je dirais, il faudrait que je fasse le test précisément si ça vous intéresse). Donc il est également possible qu’il y ait un conflit de buffer en UPnP.

Bref, horloge flux ou buffer ou les deux… il me semble que ce sont les seules possibilités qui peuvent causer le problème. Ou le gapless, mais ce serait curieux qu’il bugue au départ de piste.

Rappel : j’ai testé plein d’applications UPnP (mconnect, Linn Kazoo…) elles fonctionnent TOUTES en UPnP avec le DP3. Certes en FLAC (et sans buffer je pense), certes avec des problèmes de gapless, mais ça fonctionne.

Pour info, j’ai regardé ce que me dit BitPerfect du SMSL DP3 pour le buffer Airplay.
Au cas où ça soit intéressant pour un buffer UPnP

Name: SMSL DP3
UID:48:0F:70:32:80:3A-107252783371460-airplay
Model UID: 48:0F:70:32:80:3A-107252783371460-airplay
Device Id: 74
Hogged: NO
Frame Buffer Sizes: 14 - 4096
Current Frame Buffer Size: 512
Left Channel: 1 Right Channel: 2
Sample Rates: 44.1
Audio Streams:
Stream ID: 75
Stream Number: 0
Starting Channel: 1
Total Channels: 2
Total Physical Formats: 1
Physical Format 1:
Sample Rate: 44100
Bit Depth: 16
Format Flags: [ kAudioFormatFlagIsSignedInteger kAudioFormatFlagIsPacked ]
Format ID: mcpl
Channels Per Frame: 2
Bytes Per Frame: 4
Frames Per Packet: 1
Bytes Per Packet: 4

Ces applications ne doivent pas utiliser le UPnP media renderer, avez-vous contacté SMSL pour leur poser la question sur l’intégration UPnP des applications utilisant l’UPnP media renderer pour leur DAC?

Qu’il soit DMR je n’ai aucun doute, il est capable de jouer un flux direct sans le demander.
S’il était player seul, il devrait interroger un DMS (ce qu’il fait aussi)

Je ne sais pas s’il est full DMR (peut-être manque-t-il une commande)…
comment le tester par exemple ?

Le firmware semble figé depuis un moment. On peut mettre les mains dans le cambouis, mais le jeu n’en veut peut-être pas la chandelle, quoiqu’il s’en est vendu des wagons et qu’il semble d’une transparence à faire pâlir des références bien plus chères, maintenant débarrassé du crosstalk.

Audirvana le voit systématiquement, alors qu’un UPnP implanté dans une télé Sony Android n’est pas toujours vu, si ça peut jouer. Et la Sony est DMR et DMP c’est certain.

Du reste si je joue Audirvana sur la Sony, je viens de faire l’essai :

  • pas de problème au départ de lecture de la piste (qui est bridée à 44,1 et n’est donc pas reconnue MQA contrairement au DP3)
  • le bruit blanc arrive en fin de piste, puis ça charge la suivante qui démarre normalement.

La Sony semble réagir comme d’autres utilisateurs d’Audirvana remontent le problème de bruit en fin de piste. Le DP3 réagit 3 secondes après le départ et pas en fin de piste.

Edit :

Le DP3 est forcément DNR vu qu’il peut recevoir les commandes de volume, de pause etc. d’Audirvana.

La Sony a une moins bonne implantation DNR, vu qu’elle n’a pas l’air de réagir à la commande de volume logicielle d’Audirvana, le son est marqué coupé.

Le scan UPnP du SMSL DP3 (qui est bien un DMR) :

1

0

urn:schemas-upnp-org:device:MediaRenderer:1

/renderpres.html

SMSL DP3

HiBy Music

http://www.hiby.com/

gmediarender 0.0.6

gmediarender

http://www.hiby.com/

uuid:HiByMusic-e2ccd3a9-29f8-479e-a

image/png

64

64

24

/usr/resource/upnp/64x64.png

image/png

128

128

24

/usr/resource/upnp/128x128.png

urn:schemas-upnp-org:service:AVTransport:1

urn:upnp-org:serviceId:AVTransport

/upnp/rendertransportSCPD.xml

/upnp/control/rendertransport1

/upnp/event/rendertransport1

urn:schemas-upnp-org:service:ConnectionManager:1

urn:upnp-org:serviceId:ConnectionManager

/upnp/renderconnmgrSCPD.xml

/upnp/control/renderconnmgr1

/upnp/event/renderconnmgr1

urn:schemas-upnp-org:service:RenderingControl:1

urn:upnp-org:serviceId:RenderingControl

/upnp/rendercontrolSCPD.xml

/upnp/control/rendercontrol1

/upnp/event/rendercontrol1

http://(je masque)/

Après plusieurs essais de comportement en USB et UPnP je pense que ça vient vraiment de la commande d’attente avant lecture.

En USB : Audirvana charge son buffer, puis la lecture démarre

En UPnP : Le flux démarre directement, même avec une latence de 5s demandée au changement de fréquence

  • j’arrive à une pause en qualité 16/44 à environ 3 seconde (durée de 1 à 3 seconde sans lecture puis reprise)
  • dès que le format est plus lourd que 16/44 (exemple 24/48) il y a émission de bruit blanc au lieu de la pause. Parfois, avec de la chance, ça reste un blanc.

Je parle là de lecture de première piste demandée par Audirvana.
Lors du passage à la piste suivante on se retrouve avec le “playback” que j’ai mentionné plus haut.
En gapless il y a une toute petite interruption (<<1s), mais ça enchaine bien sur la piste suivante.

Je suis persuadé que c’est la source de bien des problèmes avec les Streamers.
Avec BubbleUPnP sur mac sur une Chromecast on a ce départ différé (et pas de gapless).
Sur la Sony mentionnée plus haut, départ immédiat, le bruit arrivant sur la fin de piste.

Il doit y avoir une solution pour différer la réception du flux et sa lecture.
Tous les steamers sont DMR et DMP, la solution vient de la commande DMR pas toujours implantée de la même manière. Les fabricants devant privilégier le pilotage interne (DMP), ça m’étonnerait qu’ils modifient leur firmware.

Sans critiquer outre mesure, je pense que c’est à Audirvana de s’adapter aux différents comportements des DMR. Sur pas mal de topics vous bottez en touche sur les problèmes DLNA/UPnP en parlant de mauvaise implantation constructeurs. Je pense que ça finira par conduire les fabricants à dégager l’UPnP pour des solutions propriétaires (style Roon, RAAT). Ils ne peuvent pas se permettre une UX désastreuse sur le long terme.

Par exemple si le problème vient de l’implantation gmediarender 0.0.6 par rapport à gmediarender 0.0.7, Audirvana doit permettre le choix de comportement à l’utilisateur.

Aujourd’hui vous avez la meilleure interface, les meilleures possibilités de streaming plein débit et conversion de flux (MQA-PCM DSD->PCM…). Votre remote a une meilleure ergonomie que les solutions constructeurs UPnP (style Linn, AK…) ou même mconnect. Mais vous restez captif d’une application sur ordi. Pour l’imposer, il faut que cette application fonctionne avec les DMR actuels, non?

Bonjour @n.d.b,

J’ai constaté, il y a plusieurs mois, les mêmes problèmes de buffer en mode UPnP. Je possédais alors un Naim Uniti Nova. Je devais démarrer une seconde fois la lecture pour que la piste de musique puisse démarrer adéquatement. De plus, les formats haute-résolution en ALAC, au-délà de 24/48, arrêtaient souvent en pleine lecture sans raison apparente (transformé en Flac, le problème disparaissait. Switch Cisco et Internet à 400 mbps).

J’ai rapporté, dans ce forum, ce bogue auprès de Damien. Malheureusement, la faute a été imputée à Naim et qu’une mise à jour imminente allait corriger la situation. J’étais, alors, bêta testeur pour Naim et je possédais déjà cette mise à jour qui allait supposément corriger le problème… J’ai signalé ce fait à Damien, et puis, plus rien. Silence radio. Tout comme vous, je regrette cette situation et ce comportement. J’admire énormément le travail de Damien et la qualité sonore de son logiciel, mais, parfois, il faut reconnaître que la faute peut parfois être de notre côté et non du fabricant hardware.

J’ai fait récemment l’achat d’un Sonore OpticalRendu (certifié Audirvana +). Il sera branché sur mon Dac Schiit Gungnir qui lui, est connecté sur mon amplificateur McIntosh. On verra bien pour l’efficacité d’Audirvana en mode UPnP. Je dois avouer que j’ai une certaine crainte pour la suite des choses. Je trouverais malheureux de devoir me tourner vers un logiciel qui ne me pose aucun problème (Roon + HQPlayer) au détriment de la qualité sonore.

Bonjour @beajuju

Merci pour ce mot.

J’ai commencé la dématérialisation très tôt.
En 2010 j’ai passé tous mes disques sur un NAS (10 jours pendant une convalescence), c’était infernal. J’avais toujours un doute sur la solution NAS et PC/MAC directe. Je trouvais mon NAS de l’époque lent et je n’étais pas forcément totalement convaincu du son.

Vers 2011-2012 Apple fait plusieurs mises à jour de ses bornes (en particulier de l’Airport express), tu peux retrouver mon premier message sur HCFR qui fait état des “clics” qui apparaissent dans le flux Airplay. Je l’ai relu l’autre jour, peu y croyaient. Il a fallu donner une piste d’essai (track07), une montée de 20à20kHz pour que les gens se rendent compte que ça le faisait chez eux. J’ai aussi mis en ligne une video qui montre le phénomène. Et en discutant sur le forum (ça sert de discuter) j’ai fini par trouver après plein d’essais que la dernière version non buguée de la borne AExp était la 7.4.1

A l’époque le streamer à la mode c’était la Rosita Pi. Une borne Airport décortiquée et remise dans un châssis avec une bonne alimentation et une optimisation du flux “plein débit” (16/44,1 le max d’Airplay). On fait 2 choses. 1 supposer que l’évolution d’Airplay venait du fait que le flux passait de plus en plus de choses. Ce qui nous a fait nous intéresser à Airtunes1, protocole qui ne passait que du son. Il avait été décodé en reverse ingénierie. On le trouvait sous le nom RaopX avec une mécanique plein débit et un buffer. 2. considérer que la Rosita devait bien avoir le problème et c’était bien le cas car ils ont sorti un plugin pour son fonctionnement avec iTunes. Donc on avait le flux, le buffer, l’idée de porteuse et on remarquait directement que l’amélioration du son était conséquente. Un autre monde. Ca a donné un plugin.

Dans le même temps on a fait joujou avec le câblage interne du mac. Le CoreAudio. A l’époque on pouvait faire des choses dans l’interface MIDI. Il y avait Soundflower qui permettait un raccordement et Qjack. On a ainsi optimisé la sortie du mac pour passer outre le mixer. Comme le font toutes les applications un peu hifi aujourd’hui comme Audirvana. Mais tout ça est resté un peu de la bricole.

J’ai aussi essayé un petit plugin “bitperfect” sur mac. Ca marchait pas mal. Puis mon NAS a planté, j’ai perdu tous mes fichiers, tous mes disques sauf la version compressée… incompréhensible. Ca m’a énervé, je suis passé à Spotify et à Qobuz, ressortant les disques que j’avais envie d’écouter à l’occasion. J’avoue alors avoir passé plus de temps à écouter de la musique qu’à bidouiller, tant pis pour “l’idéal”.

Là je refais un essai avec Tidal. En fait je crois que tout ce marché “hifi” est une niche et que s’il doit un jour se généraliser c’est bien avec un format acceptable pour tout le monde, utilisable pour tout le monde. Le MQA pourrait-être celui-là. Sérieusement aujourd’hui un paquet de gens qui veulent de la haute résolution ne savent même pas ce qu’on peut faire avec du CD 16/44,1… On pouvait les jouer à l’époque avec de bons lecteurs, j’en ai encore 1 de ceux-là. Aujourd’hui… c’est presque un marché mort. Tout est devenu sec, pétillant, les gens veulent du micro détail, mais il n’y a plus de musique, plus de rythme… Rien qu’à voir la concurrence dans les DAC tu comprends le problème. Des vieux DAC qui savent jouer du 16/44,1 il y en a beaucoup plus que des DAC de course d’aujourd’hui qui sont des scalpels pénibles. Perso j’ai succombé à ça autrefois. J’ai eu Sony SACD ES, DAC qui upsamplaient et ça m’ennuie. Là j’ai un Mytek Brooklyn DAC+, je l’ai acheté sans même l’écouter parce que je connais par coeur son ainé le 192 DSD. Ce n’est pas lui qui va te faire la scène la plus large (démesurée), ce n’est pas lui qui va te montrer le point noir sur le nez du violoniste, mais il a le sens du rythme, il a de la matière, il est foot tapping, tu es au concert avec lui en comptant les mesures, pas en mode contemplatif. Pour moi il fait le job : il joue de la musique. Il est très rapide et doux. Il apporte de la densité à la scène sonore.

Une chromecast audio, une fibre optique et zou la musique.
Alors en confinement je me suis mis à rechercher le poil de c. qui manque et j’ai essayé la nouvelle version d’Audirvana. Et je dois dire que son interface est très correcte (pour mon besoin) et surtout ça fonctionne. Il y a tout ce qu’on avait bricolé à l’époque : le plein débit, le buffer, la connexion directe du mac. Franchement bien et un truc en plus : DLNA UPnP. Et là je dois dire que ça sonne mieux que le vieil Airplay. En plus on peut monter en débit, tester les MQA et autres DSD pour voir si vraiment c’est mieux que le CD (ça peut l’être, mais il faut que la musique reste).

Donc BubbleUPnP, déclaration de la Chromecast et Audirvana, et hop un nouveau pallier.

Après c’est normal de vouloir un lecteur plus généreux que la Chromecast. Et là j’ai halluciné : dans un marché complètement immature tout sort à n’importe quel prix avec des arguments totalement déconnants. Je ne veux d’aucune solution propriétaire, aucun “tuner” like. Je suis habitué à mon ordi et mon tel, ça me suffit, j’ai déjà trop de télécommandes. Donc 1 seul me paraissait intéressant : le SMSL DP3 avec sa prise AES/EBU et UPnP. Ce truc est une vraie daube en sortie de carton. Du crosstalk (volonté constructeur) insupportable. Incompréhensible… Quobuzissime, je me demande s’ils ont des oreilles. Bref, reçu depuis peu, je constate un problème de son et un petit passage sur les fora me montre qu’un russe a mis au point un firmware sans cette diaphonie insupportable. Avec ça il est complètement transparent dans le système. Incroyable pour le prix. Aucune différence en AES/EBU avec l’USB/Ordi (à flux équivalent). Sauf peut-être Audirvana… Et là j’ai des problèmes et je constate qu’un très grand nombre de DAC ont des problèmes.

Alors j’ai testé :

  • applications alternatives (c’est nul)
  • passage en OpenHome (incompatible avec Audirvana) et application LUMIN (mieux que Linn Kazoo). Déjà on gagne en ergonomie et je fais tourner Bubble sur mon NAS ou Mac.
  • Audirvana direct USB et UPNP et j’aime bien, mais ça ne fonctionne pas au top.

Donc à l’heure ou tout va se jouer dans un marché de niche. Où le MQA va peut-être prendre. Où ROON dégage l’UPnP pour créer son flux, on pourrait se dire que le champion du son Audirvana va jouer la seule carte possible de l’expert en DLNA/UPnP, mais non… c’est la faute du constructeur. Ca risque de ne pas durer, je ne comprends pas.

Ce n’est que du protocole. Il y a 2 choses qui leur posent problème :

  • la tempo pour démarrer le flux différé
  • un retour “à un moment” sur où en est le DMR.

Tous les topics de dysfonctionnement ont, je pense, à voir avec ces 2 choses.
Et je sais qu’on avait aussi nos problèmes sur le flux Airtunes. Mais c’est là qu’ils doivent devenir les plus forts.

Certains appareils ont des buffers. Ca doit-être difficile de savoir la différence de “où il en est dans la lecture” et “où il en est dans le remplissage du buffer” (et ce qui reste). Mais il y a des solutions je pense.

Le SMSL DP3 c’est un appareil de masse (qui fonctionne à mon avis aussi bien que n’importe quel autre streamer à n’importe quel prix), il doit y en avoir plus chez des clients potentiels que du Naim, du Linn ou du Lumin non ? Et je pense que le problème est exactement le même. Si le constructeur a loupé une implémentation DMR parce qu’il donne la priorité à son DMP il doit bien y avoir la parade.

Je leur souhaite du courage, car devenir le champion de l’UPnP c’est toucher un paquet de monde.
Sinon les gens retourneront chez Sonos, ou leur mp3 bluetooth.

Bon je retourne écouter sur Lumin, je ne suis pas au top, mais c’est pratique et j’attends, parce que je me suis un peu habitué à l’interface d’Audirvana pendant mon essai…

C’était 3615 my life, mais au milieu d’un monde de gratuit qui bouge, de bricoles toujours possibles, on a là une solution payante qu’on a envie d’acheter (c’est rare) mais que les idiots de constructeurs rendent non-compatible…

@Damien3

Si ça peut aider, voilà comment le SMSL DP3 fait sa publicité sur le réseau.
12 messages toutes les 20 secondes, cache des messages : 100 secondes
Il envoie bien son “alive” sa description, son adresse, ses commandes de contrôle, de renderer, de manager et de transport.

Je ne vois pas passer les réponses ou les demandes d’Audirvana.

1 Like

@Damien3 une chance que ça fonctionne un jour ?

Comme je vous l’ai expliqué après votre premier message ce n’est pas un problème venant d’Audirvana mais venant du DP3. Avez-vous la dernière version de firmware disponible pour votre DAC?

@Damien3

Bien sûr que j’ai la dernière version.
J’arrive à sortir tous les flux que je veux en UPnP sur cet appareil depuis toutes les applications ou serveurs, sans défaut, sauf Audirvana…

Du reste c’est presque le cas avec Audirvana. Ce qui pose problème, je vous l’ai dit, c’est le buffer. Le renderer démarre trop vite. A 3s de la lecture il y a comme un conflit de flux.

Mais je le répète aussi, il semble que vous avez des problèmes du genre avec beaucoup d’appareils si j’en lis ce forum. Il doit bien y avoir un truc chez Audirvana qui pose problème.

Que ce soit mon soucis au début de lecture de piste, le soucis d’autres vers la fin de la piste ou des arrêts, ça doit bien venir d’Audirvana.

Chez moi, ça enchaîne, Audirvana a le contrôle, je peux faire pause, reprendre, lancer un autre flux, ça fonctionne… sauf à moment. Mais quand on est en écoute et qu’on se prend un bruit blanc plein volume de 2/3s, ça fait mal…

Le retour d’information du DAC vous l’avez, je vous ai donné les éléments de ses envois “alive” avec son adressage de commandes sur le réseau toutes les 20s. La durée de vie de la commande, vous l’avez : 100s
Vous avez même la version de gmediarender 0.0.6 comme beaucoup de renderer sur le marché.

Là je ne sais pas quoi donner de plus.
Idées ?