Cannot add album to Audirvana library!

Hello! I’m using Audirvana 3.5.50 and I’m having difficulty adding an album to the library.
My library is on an external HD and I have many albums already, this is the first time I am having issues.

The album is called Audiophile Analog Collection Vol.2 (which is also the name of the folder)
There are 11 .dsf files in that folder, as well as a cover.jpg

I resynced the library, and did all the maintenance options, but I cannot find the album or the tracks in the library at all!

If I click on the track in finder, and open with audirvana, it plays without issue.
But for some reason, it won’t add to library.

Any suggestions?

How big are the files? If you’re on Windows and the files are bigger than 2GB, that’s the reason.

Sorry, forgot to mention, macos big sur.
each dsf file is between 500mb to 1gb
i’m trying to to see if I can convert dsf to another format (not flac) but not sure how to go about doing that

DSF should work. Check the filenames and the folder names for unusual punctuation.

We are of the same mind! I renamed each of the files
they were in the format 1_first_track_stereo256.dsf
I renamed them to 1. First Track.dsf thinking it may help

I’m wondering if they are actually proper .dsf fies though. When I run it from finder for example, audirvana plays them, but sometimes it will list the length as 00:01 , even though it plays for a minute or two…

For example, it lists this as 00:13 duration, but you can clearly see its over 10 minutes (from the slider on the bottom)

it is not the renaming of the tracks that count,
but the tags in Audirvana… you see there is no artist or album tags…
you can only find them by name now…

remove them, create a playlist empty and drag the songs in that playlist… select them all, put artist name and album in the tag window and save… now they will be at the right place… then, check them again for time…

Also, you see at the bottom right that the song is not playing as DSD but PCM 24/88

So I thought maybe the same thing. I tried editing the metadata, but then it said it could not save. (similar to trying to edit a .iso). I get the error message:
1 tracks have not been updated, probably due to a write permission issue

I created a new playlist, and tried adding those tracks to the playlist, but it would not add. I can add other tracks from different albums, but these don’t seem to want to be work.

I noticed that all the tracks have incorrect durations, even though they play correctly. I’m wondering if something went wrong in the conversion/creation of this album. I was hoping that converting DSF to another format would help, but I can’t find any way to do that aside from converting to FLAC which I don’t want to do.

The pcm 24/88 is because I don’t have my DAC on, and is just playing using the imac dac.

maybe they are lock in the finder… command i on one track to see if locked

Checked that as well.
It’s not that they don’t show up in audirvana as an album, they don’t show up even as individual tracks

.dsf can be tag, so maybe they are buggy, redownload one of them to see

Thanks RunHowSlow, that’s what I was afraid of. I don’t think redownloading would help, because all the tracks are like that. Probably whoever made them didn’t do it properly.
I guess the only way to proceed is to convert to FLAC, but that is what I was trying to avoid :frowning: