Cannot add network folder to library


I’m trying out your software but having tremendous difficulty adding a folder from my NAS (Synology) due to the simplified Windows form used. It will not accept that any folder clicked on is a folder and the OK buttons is always disabled.

The folder selection method needs to be improved and stands out as quick and dirty way of doing things in contrast to the general standard of the rest of the software. A manual entry method should also me available to get around any of Windows odd ideas of what make a valid folder or not. If Explorer can do it then the crippled standard folder form should, however that is not always the case, and using an out of date or buggly version of development library can cripple your software.

I’m guessing that’s the case here. RIghtly or wrongly. Probably the later.
A manual method should be able to bypass any issues like that.

Where does this software even install?
Is there a config file that be manually edited to get around this issue?

It sounds great but I can’t get to hear most of my audio library.

Just thinking, have you tried mapping the NAS with a good ol’ drive letter? Many times this old trick gets around such limitations and a bunch of other problems too. The command you’d be googling for would be “net use”.

On Macs, Audirvana uses a single SQLite database for everything. There’s a WATCHED_FOLDERS table; Might try messing with it directly, but it might be difficult to get the required device_uuid’s etc. just right. Not for the faint of heart.


Thanks for the reply. But yes it would be a get around and not ideal in my case.
Yes inserting records directly into the database is definitely a hack.

I think I will just wait until this software is more mature. The library management leaves a lot to be desired.

Hello @brianjaikens,

Can you post a screenshot of what you see when you want to add your Synology? We use the Synology assistant to setup our NAS and adding it to Audirvana worked flawlessly.

As requested

Screenshot 2020-12-17 105903

We need to see the root folder, not the folder you want to sync

Screenshot 2020-12-17 113307

Can you try to go in the Network section instead? You should see your NAS name in it.

It fails to populate anything in there.

You need to enable network sharing on the NAS and connect using the SMB/CIFS protocol.

I also use Synology NAS with Audirvana (on the Mac). It was trivially easy to connect.

Have you used the software made by Synology to do the setup of your NAS? It’s called Synology Assistant and can be found here:


All sharing protocols are enabled as suggested and have been since I got the NAS over a year ago.

I’ve had no problems using the NAS with any PC or mobile device on my network. Except for Audirvana’s browse form.

Thank you for helping.

If it’s setup properly then you should be able to add a network drive to be able to browse to your folder:

It’s unfortunate that a brilliant product like Audirvana (I used it in the past on a Mac and was blown away) relies on a infuriatingly incompetent company like Synology for a Windows solution. As a mostly Linux user, I’m used to finding software and hardware solutions online. So, if I can’t make heads and tail out of the circular, pointless Synology webpages (including the useless links posted by Damien3), you know you landed in the Windows nightmare. Come on Audirvana! You can do better than that! The problem described in this post is real and it’s up to you to solve it, instead of pointing us to this Synology crap! As the original post says - all other apps on my Window machine can see the networked folder just fine - for example, VLC - except Audirvana. It can’t be that difficult. You produced a brilliant Mac product. Now do the work to properly port it to Windows, please!

Useless? This is how Synology recommend to connect a Sinology NAS to your computer :slight_smile:

I have a very similar issue. WD Storage Drive running Twonky Server to create a DLNA Media Server. I can see the Media Server (under My PC) in the Add Folder routine but the OK button is greyed out so it can’t be added.

If I select the Network Option then no network drives are shown other than the local PC.

Right now a bit frustrated; software looks good but it’s useless if I can’t access my music library.

Environment: Windows 10 on PC

You need to add it as network drive and it will work

That worked - thanks.

1 Like