Cannot connect to Advance Acoustic WTX MicroStream

Hello everyone,
I’m new to the forum, just starting with an issue.

The Advance Acoustic WTX MicroStream Netzwerkplayer is supposed to process UPnP streams i.e. However, when it is on, I can select it as a streaming device on my iOS devices regardless of the wifi channel whether 2.4 GHz or 5 GHz. Which is fine.

I have also been able to connect from Windows in case the wifi channel is set to 2.4 GHz. In this case, Audirvana recognizes the device and offers it in the DAC list for streaming. I have been able to connect the WTX to 5 GHz and the DAC appears in the list when Windows wifi is on 5 GHz too. Now even from the Audirvana app I can remote access the WTX and stream nicely from where the PC is located. Nice too.

Unfortunately, the WTX connects to 2.4 GHz by default. Since iOS even connects to the WTX from 5 GHz while the WTX connects to 2.4 GHz, I’m hoping there is a chance to configure Windows to find the WTX regardles of the wifi channel selection. I’m having Fritz!Box 7590.

Hoping this is comprehensible and the streaming experts here have an idea on this.

You could configure your router to assign different ssid to 2.4GHz and 5.0GHz networks, this should solve the issue.

The ssid are actually different. However, I have about to repeaters within the mesh. If that makes a difference. I just the at this moment all devices are hooked to the same repeater on no effect if that would have been important.

Try to delete from your devices the 5.0GHz access, or change the pwd from the router.
It should be impossible for the devices to connect anymore to the 5.0GHz network

My assumption is that your networks are password protected …

Another hint could be to assign to the two network the same name.
My network allow this, I use Apple router and Apple access points, and I don’t care on which frequency my devices are connected as they work without any issue …

I’m sure having no plans to pass on the 5 GHz network as I’m doing more with the PC than streaming. The bandwidth on the 5 GHz network is highly appreciated. And sure are my networks password protected. The WTX device is password connected to the wifi too.

As I said, iOS can sort out the mix and connect to the WTX either way. Therefore, I assume a setting on Windows 10 solving the issue.

Well, I cannot try to help anymore as all my devices are from Apple … I “don’t like” Windows …

Never mind, I can’t leave Windows for some reasons. But, many thanks anyway.

Merge the networks, use the same SSID for both 2.4 and 5GHz.

Seemed to work in the first place. I had done: Network ssid separation removed on the router. Reconnect of the WTX and restart of the PC. Audirvana found the WTX and it could be selected for streaming.

Checking networks looks like that WTX and PC found themselves randomly or intentionally on 2.4 GHz. All other devices are on 5 GHz. Meaning, that the app lost connection to the host. Can’t find the PC for connect.
Unfortunately, this is not the solution.

You need to work on the router. It’s been a while since I last used FritzBox devices, so I don’t remember the settings by heart. You need to make sure that both bands behave like one network and you’ll be good.

Devices automatically select which band to choose, iOS devices typically preferring one with more bandwidth (which is 5GHz). The other devices that don’t support 802.11ac typically choose 2.4GHz band, even those that have dual band support.

Also try to restart the router.

Under Wireless -> Security options make sure “Allow wireless devices to communicate with each other” is ticked.

The encryption setting was set already. I think iOS was/is working with that.

I’m back to ssid and it seems to be fine for now. The WTX appears to be the one and only device on 2.4 GHz and things connect. Thanks a lot.

Feedback after two weeks. I couldn‘t connect the app in a solid way to Audirvana and stream to the WTX device across two bands.

As I had the idea to potentially create a special audio station on a small PC or so. I won‘t invest the time on such a project for now.
Thanks for help!