Cannot edit blank Year

I have over 1300 albums, all with complete metadata so they can be sorted by Album Artist and Year. MusicBee, MP3Tag, Volumio, Moode etc. can all read the Year. AS is missing the Year in many of my albums and when I edit the Release Date field within AS it does not save.

  1. Is Release Date the same field that every other software package calls Year?
  2. Only the year should be required. Not the month and day.
  3. Why is nothing being saved even when I complete the Year/Month/Day?

When you click an album and see the tag window… you see that release date, i don’t touch it except when Audirvana tag it with a bad date… MusicBrain :slight_smile:

Select all songs from that album,
then open the tag editor and there you can set the regular year…
hit return and save.

An example of what I am experiencing. Beatles’ Rubber Soul is not showing the Year when you click on the album. That header area is blank. When I selected all the tracks and edited the Year per your instructions, the year was correct (1965) in the editor. When I changed it to 1966, it sorted it after Revolver because I sort by Album Artist / Year. Then I put 1965 back and the sort order was proper. So the year is correct for the sort. But the Year doesn’t show in the header for many of my albums when they are individually selected.
So there is an issue with the Album Header data.

Can you send some screenshots of what you describe?

I cannot detect a pattern of why some show the Year and some don’t.



That date in the header, come from when you only click the album (no song selected)

You can put a label in the tag and write the date you want like 01-01-1965
like in my exemple i had a Label tag and a Release Date. i can remove the label after, but the date, i can’t and they will appear in the header.

When you have saved the editing, you have to click another album and come back to the one you changed to see the changes :slight_smile:

I truly appreciate the help. But it didn’t work. I edited the metadata, saved, choose another album, went back to Rubber Soul. No Year. I tried again, except resynced my library before going back to Rubber Soul. No change. Still not understanding why it won’t display the Year that is already in the metadata. All my music is local. No streaming.

Have you tried writing 01-01-1965 ?
i don’t have that little calendar on the right, you are on a PC ?

Do a right click in the title bar and add the year like my window… you’ll have the Year field :slight_smile:
you can move those columns where you when them after.

Thanks for that great tip. I am now getting the Year in all my Album’s track listings. But it still doesn’t show in the Album Header.

found a bug…
i add some Elvis tonight and found that for me too some release date didn’t work while editing tags…

but i found that clicking the album and entering 01-01-19xx, hit return and save
then choose another album or go back, it stick in the field… so just do the release date entering then leave that album :slight_smile:

I have done that numerous times with no success. The last several albums I added all show the Year properly. So I deleted Rubber Soul and Revolver, exited AS, copied the folders back, went into AS and it analyzed and synced, but with no different result. Year is in track listings, but not in the header.

I didn’t confirm earlier, but yes I am using a PC (W11 Pro).