Changes via MathAudio control window won’t stick :-( (Windows 11)

Hi there!

After leaving my current settings untouched for some weeks, I now have reason to do a little modification to the MathAudio Room-EQ control window, under »Processing«. I can edit, I can hear the results of those changes – but somehow my changes won’t stick. Maybe I am doing something wrong here.

So what is the recommended procedure to go about this?


Hi @Audi100,

Have you made those changes while playing a music?

1 Like

Hi, Antoine,

I tried both: Editing during Play, editing when on Pause. Same result.

Two more observations:

• After the last tune of a given album has been played and when Audirvana proceeds to the first tune of the next album, a »refresh« of the MathAudio control window can be watched, with any latest edits to the »reference frequency response line« lost :frowning:

• Interestingly, not all edit get lost that way: There are sliders for »RoomEQ gain« and »Stereo balance«, which edited values do very well stick.

Are you using the latest version of this EQ?

I do. 2.8.4.


Can you please take a screenshot of your plugin configuration so I can reproduce your issue?

Here’s the pre-edit setting:

After editing (heavy, for demo purpose):

After unwanted »refresh«. Notice, that edits of »RoomEQ gain« and »Stereo balance« are sticking:

Also, trying it via »Configure«: After saving, any recently done edits to the frequency curve are lost :frowning:

That’s a bug quite obviously.

No problems whatsoever with Audirvana 3.5

This is like some déjà vu phenomenon, as the same problem seems to have occurred before, at least once, about four years ago. It was based one some »data chunk« handling in connection with vst3 that Audirvana had not implemented at first.

Could you please see to quick solution, @Antoine? Thanks a lot.

Hi , Sergay from MathAudio reached out to us, we will see what we can do on this as soon as possible.

Sergey from MathAudio suggested me to un-install Audirvana / computer-reboot / re-install Audirvana.

That solved the problem :hugs: Great!

1 Like