Connection with internal Audio Devices Windows 10

Recently, Audirvana has not been able to play music with my internal audio device (Realtek ® Audio).
Windows 10 and the drivers are updated yesterday. Reinstalling Audirvana doesn’t help.
External audio divices are not affected. Other audio players have no playback problem.

Yours faithfully

Can you dump debug info here?

Hello @acin, what is the error message you get when you want to start a track in Audirvana using your internal audio device?

Hallo bitracer,

here the Debug Info:

Audirvana 3.5.39


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins ACTIVE in realtime mode
	VST3 plugin #0: C:\Program Files\Common Files\VST3\Ghz CanOpener Studio 3.vst3
		ClassID: 5653544353335867687A2063616E6F70
	VST3 plugin #1: C:\Program Files\Common Files\VST3\SatsonCS.vst3
		ClassID: 565354436E6573736174736F6E206373
	VST3 plugin #2: C:\Program Files\Common Files\VST3\Ghz Midside 3.vst3
		ClassID: 5653544D53335867687A206D69647369
	VST3 plugin #3: C:\Program Files\Common Files\VST3\Spectre.vst3
		ClassID: 56535453705472737065637472650000

SoX with device max frequency upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 17

Max allowed volume: 84.5266
Replay Gain: None
SW volume control: OFF

Sync list: 0 folders
Library database path: C:\Users\kette\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

Qobuz: Connected as Qobuz Hi-Fi Sublime+

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 13654MB

Local Audio Engine:WASAPI

Preferred device:
Model UID:iriver Ltd. AK380

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: 192kHz
Sample rate switching latency: 1s
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Lautsprecher/Kopfhörer (Realtek® Audio) Manufacturer:
Model UID:Lautsprecher/Kopfhörer (Realtek® Audio) UID:\?\SWD#MMDEVAPI#{}.{28715890-75e4-4d44-8950-2e215301c592}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

1 available sample rates up to 48000Hz
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 48kHz
2 ch Integer PCM 20bit little endian aligned high in 32bit chunk 48kHz
2 ch Integer PCM 24bit little endian aligned high in 32bit chunk 48kHz

Local devices found : 1
Device #0: Lautsprecher/Kopfhörer (Realtek® Audio) Manufacturer: Model UID: Lautsprecher/Kopfhörer (Realtek® Audio) UID: \?\SWD#MMDEVAPI#{}.{28715890-75e4-4d44-8950-2e215301c592}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

UPnP devices found : 0

First step is to disable the upsampling.

Also reinstall the audio drivers.

Hallo Damien3,

there is no error message. The player-bar seem just normal, the buffer is filling,but then it stops (time 00:00).

is done, no effect

doesn´t work either

It‘s weird that it shows only one sample rate supported.

Try to make the pre-loading buffer smaller. Experiment with 1024. 2048, 4092 MB.

Unfortunately no effect either

Hello @acin,

Can you check the firewall settings: In Settings > Update and Security > Windows Security > Firewall and Network Protection > Allow an application via a firewall, make sure that the file audirvanaplus.exe is allowed to access the network.

My firewall allows audirvana everything, so it is not the cause of the problem.

It looks like device driver issues to me. Are you sure you installed the correct driver?

Yes, other media-players are woking just fine.

Have you also tried to deactivate your audio plugins?

Do you mean the VST plug-ins, then yes …

Okay, can you check in your Windows 10 advanced sound settings if you have those two options enabled or not?

Yes, the settings are both checked. But after I removed both and cheked them again, the app works miraculously again.

Thank you for the effort.

Best regards