Controlling Playback though HID device

Hi all,

I have connected my Hegel H80 (amp/DAC) through USB with my iMac. The remote of my Hegel follows standard HID(Human Interface Device) protocol. With this remote I can play/pause and skip songs - directly through my Hegel - playing in iTunes or TIDAL desktop on my computer, but I can only pause/play when Audirvana (2.6.4) is used as player. In preferences all remote control options are activated. Any members experiencing the same problems?

I suspect that either iTunes or Tidal failed to relinquish control of the IR remote. Try restarting the computer, do not launch iTunes or Tidal, and then see whether Audirvana responds to all the remote commands.

(FYI, an infrared remote is not an HID device. What you mean is that Hegel’s IR remote transmits the same command codes as the Apple IR remote, i.e., they are interchangeable.)

Tried your suggestion, but no results. By the way my Hegel remote is not interchangeable with an Apple remote. I repeat that: The “Computer” commands on the Hegel RC8 remote are standard HID. This was confirmed by Hegel. So I guess the Hegel remote can’t be an IR remote. Any other suggestions?


Nobody experience with Audirvana and a DAC with the USB HID functionality?
Damien, could this link help you to solve my problem? Thanks for an answer.

Hi Peter
I am also having the same problem as you.
I have a Hegel h90 connected to a mac mini with high sierra & audirvana, via usb.
Hegel remote RC10 controls only play/pause.

lately I had 3 months trial with roon.
that software was working ok with the hegel remote, meaning play+pause+next+previous worked ok.
So it must be either a conflict or a setting with audirvana that prevents the full control.

Probably you did not notice, but Peter wrote that 7 years ago :wink:

oh yes :slight_smile: but the problem still persists.
I found a solution though.
on another forum someone suggested BetterTouchTool to “record” hegel remote commands.
here is the link for that thread:

That was a response from me. At the time I hoped this would be a temporary fix until it was resolved by the Dev team.

As far as I know they never resolved it. The Hegel remote also worked for me for all other software, except Audirvana.

And by capturing the remote with ‘bettertouch’ and linking a script to it that gives a ‘next’ command to Audirvana, it just works.

This is not necessary with other software.

We would really like this to work, but it will require Hegel to look for the issue on their side, and for the time being, we never had a response from them in this manner. I will send them an email again.