Cracks in sound with VST plugins

Hey, i use Tidal lossless and it works perfect. Until I acitvate VST, then it starts cracking and I get noises which arent supposed to be there.

Its not because of the plugins, its Audirvana whats causing this. I tried multiple plugins and I also get the cracking if I just activate VST without selecting one in the drop down menu.
Also its not depending on the EQ setting.

Upsampling is deactivated, but doesnt chang if I activate it.

Anybody knows how to fix that?

Audirvana Studio 3.5.51 (2051)

Windows 10 (19043) with 32GB physical RAM


Polarity Inversion:
	Globally: ON
	Per track: OFF
Effects plugins NOT ACTIVE

SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
AUTO: C:\Users\baroc\Music
Library database path: C:\Users\baroc\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 15530MB

Local Audio Engine:WASAPI

Preferred device:
Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter)
Model UID:Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter)

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter) Manufacturer:
Model UID:Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter) UID:\?\SWD#MMDEVAPI#{}.{5aa46e4f-9c12-4450-ae2b-b8480547680b}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

2 available sample rates up to 48000Hz
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 16bit little endian 48kHz
2 ch Integer PCM 24bit little endian 48kHz

Local devices found : 6
Device #0: Digital Audio (S/PDIF) (High Definition Audio Device) Manufacturer: Model UID: Digital Audio (S/PDIF) (High Definition Audio Device) UID: \?\SWD#MMDEVAPI#{}.{3b411db8-a8d7-463e-8756-14207b73c79b}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #1: Mi Monitor (NVIDIA High Definition Audio) Manufacturer: Model UID: Mi Monitor (NVIDIA High Definition Audio) UID: \?\SWD#MMDEVAPI#{}.{0f086469-143e-4fc3-bc91-1f07f903e4f1}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #2: LG TV SSCR (NVIDIA High Definition Audio) Manufacturer: Model UID: LG TV SSCR (NVIDIA High Definition Audio) UID: \?\SWD#MMDEVAPI#{}.{25c64748-32de-4806-858e-cf417d9270e7}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #3: Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter) Manufacturer: Model UID: Kopfhörer (USB-C to 3.5mm Headphone Jack Adapter) UID: \?\SWD#MMDEVAPI#{}.{5aa46e4f-9c12-4450-ae2b-b8480547680b}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #4: Lautsprecher (XSplit Stream Audio Renderer) Manufacturer: Model UID: Lautsprecher (XSplit Stream Audio Renderer) UID: \?\SWD#MMDEVAPI#{}.{62e12c01-c30b-4c42-83d9-f8f285168745}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #5: Speakers (NVIDIA Broadcast) Manufacturer: Model UID: Speakers (NVIDIA Broadcast) UID: \?\SWD#MMDEVAPI#{}.{cfe46840-fc67-4274-a070-2d03223b524b}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

UPnP devices found : 1
Device #0[LG] webOS TV UN73006LC UID: uuid:27458997-f69c-73e0-db23-aea2b05fe4e0 Location:

Than you!

I just dubble checked and I have the same issue on my second PC aswell! Very weird. So its a software problem definetely

Its also not only with Tidal, I just checked if I play local files I get the same problem.

Found the solution! I lowered the out gain of the EQ and lowered the boost in audirvana from the default 6db to 0.

Now no more cracking just pure perfect sound!

1 Like

Perhaps now less useful information. Be careful with the gain stages in DSP. If a track is already at the limit, any change can cause clipping. An EQ with negative value and a steep slope also gives a small boost to the tilt frequency. Clipping gives distortion at the frequency that you boost but also harmonics due to the square waves you create. Decrease your in or out gain at least as much as your boost. Play some of the loudest tracks you can find. With a lot of low frequency energy in it. If no clipping occurs then you are safe to listen to music undisturbed afterwards.

1 Like

Hey Jacob, thank you very much, very valuable and logical information, makes sense but I didn’t think about it.

It’s only a temporary solution for my headphone setup. I’m having a cold and maybe you know that feeling, if your nose and everything is closed you almost hear no bass. So I need to compensate temporarily :).

Have a nice day!

1 Like

Ok, thank you . I’m not losing my mind. I’m hearing these “crackles” with regular streaming now; from any source and any mode; Kernel, ASIO, or WASAPI. We’re in a deep freeze here so at first I thought it was my daughter’s space heater. But she turned it off and still exists. I’ve tried other input sources and audio players and don’t hear it; I’m 99% convinced it’s coming form Audirvana. And it only happens when music is playing and seems to get worse when the music being played is busy or intense. This is a deal breaker; I have a very resolving system and cannot tolerate this. Is this a known problem being worked I hope?

Knocking these back a little seems to have fixed it; or at least made it much better.

Can you share the Debug info here?

I see you are upsampling and have the volume control turned on. (the left two in the picture)

Does the cracking go away if you disable both? If you turn them back on 1 by 1, when will it come back?

If you use a negative gain before applying upsampling, does it go away?
To test this you can apply a simple gain in the DSP bus and reduce it by 3 dB.
Download link:

I’m not sure if you were intending your reply for me or gabelrocker. Either way I have been doing quite a bit of experimenting and no doubt the cracks are related to the level of oversampling. I’ve eliminated volume controls and algorithm type. At no oversampling or x2, no cracks, at x4 oversampling some, and beyond x4 it’s unlistenable to me. If I use another music player with the same level of oversampling, or use the DAC’s built in oversampling with a different input I don’t hear the cracks so it’s not the DAC, I’m convinced it’s an Audirvana artifact. For now I’ll limit oversampling to x2 and hope a fix is in the works. This is a great forum; thank you.

I expect that if you reduce a 3dB gain before the oversampling you can go to x4 or x8 without any problems. If not then it is not clipping but a different kind of crackling.

After all of this the cracks came back so I was he** bent on figuring it out. It appears to be coming from the USB bus on the PC. I have an iFi Stream I use on a second system. I hooked that up as a bridge device between Audirvana and my main DAC and I can oversample to my hearts content and don’t hear any cracks at all. The USB driver on the PC is the one Cary shipped with my DAC I believe. I’ll see if I can go back to a native Microsoft driver and see if that helps. Anyway, I rescind everything I said relative to Audirvana. In my case anyway this appears to be a PC problem. Thanks again for your help Jacob.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.