Crashes after change of audio process settings on M1 Max wolved with the 14.2 MacOS update

Tried to find a similar report before posting this, but have not found anything.

I’m running Audirvana Studio 2.6.2 (20602) on an M1 Max MacBookPro with macOS 14.1.2. Using an external USB-C dongle DAC as output device. Trying to make sense of the various upsampling and process settings and trialing sound quality differences.

The Audirvana Studio app seems highly unstable when switching settings and often crashes upon even a single change. Sometimes it immediately disappears upon saving settings, sometimes the app crashes upon buffering of the first played track. When crashing, pref’s seemed not to be saved: the previous last song and the previous settings are presented when restarted.

Exclusive and Integer Mode = on
Audio buffer size = max
Max. I/O Buffer size = on
SysOptimizer = on

No signal processing
No volume levelling
No volume control
No sample rate limit

Qobuz connected
Last.fm connected
Apple Music synchronizing
Local files synchronizing

Not including the used settings for upsampling, since I have been trying SoX and r8brain with various settings (off, 2x, max, etc.) Point is that when changing these settings specifically, crashes occur.

I am giving Audirvana time to switch on/off exclusive mode. I am frequently quitting the app to save pref’s prior to playing a track, as to prevent settings to get lost when crashing.

Before starting a test, I check with Audio Midi Setup app whether devices are present and/or locked. I use a CPU/Memory meter and I can see that Audirvana never maxes out.

I can’t reproduce the exact issue with a fixed path of clicks or interactions. In some cases, I can click around and nothing happens, at other moments I run into crashes repeatedly. I have now installed the Audirvana helper needed for system optimization and, knock on wood, it seems to run more stable.

My question: is this a known issue?

Hi @rolandb,

Can you send us the crash report generated when you reproduce your issue at support@audirvana.com?

Sure, I will do that. Would you like me to send both the Studio debug info, as well as the crash log that Apple generates?

FYI:

This is what the most recent crash log stated.

Thread 77 Crashed:: com.apple.audio.IOThread.client
0   libsystem_platform.dylib      	       0x188d873ec _platform_memset + 108
1   Audirvana Studio              	       0x102dc8fd4 0x102abc000 + 3198932
2   CoreAudio                     	       0x18b57d19c HALC_ProxyIOContext::IOWorkLoop() + 9244
3   CoreAudio                     	       0x18b57a650 invocation function for block in HALC_ProxyIOContext::HALC_ProxyIOContext(unsigned int, unsigned int) + 108
4   CoreAudio                     	       0x18b6f893c HALC_IOThread::Entry(void*) + 88
5   libsystem_pthread.dylib       	       0x188d59034 _pthread_start + 136
6   libsystem_pthread.dylib       	       0x188d53e3c thread_start + 8


Thread 77 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000000   x1: 0x0000000000000000   x2: 0x0000000000001000   x3: 0x0000000000000000
    x4: 0x0000600003f4f500   x5: 0x000000012f2ac0e0   x6: 0x000000013c29a818   x7: 0x0000000000000000
    x8: 0x0000000000000000   x9: 0x0000600003f4f500  x10: 0x0000000000000008  x11: 0x0000000000000002
   x12: 0x000000000000000a  x13: 0x0080002000080001  x14: 0x0080002000083001  x15: 0x0000000000000000
   x16: 0x0000000188d87320  x17: 0x00000001e7ef5588  x18: 0x0000000000000000  x19: 0x000000013c29a818
   x20: 0x0000600003f4f50c  x21: 0x0000600003f4f510  x22: 0x000000013c892948  x23: 0x0000600001c39ae0
   x24: 0x000000013c892810  x25: 0x0000600001c39ae0  x26: 0x0000000000000000  x27: 0x000000000003593b
   x28: 0x000000013c892920   fp: 0x000000016f49ad30   lr: 0x0000000102dc8fd4
    sp: 0x000000016f49acc0   pc: 0x0000000188d873ec cpsr: 0x80001000
   far: 0x0000000000000000  esr: 0x92000046 (Data Abort) byte write Translation fault

Yes, please send the whole crash report and debug info so we have more information about your setup.

Mail sent. I’ve added both the debug info and the crash log. I also added a couple of earlier crash logs for comparison sake.

Wow. Impressive. Quick support and very fast resolution as well! Thank you.

Not sure whether this was an issue with previous versions or something on my end, but the suggested update of the OS seems to have solved it. Been switching continuously between settings and not once has the app crashed so far.

1 Like