Dirac calibration using UPnP

Hello @Antoine ,
Did you succeed to reproduce yesterday ?
By the way in parallel I bought a device to access my HIFI device through USB this time : same error message than with Upnp.
Dirac calibration with Audirvana Studio on Mac seems not to work at all.

This has always worked. Did you play a track during the measurement? The Plug-in must be active in real time from Audirvana and then during playback you allow DIRAC to connect.

What I find easier is to activate the ‘systemwide’ standalone DIRAC. Take the measurement with that and when you are done, load the configuration into Audirvana’s DIRAC.

Hi @Jacob ,
Thanks for your help.
I sat the real time toggle on and off . I played a track while calibrating and not . I chose wide imaging and all combination of these options . Each time I got the same error message (as described above) either during stereo volume calibration or measuring.
It’s as if the Dirac Live process did not succeed to access the Dirac plugin in AS to set volume or play a calibration sound ( I could be wrong, this is what I feel). For UPNP and USB.

Have you tried it with the standalone DIRAC unit? If this does not work either, the problem is not with the Audirvana software.

If you do it in Audirvana then the DSP must be in real time. (which is only possible via USB) A track must be playing and it must continue to play during the measurement. If it stops or a track with a different sample rate starts, you will lose the connection again.

1 Like

I tried with the standalone Dirac unit : it works ( I succeeded with the first measure) using USB.
So it does not work with AS using Dirac plugin and USB and this is what is needed to calibrate my HIFI devices if i want to use both AS and Dirac.
Please @Antoine can you reproduce on your side ?

I will do the test tomorrow, couldn’t do it today.

Lately I always calibrated in the standalone unit and then opened the file in Audirvana. This is much more user-friendly than having to pay attention to whether a track is playing and whether it has been accidentally stopped.

But it has always worked well in 3.5 and studio. I don’t know if there are any recent updates that have changed this.

So , thanks one more time @Jacob , I used your by-pass : I calibrated in the Dirac standalone unit and I succeeded in opening the calibration file in AS : it works when I play in AS when I keep the USB connection, unfortunatly it does not work with UPnP.

I do not know if it is a bug or if it is as designed by Audirvana.

I don’t use Audirvana anymore, but if I’m not mistaken, you can edit the settings when the player is stopped. Then save this. And if you then deactivate real-time and play via UPnP, it should work.

The behavior of plug-ins when employing UPnP was previously described in this thread…

From what I hear (because we cannot see what happens because “real time control” is disabled) the correction using UPnP seems NOT to be applied. I will work on this this week to confirm.

Also the fact that the calibration in AS as well as the play back with room compensation are not working with UPnP is it by-design (Audirvana has decided not to support) or is it a bug (Audirvana supports it and it does not work) ?

I may not be interpreting this correctly, however, from what I am able to discern from this UPnP white-paper, ‘device management’ is not a universal aspect of the protocol and it seems the device(s) must support this functionality, which would be unique to each device as these would have different assigned parameters for remote management/adjustment… If this is the case, where each device would have a uniquely different set of parametric adjustments, I can see where it is impractical to provide support for more unknown operating system(s) functions.


For device control my feeling MIDI 2.0 protocol is most appropriate:

To summarize the results of my tests:

  • calibration from within AS 2.6.0, MacOs 12.7.1
    - with USB : KO
    - with UpnP: KO
  • play in AS with calibration file computed from Dirac standalone app
    - with USB : OK
    - with UPnP: it seems the correction is not applied . to be confirmed

Hi @Alain1,

When you say KO for USB, do you see the plugin like this or not at all?

Yes @Antoine, this is what I see (cf photo below).


Then I click on calibrate, , dirac live starts, I choose the processor (only one is displayed), then I choose the mic , then I start Volume calibration . first problem here : when I select one speaker an error message is fired (cf photo below)

I can go on the next screen to choose a listening configuration and then I go to the measurment screen. second problem here , when I measue a point an error message is fired (cf photo below)

Hi @Alain1,

Then, in that case, you need to ask Dirac about it. You mentioned that the Dirac software itself can’t control the Dirac Live Processor.

In Audirvāna Studio, the plugin is displayed and seems to work, If the issue is really on our end, then Dirac will send us an email regarding this.

Hi @Antoine ,
I am avery confused with your answer:

  • I thought you had a partnership with Dirac , didn’t you ?
  • I altough thought that at least you could check that you didn’t receive correct orders from Dirac Live process in order to confirm that the problem in on their side
    - finally this is the second time I am locked between Audirvana and a third party, as a customer understand that it is not my role to follow up bugs between software providers. I am disappointed…

Yes, and they do have access to our software to reproduce if an issue like this comes up. Please contact them and put support@audirvana.com in the loop so we can keep in touch regarding this issue.

Mail sent to Audirvana support and Dirac helpdesk. Please follow up.

1 Like

I saw the mail, hope they will come back soon regarding it.