Dirac Live VST3 Plugin not working

Hi ,
I am trying to see if I could get the Dirac Live VST3 Plugin working.
While the processor start up ok.
And I was able to get the Dirac to recognise Audirvana.
However, I am unable to get Dirac Live to play any sound to Audirvana for measurement.
Every time I press play sound , an error message " Error during measurement (Device internal error) " pop up.

Can someone tell me what I am doing wrong?
I have tried turning on Realtime control, and it’s not helping.


Hi Damien,

Would appreciate your help on this.

It seems to be the Dirac Live issue with the VST.
As I tried other plugin hosts, and it all had the same results.

Do you have any other VST3 Room Correction recommendation that will work with Audirvana?

Hello @delphi17,

Can you make a screenshot of Dirac Live while you have this error?


Dirac and Audirvana seem to interact strangely in fact.

I had the same problem. My solutions consisted to run a third software (Reaper DAW) to do the measurements/test sounds and to configure the Dirac plug-in. Once this is saved within the Dirac plug-in, I could run it smoothly within Audirvana.

Just to add another problem with Dirac Plug-in here:
The plug-in worked like a charme for weeks and since yesterday, the plug-in doesn’t launch anymore automatically when playing a song. Actually, the song doesn’t start at all, which I found out is related to the Dirac plug-in not starting automatically anymore (out of a sudden). Now I have to launch the plug-in within Audirvana (configuration button) and save it again each time, then it works until the next song/album/playlist.

I don’t know where the problems are, but I wish that the integration of Audirvana and Dirac would work better, as I think that the possibility to integrate such plug-ins is a real plus for Audirvana and Dirac Live Studio is such a benefit add-on to it.

Looking forward to the evolution of this integration.

Thanks Damien :slight_smile:

1 Like

Hello @Damien3 ,

I believe I have found the reason for the problem I was facing.
The plugin will not work when the selected music is on Tidal Master MQA.

When I change the played music to a standard Flac , the Audio Unit plugin behaved properly.
Is this because the first unfolding of MQA is causing issues with Dirac Live?

Thank you

1 Like


I think the fact the Roon would not work with VST3 or AU gives Audirvana a huge advantage in this field.
Audirvana already has the best sound, if and when the integration with Dirac Live can be even better.
It would be a unstoppable combination for streaming audiophiles.


@delphi17. It works. I had use it with the same difficulties as you at the begining.
you have to look to : https://live.dirac.com/processor-step-by-step/

install VST3 processor module, after that you must find it on the vst3 audirvana plugin menu.
I think you have also to select real time configuration for the dirac plugin.

But the most importatnt thing is that you have to start to read some music BEFORE you launched the dirac calibration tools. Then you will see dirac processor detected, after that it’s easy.

@delphi17 of couse read music with audirvana. After that the calibration tool interrupt the music as necessary for the room test through audirvana player.

Hi Didier22,

Thank you for the reply…
Yeah I did get it to work as stated on my previous reply…
The MQA was what was causing the issue.
As long as I did not select MQA as my file while using Dirac live.
Dirac only works with PCM, so MQA is out of question unforturnately.


Question to Audirvana community - I have the perception that the Dirac plugin takes a few seconds to read the file, so within the first 5 seconds of a track, the (unmodified) sound plays, then the EQ sound is played from there on. Not such a big deal with an album, but annoying if you go track to track where (it sounds like) the EQ is changed for each track. Observations? Conclusions?

Hello @Antoine
I face the same issue as @delphi17 but MQA is not the cause.
I have set the Dirac AU plugin in Audirvana, I play a track, launch Dirac live and Dirac live recognizes the plugin. All fine.
However when I want to play the calibration sound, the initial track keeps playing, instead of being interrupted by the calibration sound. Also, the master volume slider has no effect. And then an error message " Error during measurement (Device internal error) " pops up.
Probably important: Audivarna plays through upnp to my active speakers (Cabasse Akoya Pearl).
(all concerned soft are at the latest revision)
Any idea ?

Same problem here : I can’t play the calibration sound to left or right speaker. Same error message.