Disable flac to pcm conversion

In some cases like my for example , the flac to pcm conversion is better inside my streamer that from audirvana.
The audio quality of my streamer its better if i use the streamer own app without any conversion built in.
Dear Audirvana develop team, is possible on the next versions make something for disabile / enable the inside conversion ?
Thanks at all

You have this feature already.

If i disable the oversampling and play a song with audirvana studio, in the streamer app i read pcm data in and not original flac file
Studio make some conversion and the quality is not the same

If you’re streaming using UPnP there is a switch to send raw PCM or uncompressed file.

Thanks a out your answer but you say disable raw…. ?
I have try but always wav file i read on own streamer app.
Is not the original flac stream

Don’t know, but it’s what it does.

I would think that a lossless format couldn’t be decoded better or worse. Maybe the streamer internally handles the different data streams differently.
For example, that the file ends up in a different buffer with a different clock.

The advantage of Audirvana is that everything is decoded to the same wav/raw pcm format. And in this format offers the possibility to upsample or add DSP. (Edit: Or DSD format)

If you don’t need all that and your streamer sounds better if it loads the file itself from a location, the question is whether you should use Audirvana. Or is that a weird question?


Dear Jacob, thank you for your response. I’ll explain. my streamer is connected via upnp and if i use its proprietary app i read that the listening file is for example flac 24 bits 88.2 khz.
The same stream through audirvana comes to my player as wav 24 bits 88.2 khz.
Surely the transcoding adds something because to the listening some difference exists and is perceptible. My question: Aurdivana can send the original flac stream? Thank you.

Audirvāna Studio is already sending the original flac stream, it’s just encapsulated in wav so nothing is altered during the transport of your your track to your streamer.

What streamer are you using?

Antoine my stream is Naim ND555.
If you say that don’t change nothing, but is only an encapsulated i dont know why there is a little bit difference when i listen the same audio stream.
must change something in my setting ?


Can you send us a copy of the “Debug Info” when you have this issue? You can get it in Audirvana Settings>My account

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Antoine, i can do it this evening because the pc is not the same where i write to you now.
Its a mac book air m1 with only the audirvana studio installed.
I reply with the debug info this night.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.