DSD playback quality

Hi there, I am new to Audirvana but like it a lot, using it mainly to playback my vinyl recordings to dsd128 files. Question; does Audirvana change or enhance the sound I get from playing these dsd files e g in Foobar2000, and if so, in what ways?
thanks, Oystein

Only you can answer that question because this is highly subjective. Just compare Foobar2000 to Audirvana and judge for yourself.

If you play your tracks and you don’t use DSP (digital signal processing) (also disabling the volume control in Foobar and Audirvana), there should be no difference (in theory), because both should not alter the source (or add something) in that case. Audirvana and Foobar will then pass the bits ‘as is’ (‘bit perfect’) to your soundcard/DAC.

If you use upsampling or other forms of DSP in Audirvana or Foobar the sound will change. Then it simply depends on what you like the most, because, as said, this is highly subjective. Just follow your own taste.

All I can say is that both are excellent programs and I use them both on a regular basis. Both have very good sound quality and both have very different user interfaces. By the way, I am speaking from the perspective of a Windows user.

Edit: I forgot you are talking about DSD. If you play DSD files (from a hard drive?) directly via both Foobar or Audirvana both programs can not change or enhance the sound in any way even if they wanted to. Digital signal processing can only be done in the PCM (16, 24, 32 bits) domain and not in the (1 bit) DSD domain.

Thank you! Oystein

Hi again Andy
Some more info. I am using A Origin in order to play ca 250 LPs, the ‘best of’ in my 2000 LPs collection, that I have recorded to DSD128 files with the Tascam DA-3000 recorder. Although streaming quality has advanced (I pay for the best level in Qobuz), I still often like my vinyl rips better, and the DSD format plays a big role here. So Audirvana’s effortless direct / pure / native playback of DSD is not just a big bonus for me, it is in fact the main reason I bought it. I use external hard drives connected to my home network, through a Thinkpad T14 (2022). A small Topping e30ii DAC is DSD-ready and accepts my files fine. In Audirvana. Not through Foobar, however. I have recorded LPs in both .dff and .dsf variants of DSD. Audirvana plays both with no problem, but Foobar insists in going back to pcm conversion for the .dff files. Have not found out why.
Comparing the same .dsf files played in both Audirvana and Foobar, I sometimes think A is better than F. Other times, that this is just my “audiophile imagination”. Not sure, the difference is subtle. Could it be, that A is better on buffering the file input? Slightly more volume? What is clear is that when A starts, playing DSD, there is a click in my speakers. It feels like A takes a more total control of Windows.

There can be many variables in your perception (some of them you already mentioned yourself):

  • Is the volume exactly the same?
  • You can vary the buffer length in F in different places (also in the advanced section). Also you can vary the buffer length in Audirvana.
  • F should take total control of your soundcard/DAC (just as A) as well if you use exclusive output.
  • Are you using the same output in F and A (ASIO, WASAPI?).
  • Are you playing native DSD through your DAC with F?

I use a Topping D90 DAC (AKM version) and have a Topping E30 as well. Both accept DSD fine in A and F. You do know that for playing SACD/DSD files you need a plugin in Foobar? (Foo_input_sacd). It takes some settings. Click the link below:

Super Audio CD Decoder - Browse /foo_input_sacd at SourceForge.net

If you installed the plugin in F you see these settings:

Also make sure you set your output in foobar to exclusive:

I don’t want to derail this thread to a Foobar thread, but with the above settings your Topping E30 should have no trouble at all to play DSD (up to DSD256) with Foobar2000.

Thanks a lot. I think that Foobar2000 is such a good companion to Audirvana that discussion is relevant. With F I can quickly test-play a file, before adding to the A library, I can sort files in Windows Explorer, etc. Very useful for me, although I turn to A for longer time listening.
I had the SACD component already, but turned on the Dop for converter. And set the output to my DAC. I tried “speakers - 5 topping usb dac”, and then “ASIO+DSD: Topping USB device”.
Result - like before. My .dff files only play back through pcm conversion, not direct.

With ASIO output you should not need DoP. That is only for WASAPI (standard Windows output in this case). What do you see on the display of your E30: DSD or PCM?

My suggestion in your case is:

  • Turn DoP on in your SACD settings in F
  • Don’t try the ASIO, but the standard ‘exclusive’ output in F (which is basically WASAPI).
  • Also the SACD plugin can be a little buggy. Do you have ‘DSD processor’ on in the plugin?

Another thing:

If you want to go the ASIO route:

The ASIO+DSD plugin you have is buggy. Go to the official Foobar site and install the Foobar ASIO plugin written by Peter (Foobar developer) himself.
Link: foobar2000: Components Repository - ASIO Output

Install that and set the output in Foobar to ASIO. In that case turn ‘DoP’ off in the SACD settings.

Of course I assume that you have the official Topping ASIO driver installed on your computer:
Link: V5.62 driver for most of TOPPING DACs-TOPPING (tpdz.net)

With the Foobar ASIO plugin your setting should look like this:

In my case the Toppings (D90 and E30) play DSD perfectly when I play through ASIO or WASAPI in Foobar. It should work. F is far more fidly than A, but when it works it works.

Thanks a lot, this is really helpful.
I will go through the points and report back.
For now: the Topping e30ii display is correct. That is, it displays “5,6 mhz dsd” when I play my .dsf files, and “192 pcm” when I play .dff files. Which is exactly what I hear. The volume control is turned off with .dsf playback, while it is on with the .dff in pcm mode. As expected.

I reinstalled the Asio driver from Peter, and then, the Topping 5.62 driver. So far, no help.
Maybe the reason is that I cannot find any output device named “exclusive” at the end. I have Topping speakers, Asio Topping, and Asio + DSD Topping. So, whatever I do, F insists that my .dff files should be played back as pcm. While A does it correctly.

How does F insists that? Do you have a screenshot? If you haver the correct plugins installed F should play dsf and dff files natively. The comparison between A and F in your case is not ‘fair’ because your hear PCM via F and DSD via A.

To avoid confusion, there are 2 different routes to go here. ‘Exclusive mode’ only needs to be used when you use the ‘default’ Windows output in Foobar. When you use ASIO the exclusive mode is irrelevant.

I assume that you also installed the Foo_input_SACD correctly. It is actually 2 components.
‘DSD processor’ and ‘Super Audio CD Decoder’:

The best way to go in this case is ASIO, because that is capable of sending ‘raw’ DSD to your DAC.

Here step by step checklist of the Foobar settings with ASIO and my Topping DAC.

  • in Foobar settings/output set output to ASIO:

  • Check in Foobar with the ASIO settings that your Topping Driver is displayed. You can also double click on the Topping driver to change its settings but that should not be necessary

  • Check in Foobar in the SACD settings that you have the settings as below:

This is exactly how I have my settings and that works flawlessly with the Topping E30 and the Topping D90 in my case.

What version of Foobar do you have? I use Foobar V2 (64 bit). Also make sure you have the most recent version of Foo_input_SACD.

After doing all of the above it can also be useful to rescan your library in Foobar (then it will update the DSD/DSF/DFF files as well in your library). Right click on you library entry and ‘click rescan.’

If all of the above does not work in your case I will eat my hat :wink:. You must have forgotten a tiny step somewhere…

Got it! It works! You don’t have to eat your hat ; - )
I forgot the old rule; Look for the most obvious first.
I was running F v 1.6.4! Upgraded to v 2. Installed the newest version of the DSD processor and the SACD. Restarted the Topping DAC.
Now, the DAC and F both display the correct DSD resolution, and play .dff as well as .dsf files fine.
Your patience and help have been outstanding! I wish you a great weekend!


I mistakenly believed that Preferences / Components / Get updates would update the program as well. Wrong. Its in the Help menu.