[FIXED!] Audirvana hangs with Mac OSX 10.11.5 Public Beta (15F24b)

I am seeing a couple of pretty persistent bugs in 2.5. The first is simply starting up the app. It’s taking about a minute to load at the moment. I have a fairly large library - 981 albums apparently - but I did not have these problems with the last version of A+2. Seems to be worse on the first start up. I’m thinking maybe the database is corrupt?

The other is that I can’t seem to get an album to play by clicking the cover. A+2 just shows a “loading first track” message. I see this consistently, actually. I can only get an album to play by using the controls at the top of the app or my keyboard.

This is on a 2011 15" MBP, 2.5 i7, 16GB RAM, running OS 10.11.4. All of the music A+2 accesses is on a second internal hard drive (drive put in where the optical drive used to be) and it does not share with iTunes. I do not use any music streaming services.

EDIT: Ooops. See post above mine. Forgot that I’m on the beta channel.

Just upgraded to the latest Mac OSX 10.11.5 Public Beta (15F24b) and noted that Audirvana 2.5 hangs in either iTunes Integration mode or as standalone when trying to load a track ("loading first track).

Understand that the use of beta software has its risks but wanted to make all aware and something you may want to check into on the development side.

Yes, this is true. See my post below. Don’t know why but I can’t get A+2 to work at all now.

Hopefully Apple will fix this bug in the next beta of 10.11.5…
I’ll check this upon my return next week (currently travelling with only a poor 3G connection…)


Same problem here. But there’s a kind of workaround:

Point on the folder with the music you want to hear in the itunes library and move it to the desktop. Remove the sync with your itunes library and add the folder on the desktop.

True, it’s very uncomfortable but it works for me.

Just installed the newest public beta that was released yesterday 10.11.5 Beta (15F28b) and same. When trying to play in iTunes Integration Mode hangs when trying to load a track (“Loading first track”).

Wondering if this may have something to do with A+2 - v2.5? In thinking about this I upgraded from the earlier 2.4.x version right around the same time i upgraded the OSX public beta. Is there anyway to download the older 2.4.x version to see if this will fix the problem?

I’ve not had the hanging when playing the first track, but I am experiencing the long start up, with the spinning beachball. Once open it seems OK, but this does happen every time, and also with either of the Macs I use for Audirvana. One is an older 2008 iMac, the other a more recent 2013 i5 MacMini, so it does seem to be an OSX issue.

Update: From original issue started thread on, after deleting and reinstalling A+2 on my iMac 5K Retina - able to play direct from library. iTunes integration still hangs as reported earlier. Same with A+2 version 2.4.

Loaded up A+2 v2.5 on new Mac Mini server (not running beta) and all working fine.

Appears to be definitely related to changes made by Apple in beta versions reported - which either related to changes that could be on-going forward or just a glitch in the development cycle. Again, would be good to check to see if duplicated on the same so for next imminent official OSX release there are no issues.

I also am a apple beta tester and experienced the same problem as bgroove. The work around on my system is to temporarily uncheck the the following boxes in system preferences / audio system: Exclusive Access Mode, Direct Mode and Integer Mode and then check the Core Audio box. Audirvana Plus then begins playing my library and Tidal without problem. Once it is working I can then go back in and check the boxes I unchecked and disconnect it from Core Audio. Audirvana Plus appears to continues to work well until I turn it off. Then I have to repeat the process the next time I turn it on. I hope this helps others.

Thanks sleepace. Your temp fix works for me as well so back in business.

Btw - just upgraded the latest released this morning - 10.11.5 Beta (15F31a) and original issue still there. Appears something has changed in OSX for the coming release that Damien may want to look at.

Update: With the 10.11.X beta (10.12 upcoming release), the work around to use the Core Audio (and disable Direct / Integer Mode) does allow to play through A+2 but of audio quality not the same. The switch back in Audio System from Core Audio “once playing” appears to not make any difference from an “audio perspective” - My guess is the Audio System does not re-route until A +2 turned off/on.

Ended up moving all to my Mac Mini that is still running non-bata software and all ok for now in terms of my audio system set up.

Asked an Apple developer friend of mine to check a demo of A +2 to see if works with the latest (and assume eminent release. Appears that even with latest same problem.

Not sure what changed but worried the next official OSX will leave us disabled with the audio quality we’ve all grown to love.


And fortunately we are not encountering another strong quality issue others are getting on El Capitan: http://www.macrumors.com/2016/05/13/macbook-pro-system-freezes-os-x-10-11-4/

Another workaround is to simply press play, wait while the loading notice appears, press stop, press play, wait while the loading notice appears, and so on until it starts playing. A+2 will play eventually, it just takes some patience.

As I’m sure you know now, the 10.11.5 public release does not fix this issue… or rather, the release officially introduces this problem.

OSX 10.11.5 went to general release, with iTunes 12.4. I’m still running the old v1 of A+, the problems I’m seeing (playing one song and “stopping unexpectedly”) suggest that this issue isn’t resolved.

Yes indeed the case. Official release has made this problem official. Moved things over to my Mac Mini which was not on the beta to get things going again. After today’s official upgrade though this also has problem.

Damien, are you looking into this?

Oh yes, this other regression in El Capitan (now official …) has broken Direct Mode.
If you want to get it back, you have to replace IOAudioFamily.kext in /System/Library/Extensions by one from a former El Capitan release. You may have to disable SIP to perform this action.
The new Apple bug is located in this IOAudioFamily.kext module.

Just released 2.5.1 that gives an explicit error message (telling to disable Direct Mode) when encountering this 10.11.5 regression.

GREAT NEWS! Found a way to get Direct Mode back in 10.11.5!
You can now update to Audirvana Plus

Thanks Damien. Back in business!