Go to playing track does not go to correctly

Studio 2.6.6. MacOS Sonoma 14.2.1. M1 Mini.

Using list view, the go to playing track command (cmd L) does not work correctly when streaming from Tidal. When I press cmd L, either nothing happens, or the playlist jumps but the playing track does not come into view. It seems to miscalculate where the item is in the list.

When playing back a local file, this works as expected. The playlist scrolls the current playing track into approximately the middle of the playlist view.

Maybe check that you have not inadvertently turned the shuffle button on…

No I have not enabled Shuffle.

It’s odd.

If I choose (heart) Artists under My Music, choose an artist, then see all…, play something, scroll away, hit cmd L, it goes to playing track correctly.

If I choose My Playlists under My Music, choose a playlist I created from Tidal, do the same, it scrolls to some place but not the playing track

If I choose Explore under Tidal, choose a category, click See all…, play something, scroll away, hit cmd L, nothing happens

I switched the AS theme from Large to Default in case that was the problem. No change. Changing the Mac’s display resolution also results in no change

I use cleanmymac to uninstall AS and set up everything again, same problem. (Admittedly it didn’t actually clean everything b/c AS still remembered my accounts.

I’m using Qobuz on MacBook Air so tried to replicate as you have laid out @hifime.

Yes, exactly same

No, mine came back to playing track.

Yes, as you describe, but using Qobuz as i stated above.

Tending to think that the first 2 scenarios are being completed in My Music (which is the Audirvana) API. The last scenario is being done in the Tidal/Qobuz API and possibly not recognising the Keyboard Shortcut.

For example: If you want to check the play count on an Album from Qobuz it won’t show in my Music (apparently it only shows for local albums), however add it to a playlist in the Audirvana Navigator Section and it will show the play count on that album. That is how i check as to whether i have listened to an album or not from a streaming service. Anyway I digress so back to your issue.

I believe that there are a few things that work differently between the Audirvana API and the Qobuz/Tidal API so i guess only @Antoine may be able to assist there. Hopefully he will be able to review and advise in due course.

In the meantime, enjoy the music.

Hi @hifime, I had the same behavior on the 2.7 version of Audirvāna Studio as the one you shared :point_up_2: but not the others so I will need to check this with Damien.

Since this view as a lot of “See all” options, the issue may be between macOS API and Audirvāna. I need to review the issue with Damien when it will be possible.

I just updated to 2.7. This case has been fixed:

If I choose My Playlists under My Music, choose a playlist I created from Tidal, do the same, it scrolls to some place but not the playing track

But I can confirm that after clicking See all…, in the resulting playlist, cmd L does nothing.

Thank you

I would really like to reproduce this, can you record your screen, then reproduce this and send it at support@audirvana.com?

@Antoine

Pardon. Rather than a screencap, may I offer more concise instructions:

Left navigation pane, under Tidal, click Genres > Latin > See all…

Play a song. Scroll down a few pages. Hit cmd L. Nothing happens

Look under Play in the main menu bar. “Go to playing track” is missing

1 Like

I have been able to reproduce the behavior, thanks.