GUI frozen while converting DSD

My Native DSD Streaming Method is set to “none- convert to PCM”. DSD is saved as ISO image.

If the image is on the local drive, conversion is fast, however if it is on the NAS, conversion is like 3-4 minutes long and during that time GUI is completely frozen and Audirvana “not responding”.
When playback starts, GUI is still frozen for a while, apparently while conversion of whole track is completed. Upon track change, playback is continuing without issues but GUI gets frozen for a while, apparently until the new track is fully converted.

Is that normal, and can anything be done to avoid this?

Try to convert iso-dsd to dsf using this http://www.sonore.us/iso2dsd.html
No problem here, on macOS, to play dsd up to 128 (my dac limit is dsd128)

Bonsoir,
j’ai eu EXACTEMENT le même problème pour lire les fichiers SACD ISO. (sous W10)
J’avais aussi , systématiquement, deux gros POP à chaque début de lecture de fichiers (risque de fail pour les hauts parleurs)
N’ayant jamais eu de solutions à ces deux problèmes de la part du staff, j’ai transformé tous mes SACD ISO en DSF et changé mon PC qui était un peu ancien.
Les POP persistant en lecture sous ASIO, je lis les fichiers sous WASAPI.
Bonne chance

Hello @ron_13, Which version of Audirvana do you have? MacOS or Windows 10?

Hi Damien, It’s MacOS 10.14.6 and version 3.5.33.
My DAC does not support DSD, so I could also convert to PCM manually, but still freezing of the UI seems like something that should not happen. Thanks.

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info Audirvana button automatically copies all its content, all you have to do is paste it in response to this message

Hi. Please find the Debug info.
From pressing “play” till playback start it took 4min. 5sec, and during this time Audirvana “not responding”. Upon track change, no audio issues but UI not responding for 1min. 10sec. When UI is responding, navigation inside the track is without any problems.


Audirvana Mac Version 3.5.33 (3563)
macOS 10.14.6 with 16384MB RAM

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX not in use
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: /Volumes/NAS_xxx/test
iTunes/Music library synchronization: not synchronized
Library database path: /Users/xxx/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES

=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 13312MB

Local Audio Engine:
Exclusive access: Disabled
Integer mode: Enabled

Preferred device:
AirPods2
Model UID:4c 200f
UID:ac-90-85-06-88-b2:output

Currently playing in standard 32bit float mode
Device: 4ch Mixable linear PCM Interleaved 32bits little endian Signed Float, 16 bytes per frame 176.4kHz

Active Sample Rate: 176.4kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x39 Focusrite Thunderbolt Manufacturer:Focusrite Audio Engineering Ltd.
Model UID:FocusritePCIeDeviceModelUID UID:FocusritePCIe-00001

6 available sample rates up to 192000Hz
44100
48000
88200
96000
176400
192000
Audio buffer frame size : 14 to 3072 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Multichannel: 4 channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1
Channel 2 unused
Channel 3 unused

Audio channels in use
Number of channels: 4
Use as stereo device only: Yes
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x3a 4 channels starting at 1
6 virtual formats:
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 192kHz
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 176.4kHz
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 88.2kHz
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
4 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

6 physical formats
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 192kHz
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 176.4kHz
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 96kHz
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 88.2kHz
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 48kHz
4 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned high in 32bit 44.1kHz

Local devices found : 2
Device #0: ID 0x2f Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:94 UID: AppleHDAEngineOutput:1B,0,1,1:0
Device #1: ID 0x39 Focusrite Thunderbolt Manufacturer: Focusrite Audio Engineering Ltd. Model UID: FocusritePCIeDeviceModelUID UID: FocusritePCIe-00001

UPnP devices found : 0

Have you tried to enable DoP in the audio output settings in Audirvana? Do you have this issue only with ISO tracks?

DoP does not work for me. The sound is a low level white noise, with hardly audible audio playing in the background (probably at -60dB or so).

Haven’t tried other format playback, I am not really into SACD, only have few ISO images that I used to compare mastering. When on the local SSD, transcoding is taking less than a second, and navigation between tracks is instantaneous. When file is on the network, it’s as I described above.

My main concern is that - if under any circumstance, GUI gets frozen, in my view it is a programming issue and something needs to be done. Also, downloading file to a local buffer and playing it from there would speed up the thing like 5x.

That’s normal, your DAC doesn’t support DSD at all. You should only hear noise when selecting DoP.

Why don’t you permanently convert the DSD images to PCM files of max resolution your DAC supports? You can use third party tools for that, like XLD, dBpoweramp, …

Thanks. I rarely use DSD and normally would convert to PCM.

I mostly reported the issue here because I consider freezing GUI as a program issue that better be fixed.

Makes sense and it’s good you reported it. At least some indication it’s doing something would be useful.

It’s quite specific use case what you have here, so not many users have been impacted by this.

How are you connected to your NAS and which NAS are you using?

I have a WiFi network and NAS is Synology 1813+ . Shared as SMB and APF without any noticeable difference. Network is plenty fast for any practical application like video streaming and such.
image
I have not tried LAN connection as my Mac does not have the LAN port, but that should not change the fact that freezing GUI is not a good thing no matter what causes it.

Just to make sure, have you checked if your Synology is up to date?

Yes, it’s up to date. It also working properly for every other application.