Headless Macmini Problems


Sorry if this is the wrong forum to ask this, but I’ve tried other places have gotten no answer/suggestions.

I’m running a MacMini (Mojave) with iTunes and Audirovana Plus (3700) in iTunes Intergrated Mode. I’m using the IOS Remote on iPhone and iPad. But I have a problem; if my MacMini has been in sleep and I wake it with WOL then I am not able to connect with the Remote.app, I am only able to connect if there is a “keyboard”, meaning if I open “Screen Sharing” and connect to the Mini. Also a while I will loose the Remote connection if I close the “Screen Sharing” connection.

It does in general not matter if the Mini has been a sleep, it mostly comes down to not having a “keyboard”.

Have anyone else seen anything similar, and found a way to fix it?


Hello @casperghst42,

Did you try to enable the settings which prevent the screen from going into standby, so your Mac mini won’t be sleeping when you are using Audirvana?

This settings is in Audirvana settings>Miscellaneous, it’s the last section, this settings is not enable by default so try with this settings enable, it may solve your issue.

Hi Damien,

Yes, also screen saver has been disabled in MacOS. This morning I updated to Audirvana 3.5 to see if that changes anything - I am not sure if this has anything to do with Audirvana, this is just one of the last forums I know of where someone one might know what the problem is.


I run a headless 2018 MacMini. All software on Mac and Audirvana is latest available. I also have a Luna Display enabled on the MacMini but do not need to use it to run Audirvana, although I can use the iPad direct to the MacMini interchangeably with the iOS apps. I run the app on my iPhone and iPad. I am not experiencing what you describe. Audirvana is streaming Qobuz as I type this.

I have the MacMini set to “sleep” after 20 min. Sleep display is set to a black screen with clock. I also used the “Optimizer” function in Audirvana to control certain aspects of the MacMini. (I think that’s what it was called)

The only time I had a problem with a missing keyboard was during initial setup. Once the MacMini was setup, I disabled the Bluetooth function so it wouldn’t go looking for a keyboard. Also the MacMini is set to auto login and restart after power up. I leave it running 24/7. I never have to wake up the MacMini, it always responds. I do have a “Shortcut” on my iPhone and iPad that will wake the MacMini if necessary, but don’t need it unless I’m updating the operating system on the MacMini.

Weather or not screen sharing is running on my desktop iMac makes no difference.

Don’t know if this sheds any light - best of luck.


I had the same problem…use Caffeine. mac won’t fall asleep.

It looks like Audirvana 3.5 solved the problem, I no longer see the issue, but I’ll try Caffeine if the problem returns.