Help needed with "Unable to change to integer mode"

Hi,

I keep getting the “Unable to change to integer mode” message. I will post here the info from debug.

Any assistance you could provide would be useful. Thanks.

Audirvana 3.5.46

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX with device max frequency upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: by track
SW volume control: ON

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: F:\Albums
Library database path: C:\Users\bencl\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 22226MB

Local Audio Engine:WASAPI

Preferred device:
Speakers (AudioQuest DragonFly Cobalt v1.0)
Model UID:Speakers (AudioQuest DragonFly Cobalt v1.0)
UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{fccd2859-2502-46ac-b899-f7a241b0ea27}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

Active Sample Rate: 48kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Speakers (AudioQuest DragonFly Cobalt v1.0) Manufacturer:
Model UID:Speakers (AudioQuest DragonFly Cobalt v1.0) UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{d0b537ee-b63b-444d-8121-290204789aa9}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

4 available sample rates up to 96000Hz
44100
48000
88200
96000
Volume Control
Physical: Yes
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
MQA Renderer device
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 48kHz
2 ch Integer PCM 24bit little endian 88.2kHz
2 ch Integer PCM 24bit little endian 96kHz

Local devices found : 3
Device #0: Realtek Digital Output (Realtek High Definition Audio) Manufacturer: Model UID: Realtek Digital Output (Realtek High Definition Audio) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{1a6222c5-11f4-442c-9a66-dba67edc7d94}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #1: VG27A (NVIDIA High Definition Audio) Manufacturer: Model UID: VG27A (NVIDIA High Definition Audio) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{7062edf2-ea0e-436f-b490-d5ea62d945e2}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Device #2: Speakers (AudioQuest DragonFly Cobalt v1.0) Manufacturer: Model UID: Speakers (AudioQuest DragonFly Cobalt v1.0) UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{d0b537ee-b63b-444d-8121-290204789aa9}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

UPnP devices found : 0

Hello @Clewsie , are you trying to play tracks from Tidal or from

Both, from Tidal and my F:\Albums folder. It’s haphazard - sometimes it’s fine, other times it will play nothing, just has the message.

Can you remove upsampling in the audio output settings of Studio? Have you tried to use a different USB port of your computer?

I don’t have Studio, just 3.5.46. I have deactivated upsampling and so far had no problems. But I thought upsampling was the whole idea of the program?
Also, I have been trying to apply the 3.5.50 update, and keep getting the message:
App installation failed with error message: Appinstaller operation failed with error code 0x80070057. Detail: The parameter is incorrect. (0x80070057).
Can you help with that?

Hello @Clewsie,

We had an issue this weekend for some user to get the update, can you try again?

No, same result. The message: App installation failed with error message: Appinstaller operation failed with error code 0x80070057. Detail: The parameter is incorrect. (0x80070057)

Due a change in Microsoft security policy, the update to Audirvāna 3.5.50, from previous versions is special.
It requires, just for this time, a few actions from you to not lose the import of your tracks and playlists. So please follow the steps :

  • Make a copy of your database:

In the settings under the library section, click on the Change button.

Select where you want to copy your database (you can put it on your desktop for example).

  • Now that you saved it in a different folder BEFORE uninstalling 3.5 (It’s mandatory to not lose the import of your tracks and playlists)

Uninstall Audirvāna 3.5 from your computer: right-click on the icon in start menu and select Uninstall

Install the latest version of Audirvāna 3.5 using the link https://audirvana.com/delivery/AudirvanaWindows.php or this link

Open 3.5 one time and close it. This will create an empty database that you will replace with the saved one.

  • Replace the AudirvanaPlusV2Database.sqlite file with the one you have saved in step 1:

The empty databse can be located in a can be in two different locations :
C:\Users[your login]\AppData\Local\Packages\Audirvana.Audirvana-[… id number that can vary]\LocalCache\Local\Audirvana\Audirvana
C:\Users[your login]\AppData\Local\Audirvana\Audirvana

to show AppData folder:
https://support.microsoft.com/en-us/windows/view-hidden-files-and-folders-in-windows-10-97fbc472-c603-9d90-91d0-1166d1d9f4b5

You can now reopen Audirvana 3.5 and listen to your music. Don’t worry, future updates will be easier.