How do I add a song to a playlist?

How do I add a song to a playlist? I’ve tried everything I can think of, nothing works.

Hi @RZangpo2,

When you click on the three-dot icon in the app, do you have the option to add your track to a playlist?

Ah, I have to hover over the name of the track to make that come up. This is nowhere in the documentation, and I don’t find it at all intuitive that tracks have to be added at the track level rather than the playlist level. If I may make a suggestion, this ought to be added to the documentation. Thx

P.S. Even so, the three dots don’t appear when I search for the track. I have to search for it, then select “See All” to bring up a list, choose the track again, then add it. There ought to be a simpler, more intuitive way to do it IMO.

You are suitable for both points; it needs improvements. We need to work on it as we have other points in the software that need those improvements.

I, however, can’t give you a date when it will be available.

A related question: when I search for a track, I get a list in no particular order. I would like to sort it by title, to find the track I’m looking for. I have to scroll through the entire list to find it, which is a chore when searching for a common title. Any suggestions? Thx

Hi @RZangpo2 When you search for the song, if you also type in the Artist (obviously only if you know that) and the search results should be much more focused for you.

For example 1978 by Jose James. First screenshot with just 1978, second with Song Title and the Artist Name.

Hi @RZangpo2,

Can you please send screenshots so I can properly answer you on this manner?

Thanks but it’s not a big problem. Bigger problem is that I cannot subscribe. When I click the Subscribe button, I get the error message “An unhandled error has occurred. Please contact” I’m using the trial version of Audirvana Origin, how can I pay for it?

Have you tried to use a private window to log into your account?

What is a private window?

Which web browser are you using?


I used Chrome, it worked. Incredibly difficult to do anything, frustrating.