Huge, terrible bug – library entirely unaccessible

The Library function was working fine until just last week – i think it was after the last update. The Library is now entirely unaccessible – there is some bug that prevents it from being displayed. The window is just blank. Has anyone encountered this?

I can search in the search bar, and that brings up specific artists/albums – but i cannot view the entire library.

Display of my playlists is working fine. (These are imported from iTunes)

i have the latest version of Audirvana. 3.5.25 for MacOS

Running Mac 10.12, Sierra.

there used to be a link on the Audirvana web site to email support with bug reports. I don’t see this anymore. Can anyone tell me if there is a place to report bugs, or does one do it now in this community forum?

thx for help. debug info below:

Debug Info:
Audirvana Mac Version 3.5.25 (3555)
macOS 10.12.6 with 8192MB RAM


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

SoX with device max frequency upsampling
SoX filter parameters
Bandwidth at 0dB = 99.5
Filter max length = 30000
Anti-aliasing = 100
Phase = 66

Max allowed volume: 100
Replay Gain: by album
SW volume control: OFF

Sync list: 0 folders
iTunes/Music library synchronization: last synchronized on Wed Jul 17 15:12:50 2019

Library database path: /Users/Gene/Library/Application Support/Audirvana/AudirvanaPlusDatabaseV2.sqlite


=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 5120MB

Local Audio Engine:
Exclusive access: Enabled
Integer mode: Enabled

Preferred device:
AudioQuest DragonFly Red v1.0
Model UID:AudioQuest DragonFly Red v1.0:21B4:0082
UID:AppleUSBAudioEngine:AudioQuest:AudioQuest DragonFly Red v1.0:AQDFRD0100132968:1

Active Sample Rate: 44.1kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x2e Built-in Output Manufacturer:Apple Inc.
Model UID:AppleHDA:101 UID:AppleHDAEngineOutput:1F,3,0,1,1:0

2 available sample rates up to 48000Hz
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: Yes
MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x2f 2 channels starting at 1
2 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

2 physical formats
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 48kHz
2 ch Mixable linear PCM Interleaved 16 little endian Signed Integer 44.1kHz

Local devices found : 1
Device #0: ID 0x2e Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:101 UID: AppleHDAEngineOutput:1F,3,0,1,1:0

UPnP devices found : 0

try to do the 3 maintenance thing here…

thx for tip – i tried that (twice), but it has not solved the problem.

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

Go to preferences panel in Audirvana… delete with minus sign your database folderS there

Close Audirvana.

You will lose your Playlists doing what is next… export them before if you want to restore them after… since they are in itunes, maybe no problem… don’t know for sure don’t use that soft with Audirvana :slight_smile:

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up before trashing! or not)

Restart MAC. Restart Audirvana. Select Music Folder at beginning, let it load and see…

Update: problem fixed when i upgraded MacOS to 10.14 Mojave (had been running older MacOS)