I cannot import an m3u playlist in Audirvana 3.5.15

These are playlists that I could import in earlier versions. I click on Import Playlist, I get the file selection dialogue, I select the playlist and say Open, but nothing happens.

I have the same problem, version 3.5.15.1

Same problem on mac mini 2012 und macbook pro 2011, 3.5.15 ???

I should add that I am running Mojave 10.14.5 (18F132).

What’s curious is that after I upgraded from an earlier version of Audirvana (I forget which version) import was working properly. But for other reasons I deleted the sqlite databases and forced Audirvana to recreate them. That’s when import stopped working.

I have Audirvana (same version) running on another mac also running Mojave 10.14.5 (18F132). I upgraded that one to the current version of Audirvana, did not do anything to the sqlite databases, and import works.

I work with High Sierra.
Console tells:

standard 10:37:27.306738 +0200 Audirvana SFBrowserCallBack (node = <SFNode 0x6000000f3380>{domain = Network})
standard 10:37:33.570905 +0200 Audirvana Read options: 0 – URL: – purposeID: 6501D41E-88B9-4BAF-8A6E-5D1D9529880D – claimID: 217155F0-C1E1-46CF-BD37-DBFA0D2DAE7C
standard 10:37:33.654506 +0200 Audirvana Claim 217155F0-C1E1-46CF-BD37-DBFA0D2DAE7C granted in client
standard 10:37:33.654535 +0200 Audirvana Claim 217155F0-C1E1-46CF-BD37-DBFA0D2DAE7C invoked in client
standard 10:37:37.376108 +0200 Audirvana Connection to sharingd became invalid
standard 10:37:37.496150 +0200 Audirvana OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(ficl,askM handler=0x7fff4510f5c5 isSys=NO) err=0/noErr
fehler 10:37:37.496243 +0200 Audirvana errors encountered while discovering extensions: Error Domain=PlugInKit Code=13 “query cancelled” UserInfo={NSLocalizedDescription=query cancelled}

Any Ideas? Thanks

also on latest Mojave, and tried importing playlists for the first time, also no luck.
M3u created in BeaTunes.also tried M3u8

The Dev hasn’t acknowledged the import issue here, or on an active forum elsewhere.
I’m now using an alternative where playlist imports function as published.
fyi- I use a Mac App that creates playlists given “seeding” criteria, far quicker than manual creation, given 30,000 tracks.
Audirvana still sounds better, but function is important.
I hope the problem gets attention and is resolved soon.

This issue has been fixed (for me, at least) in Audirvana 3.5.24 (3554). My audio files were, indeed, on an external drive and this released addressed that problem. Thanks, Damien. I’m running Audirvana on a 2018 Mac Mini running MacOS Catalina.

Version 3.5.24:

  • Fixed import of playlists referencing audio files located on external drive

I am having the same issue. Using Audirvana 3.5.24 on a Mac Mini OSX 10.11 El Capitan.

My media is located on a NAS.

Playlists import fine in Audirvana 3.2.

I encountered the same problem in different versions of 3.5, including the current 3.5.29.
I have Audirvana on a mac mini and a macbook and I found that it may happen that importing playlists works on one, but not on the other. Although they have the same version of Audirvana installed.

First: export all your playlists!
My solution that seems to work is to delete (better, add .bak) the database in home/Library/Application support/Audirvana.
Then add your monitored folders again and import your playlists.

The Wizzard. My experience is similar to yours. I have two Macs both running the latest and greatest version of Catalina, and Audirvana 3.5.29. On one of them I can import playlists. On the other I cannot. On that one that doesn’t work, I uninstalled Audirvana (3.5.29) and reinstalled it. At that point I could import playlists that I created in Apple Music. I used Audirvana for a while (a few days) and then playlist import stopped working. I don’t know what I did to break it. On the other Mac I can continue to import playlists.

OK, checking in the same bug as others reported above…Importing playlists into Audirvana doesn’t work for me.

I’m using a 2012 Mac Mini running Catalina 10.15.5, music files are stored on an external HDD. I’ve also done a delete and clean re-install of Audirvana 3.5.37 (most recent version as I’m writing this post).

I saved one of my playlists out of Music, used the File > Import Playlist command in Audirvana, and nothing happens. The playlist isn’t added. I’m trying with M3U file type for the playlist. I looked at the M3U file in a text editor and it’s clean, the data is there and uncorrupted.

In the past I’ve exported playlists successfully out of iTunes (now Apple Music) and imported them into Audirvana, so this is a new issue. I’m not sure if this happened concurrently with a recent OS X or Audirvana update…seems possible but I’m not certain.

This is a pretty big issue for me – Audirvana recently gave me a problem where all of my playlists are suddenly empty, i.e., they all contain zero tracks. I thought to export them from Apple Music again and import them back into Audirvana but this isn’t working. There are too many playlists with too many tracks for it to be feasible to re-create them by hand in Audirvana.

If anyone has ideas or workarounds to share, please LMK.

@damien – I would think this issue is a big blocker for new users adopting Audirvana. If they can’t port their playlists over many potential new customers may be put off.

Thanks in advance for any help from Damien or the community!

Hello @Lucky13, can you send one of those playlist you try to import in Audirvana at support@audirvana.com ?

Damien – Thanks for looking into this. Email sent!