In kernel streaming loud pops

When changing songs loud pops appear, but not with all songs. Filetype or buffersize no difference. In Wasapi no problems. DAC is in Nos mode through USB, Amanero COMBO384.

I have had the same problem since the beginning of AS. Unresolved, it is said to be a long time before an error is found. So Audirvana wrote me an e-mail

Thank you for this information. I purchased yesterday an annual subscription upgrading from 3.5 to Studio for having kernel streaming…!

Try “mute during sample rate change” setting.

How to mute settings? I do not understand. Can you write it differently? I do not use upsampling in kernel streaming.

  1. Go to Audio Settings
  2. Click the gear icon in the DAC Input section
  3. Enable the last option, ‘Mute during sample rate change’
1 Like

I changed this setting but it does not help.

I tried this option a long time ago, it has no effect!

Maybe it should work, but for some reason it’s non-functional, it doesn’t do anything. Could Damian look at it and let us know?

I wonder if there are any users who use the Kernel Mode without issues.

I use the Kernel Streaming Mode without any issues.

1 Like

I used (for the moment I use A 3.5) Kernel Streaming without any issues and for me that option (“mute during sample rate change”) resolve the “pops” problem. It’s strange how expensive equipements have problems, I used Kernel Streaming even with my integrated Realtek (max 24/192) without problems Also with my usb DAC (InLine) no problems.

I changed the laptop for a new one. Now the Kernel Mode works flawless.

So it can be said that NUC can cause problems? Skip still continues kernel streaming in the second track! I don’t know how to proceed. Buy a new NUC? That’s stupid isn’t it? I would rather go to ROON Nucleus than buy a new NUC.
I’ve already written it on Audirvan’s mailbox and they don’t know what it is. Is there anyone else who will skip the second track after 30 seconds? And what about the white noise between the songs? I’m desperate.
Tested in version 1.6.4 of Windows 10+ fidelizer pro

If is not a big difference for you try WASAPI. In my case WASAPI + small buffer (for example 1024) fix the skip issue. Also with upsampling deactivated.

Wasapi plays sound worse for me than kernel streaming! That’s why it doesn’t even make sense for me to try through Wasapi.

But I tried Wasapi and yes there is no white noise between the tracks! Error in kernel streaming.

I still thought of reducing the buffer from 5 GB to 1 GB and the noise between the tracks disappeared !!! Unreal but it works :dizzy_face:


I’m happy to hear this. It seems big buffer is not necesary if everything works ok, only create problems. Even with a huge file should not be a problem - it’s not necesary the whole file to be buffered from the first seconds of playing. The only problem I observed is with seeking - with small buffer you may wait more. But usually I don’t seek thru tracks so I don’t care.

1 Like

So eventually white noise is still in kernel streaming. It’s not right after the track. So I judge that my NUC will be insufficient in performance. Do you think that could be the case?