Issue on Apple M2 chip

I recently got a Macbook Air M2. Although Audirvana Origin plays fine onto this machine, there is a notable issue:

Indeed, while playing music via bluetooth headphones, if I start any other audio source (from YouTube, from a game or whatever), the audio is playing onto the Macbook Speakers, instead of being completely bypassed (and so muted) as it was the case on my old MacBook with Intel chip.

Hope you can address a fix soon!

I have a M1 MacBook Pro. And while playing music through either Roon or Audirvana Studio I’m getting the same thing as you do. Both Roon and AS use my Audiotrak USB sound card as they should, And YouTube plays through the laptops build in speakers. When I quit Roon or AS the YouTube movies play through my Audiotrak again.

It doesn’t appear to me to be an Audirvana specific issue.

1 Like

I tested it on my girl friend’s M1 MacBook Pro. Same there. I think it is a MacOS thing. In a sence it is logical because Roon and Audirvana use the sound card exclusively. If another program is trying to play sound it can not use the sound card, so it plays over the built in speakers (probably re-directed by the Operatng System).
It seems tthere is a technical difference (caused by the MacOS or chip?) between the Intel Mac and the M1 Mac.

On my NUC (Windows 11) which I use as the main music computer I do not have that behaviour with Audirvana and Roon. When I use Audirvana on my NUC other programs do not play sound at all.

I don’t think it is a bug in Audirvana (nor Roon). Probably not a bug at all, but a ‘feature’ in MacOS on Apple Silicon.

1 Like

Something to do with Audirvāna having “exclusive” control over the playback device I’m thinking :thinking:

Can this be disabled in Studio or Orgin? I can’t test this currently.

If I disable exclusive in 3.5 and choose my DAC as Apple playback device I can hear YouTube and Audirvāna at the same time (concurrent) thru my DAC MacBook Pro M1. Goto menu bar top right and choose your DAC or Bluetooth headphones as playback device.

Let me know if you need me to get my Bluetooth headphones and test further, keeping in mind I use 3.5 not studio or orgin currently.

Thanks all for your answers, that’s really appreciated.

I didn’t try yet with wired headphones, but from what I remember with Audirvana 3.5 or Origin on Intel Mac, playing via Bluetooth disabled entirely the other outputs (such as build-in speakers). This change in the behavior seems to be really related to Apple M1 hardware, and maybe there is a tweak here to do by Audirvana devs.

Regarding Exclusive mode, I remember well this option in Audirvana 3.5, but I didn’t see this option here in Origin, maybe it is enabled by default once we start the playback?

1 Like

Edit: as for wired mode, I expect that any other source would be disabled (expected behavior with Exclusive mode), as wired connection required the use of the build-in sound card. The issue, to me, is related to the fact that if playing via Bluetooth, the sound card path leading to the build-in speaker should be muted/not used thanks to the Exclusive mode. But currently that’s not working on Apple Mx chip (it seems).

@Antoine Any thoughts about it? (merci par avance)

1 Like

:notes: :eye: :headphones: :eye: :notes:@pierrechapuis

What is the output device selected in Audio MIDI Setup? This is where macOS determines the sound output device…

When playing via Bluetooth, Audio MIDI Setup says Build-in Speaker, but I guess it’s bypassed anyway by Audirvana (I mean even though it’s Build-in speakers selected, the stream comes in the Headphones via Bluetooth, as expected because this is the source I selected in Audirvana).

If I try to select Bluetooth Headphones instead in Audio MIDI setup, switching to another pref. tab and coming back results in Build-in speakers selected automatically again.

That said, this weird behavior of having the build-in speakers working while Audirvana streams via Bluetooth only appeared after I switched to Apple Mx chip laptop.

I don’t think this can be solved in Audirvana, because then Audirvana would need some magic trick to overrule MacOS or the hardware. Correct me if I am wrong, but I don’t think that is possible.

But is it really a problem? I am more of a Windows user myself but isn’t there a way in MacOS to simply disable the speakers in the settings manually or even simply turn down the speaker volume?

Yes, there is.
In this case, I selected, on a M1 Mac, as the sound output of the OS, a virtual cable that is connected to nothing.

Capture d’écran 2022-09-02 à 20.46.23

I could have also select ed"LC49G…". This is the Thunderbolt video connection to an external screen that does not have a speaker.

There’s an easier option. It’s to turn off the sound of the OS. It won’t affect the playback of Audirvana that streams through USB or the Ethernet port or Blutooth…

Capture d’écran 2022-09-02 à 20.52.52

@Cloclo That seems like a good workaround.

I also found some links from Apple support:

Set default audio output on MacBook Pro - Apple Community

If your Mac switches to a different audio device – Apple Support (UK)

@pierrechapuis maybe the suggestion of @Cloclo or the links above offer some sort of solution?

Thanks everyone.
@Cloclo’s suggestion is indeed a good workaround.

Although I’m still wondering why there is this change between Intel and M chip laptop. Exclusive mode should really prevent any other audio source from working, as it was the case since Audirvana 3.

I tried Exclusive mode on a non-Audirvana player, and it also does not work…

There’s even an easier workround.
Connect a 3.5 mm cable to the headphones port of your Mac, and it will be silenced, because the OS will output the sound to the headphones port.

1 Like

In audirvana studio and origin there is a pref somewhere (can’t check now) to use the new macos api (experimental) maybe that should be use or turn off ??

I don’t really know, all I see is the Exclusive mode turned On, which should prevent anything else (i.e. other audio sources) from working.

As said, this was already working for a while, already working since I’m aware of Audirvana back 10 years ago or so. So to me this is an issue that could be fixed in the Software, because the Exclusive mode isn’t working properly in this case.

it is in the audio units so no help for you i guess :slight_smile:

1 Like

I think your interpretation of exclusive access may differ. Basically the setting ‘exclusive access’ in a music player means exclusive access to the soundcard in use. It does not mean per se that other soundcards are denied access as well. It simpy means that the soundcard Audirvana (or Roon) uses is locked for use by other programs.

I tried it also with Roon, Foobar and JRiver on my girlfriends Mac M1. In all cases they behave the same as Audirvana (there is also sound played by other apps over the speakers in exclusive mode).
So it seems very unlikely this is something to be fixed in Audirvana. Audirvana (or Roon, JRiver etc.) only has control over the soundcard it uses, but can not dictate the operating system how to behave with other sound cards.
This is a fix to be made by Apple. Knowing Apple they will probably say that it is not a bug and ‘It works as intended’.