Kernel Streaming Modi 1 vs Modi 3+


I downloaded and installed studio last week. I was impressed by the increase depth of the sound stage using kernel streaming on my modest system using an old Schitt Modi. So impressed I decided to upgrade and order a Modi 3+ to enhance the experience; which I installed last night. But, the Modi 3+ will not work with Studio in kernel streaming mode. I get a message saying “error starting device playback”. The Modi 3+ works find in WASAPI, not listed as an option when trying to use ASIO.

I am wondering if this has to do with Schitt’s Unison USB adapter possibly not playing well with audirvana, or?

Any Help and, or comments would be appreciated.

Much Thanks.


I discovered that I am able to use kernel streaming now with the Modi 3+ if I turn on Upsampling
( either r8brain or SoX works), though was hoping to avoid “bells and whistles”.

Any thoughts, comments still appreciated.


Wow, feeling a little inept… it seems that I had unknowingly switched from Qobiz to Tidal and was then able to enable kernel streaming and make it work. Went back to Qobiz and once again cannot enable kernel streaming. So, this problem seems to be happening only when streaming from Qobiz. I have not had a chance to check out kernel streaming on my local library; hopefully I’ll some time later today to check it out.

Thanks in advance for any support, comments or ridicule.

Seems like the same issue as this:

You’re probably streaming higher than 16/44 on Qobuz and that’s why it doesn’t work unless you have some kind of sound processing enabled (in my case, a VST3 plugin with Audirvana’s real time control on.)

I’ll double check on the 16/44, but I think I tried that after reading a post in a different thread. Strange that kernel streaming Qobuz works on the old Schitt 1 but not on the new Schitt 3+.

Could you recommend a VST3 plugin, in case I go down that path.

Thanks for your help.

Thanks! Playing 16/44 worked indeed! Have no plugin and don’t wand to upscale right now, The same with MQA, which always play higher than redbook.


I’m using the Goodhertz CanOpener VST3 plugin for cross-feed. Enabling Audirvana’s real time control for the same lets me play higher than 16/44 with Kernel Streaming.

Hello AndreaColombo,

To confirm - you mean the settings in the windows sound control panel should be 16/44, or some setting in AS or Qobuz. Pardon my ignorance. Thanks.

Our overnight guest, my three year granddaughter, left for home and finally I had more than 10 minutes in a stretch to play with AS’s settings.

Thanks for stepping up AndreaColombo and pointing me in the right direction…

I had Qobuz streaming set to a max 24/192, once I set it down to lossless, kernel streaming would work. This is just fine for CD quality, and the HIRes Qobuz files I’ll have to just play on WASAPI for the time being.

1 Like