Kernel Streaming - No Sound?

When I switch to Kernel Streaming I do not get any sound. Track begins to play, everything ‘looks’ fine but no audio.

I am running Windows 11 and my mobo has TOSLINK out connected to a Genelec F2. Here’s what I see under WASAPI (note that Genelec DAC does not support 176.4 kHz) …

And here is what I see under Kernel Streaming (note that 176.4 kHz is now ‘active’. which strikes me as a bad omen) …

Any suggestions to get Kernel Streaming working?

Cheers,
Bruce.

Please paste your Debug information here, so folks can help you the best possible… it is found here: Settings–> My Account–> Help–> Debug information

:notes: :eye: :headphones: :eye: :notes:

Audirvana Studio 2.8.2 (20802)

Windows 11 (22631) with 32GB physical RAM

Connected account of : Bruce Kleinman

NETWORK
Status: available
Available network interfaces:
Ethernet LAN ({daf2c290-6a9a-4621-b057-4aad8925f025}) is private
Windows Defender Firewall status for this instance of Audirvana Studio
Active profile types: all
Private profile:
Firewall: enabled
Inbound: blocked
Outbound: allowed
Notifications: enabled
Public profile:
Firewall: enabled
Inbound: blocked
Outbound: allowed
Notifications: enabled
Third party firewall installed and registered in place of Windows Defender:
Norton 360

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins ACTIVE in offline mode
	VST3 plugin #0: C:\Program Files\Common Files\VST3\Room_Shaper.vst3
		ClassID: ABCDEF019182FAEB4D616E7555366462
	VST3 plugin #1: None
	VST3 plugin #2: None
	VST3 plugin #3: None

UPSAMPLING:
r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

AUDIO VOLUME:
Max allowed volume: 49.54
Replay Gain: None
SW volume control: ON

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: T:
Library database path: C:\Users\Bruce\AppData\Local\Packages\Audirvana.Audirvana-4118-9684-d80dbb7827cd_q3nymrkmej12j\LocalCache\Local\Audirvana\Audirvana\AudirvanaDatabase.sqlite

Local audio files fingerprinting
Tracks with no MBID: 14083

Remote Control server:
Listening on 10.100.100.222 on port 50196

ACTIVE STREAMING SERVICES
Qobuz: Connected as Qobuz Hi-Fi Sublime+

APPEARANCE SETTINGS:
UI theme: dark
Font size: large
Language: System language
Show album covers in tracks list: yes
Source list sorted:
Local
My Music
Streaming
Radios
Podcasts
Startup view: Local Library: Artists
Show local extended in source list: no
Use media keys: no
Use media keys for volume control: no
Use legacy Bonjour protocol: no
Number of paired remotes: 1
Remote pairing code required: yes
Screen saver disabled: no

=================== AUDIO DEVICE ========================

Active method: Local

Max. memory for audio buffers: 16384MB

Local Audio Engine: KernelStreaming

Preferred device:
SPDIF Interface (Realtek USB Audio)
Model UID:USB\VID_0B05&PID_1A20&REV_0002&MI_00
UID:\?\SWD#MMDEVAPI#{0.0.0.00000000}.{10842d06-f53c-444a-a7ff-ffc8d9d5d542}#{e6327cad-dcec-4949-ae8a-991e976a79d2}

Currently playing in Integer Mode:
Device: 2ch 32bits Integer, 8 bytes per frame 44.1kHz

Active Sample Rate: 44.1kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: ON
Mute during sample rate change: OFF

Selected device:SPDIF Interface (Realtek USB Audio)
Manufacturer: Realtek
Model name: Realtek USB2.0 Audio
Model UID: USB\VID_0B05&PID_1A20&REV_0002&MI_00
UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{10842d06-f53c-444a-a7ff-ffc8d9d5d542}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
USB Vendor ID: 0x0b05
USB Product ID: 0x1a20
Kernel Streaming capable

6 available sample rates up to 192000Hz
44100
48000
88200
96000
176400
192000

Volume Control
Physical: No
Virtual: No
Max volume alert: Enabled

MQA capability
Auto-detect MQA devices: No
Not automatically detected, user set to not MQA

DSD capability
Unhandled (PCM conversion) with boost gain of 6dB

Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 16bit little endian 192kHz
2 ch Integer PCM 16bit little endian 176.4kHz
2 ch Integer PCM 16bit little endian 96kHz
2 ch Integer PCM 16bit little endian 88.2kHz
2 ch Integer PCM 16bit little endian 48kHz
2 ch Integer PCM 16bit little endian 44.1kHz
2 ch Integer PCM 24bit little endian 192kHz
2 ch Integer PCM 24bit little endian 176.4kHz
2 ch Integer PCM 24bit little endian 96kHz
2 ch Integer PCM 24bit little endian 88.2kHz
2 ch Integer PCM 24bit little endian 48kHz
2 ch Integer PCM 24bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 44.1kHz

Local devices found : 2
Device #0: SPDIF Interface (Realtek USB Audio)
Manufacturer: Realtek
Model UID: USB\VID_0B05&PID_1A20&REV_0002&MI_00
UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{10842d06-f53c-444a-a7ff-ffc8d9d5d542}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
USB Vendor ID: 0x0b05
USB Product ID: 0x1a20
Model name: Realtek USB2.0 Audio
Device #1: DELL U2518D (HD Audio Driver for Display Audio)
Manufacturer: Intel Corporation
Model UID: HDAUDIO\SUBFUNC_01&VEN_8086&DEV_2815&NID_0001&SUBSYS_00000000&REV_1000
UID: \?\SWD#MMDEVAPI#{0.0.0.00000000}.{f83b64ca-7658-430c-bf7c-fd2483a7952f}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Model name: HDAUDIO\SUBFUNC_01&VEN_8086&DEV_2815&NID_0001&SUBSYS_00000000&REV_1000

UPnP

UPnP devices found : 0

Chromecast

Chromecast devices found : 0

Hi @Press250,

Have you tried to remove the software volume control?

Just tried turning off the software volume control … same problem, no sound.

Ok, let’s try a different. If you reset the settings you put do you still have your issue?

I mean by that deactivating the plugin you use and the 24 bit limitation

Disabled VST3 plugin, turned on “Bitdepth maximum of 24 bit” … still no audio, I am afraid.

Question: I mentioned in my OP that when I switch to Kernel Streaming the Output Device incorrectly shows that 176.4 kHz is available. I interpreted that as a a clue, perhaps a sign of ‘broken’ communication?

Somewhat unrelated to my problem with Kernel Streaming, I have considered purchasing an SMSL PO100 Pro external SPDIF interface. If you think the issue could be my motherboard TOSLINK, I will give that a try.

The F2 Subwoofer specifications show it capable to 96kHz… Are you getting any digital-audio signals out of the TOSLINK output with another driver like ASIO?

The PO100 Pro is a good solution…You will need to set the bridge (PO100 Pro) ‘sample rate limitation’ to 96kHz…

:notes: :eye: :headphones: :eye: :notes:

Hi @Agoldnear, thank you for the reply. Under WASAPI everything works smoothly.

I do not have an ASIO driver installed, though I could try installing ASIO4ALL if that would help debugging.

Great news @Antoine @Agoldnear: my new SMSL PO100 Pro works with Kernel Streaming!

It’s a great little device with both coax and optical S/PDIF. Supports UAC2 so it is plug-and-play with the native Windows driver. And drives the DAC in my Genelec F2 up to its 192 kHz maximum.

Any suggestion for the Kernel Streaming Playback Optimization setting?

Genelec shows the F Two having a maximum supported digital input sample-rate of 24/96kHz…

From the Operating Manual:

:notes: :eye: :headphones: :eye: :notes:

Numerical typo on my behalf, @Agoldnear, the DAC in the F2 does cap out at 96 kHz. I have the “maximum sample rate” set accordingly in addition to the “bitdepth maximum of 24 bits”.

The advantage of using an outboard DAC is that you can utilize the analog outputs to playback much higher resolution digital-audio files through the analog inputs of the F Two sub… There would be no playback restriction outside of the maximum sample-rates supported by the DAC.

:notes: :eye: :headphones: :eye: :notes: