Kernel Streaming won't play anything above 16/44

When I set Audirvana Studio to Kernel Streaming on my Win10 machine, I get an error message every time I try to play anything above 16/44 (“Error starting device playback”)

WASAPI plays those no problem and I know for a fact that my DAC is capable of up to 24/192, so Kernel Streaming should play those files.

Hello @AndreaColombo,

Which version of Windows 10 are you using and what is the device you try to play to?

Hi Damien,

My Windows 10 version is 19042.985

My DAC is the Schiit Bifrost 2:

https://www.schiit.com/products/bifrost-1

@Damien3, here’s some more debug information: If I activate the real-time plugin feature, I can play any of my HD files in Kernel Streaming no problem. If I deactivate it, I can no longer play them. If I remove plugins altogether, I also can’t play them.

@Damien3 i have the same issue using a schiit eitr. i just recently updated windows 10

@AndreaColombo i would like to know where to find this setting too so i can possibly have it work on my end

Hi @Deadspeck,

I don’t know if it’s going to work without actually using a plugin.

This is where the option is:

oh i see. thanks. i’ll redownload some plugins

seems like kernel streaming doesnt like schiit products… im using optical directly into my dac and now i can play basically any file i want now

I have similar problem If I engage Kernel streaming my Dac is restricted to 192 (capable of 384). It is ESS sabre dac in an Oppo 205. Using USB connection.

Found this thread! I can’t use my Schiit Gumby Multibit (5gen USB) with the Kernel Mode. Chord Mojo, UPNP or toslink to KEF LSX Dac work.

/Edit Schiit Modi 3 the same…

Unfortunately this is still a problem with v1.2.

I need to use a plugin in real time mode to stream anything above 16/44.1 with Kernel Streaming.