Last 0.5s keeps repeating when pausing DSD track

… using AS 2.4.0 , Windows Kernel Streaming on Windows 11 Pro.
It also repeats the last 0.5s over and over again when switching to another track until that track starts playing.
Only the unlock button stops the repeat.
Played around changing buffer size to no avail.
Settings DSD DoP 1.0 or 1.1 no difference.

It happens when playing native DSD or when upsampling PCM to DSD.
It only happens in Kernel Streaming mode.
When using Wasapi driver playing DSD, pause works as intended.
Of course I can use this driver instead, but I am really liking the sound when playing kernel streaming.

Any thoughts?

Friendly request… Can anyone that runs Windows Kernel streaming test if they have the same issue with DSD?

Thanks so much…

I am running Origin on Windows 11 and do not have your problems (when using Kernel streaming) with DSD. Not with native DSD and not with upsampling to DSD256. As far as I know Origin and Studio are basically the same programs (they have the same sound engine) except for the streaming part. So both should behave the same on Kernel Streaming. My DAC is directly connected to my PC with a USB connection.

Sidenote: WASAPI and Kernel Streaming are almost identical in Windows (except for some very low level details). Both bypass the internal Windows sound system completely. There should be almost no difference (if at all) in sound quality between WASAPI and Kernel Streaming. If you can live with WASAPI: problem solved. Also ASIO can be a good (or maybe better) choice if you have installed an ASIO driver for your DAC (in that case you don’t need to use DoP but can use raw DSD). If you can live with ASIO: problem also solved.

If you really want to solve your Kernel Streaming problem you need to provide more information about your system. To do so click on ‘debug info’ in Audirvana settings (while playing DSD in Kernel Streaming mode) and paste that info in your post.

This debug info provides lots of useful info about your RAM/DAC/Buffering/Windows settings etc. so people on this forum (and also Audirvana support) can help you better.

1 Like

Thank you for that suggestion.
While going through some menus I finally found a setting that influences the length of the piece of audio that keeps getting repeated. In the DAC settings changing kernel optimization mode to ‘standard’ it repeats a very short piece of buffer, resulting almost in a hum (I think it’s maybe 10ms or so of audio that repeats).
In setting ‘high’ it repeats in my best guess something around 200 ~ 250 ms and in ‘extreme’ this is the earlier mentioned around half a second…

Playing around with the audio buffer itself does not change anything. I can vary it from 256MB to 8GB with no difference in the way this repeat happens at pause or change between tracks.

Oh and yes, my DAC is also connected directly via USB…

Hi !
I have the same issues with kernel in dsd upsampling or dsd track. When i put the ‘‘pause’’ button , the last 0.5 s repeating.

@joffrey1981 thank you… I guess if you have 0.5 s repeats you probably have ‘extreme’ optimization selected in kernel streaming optimization as well.

It looks like it is not DAC specific as I have replicated it in two different DACs, both running USB with DSD running DoP 1.1 (tried 1.0 as well but same problem)

Thanks for the advice. I test that

Hi @hlooman,

Can you send us a copy of the “Debug Info” when you have this issue? You can get it in Audirvana Settings>My account

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Audirvana Studio 2.4.0 (20400)

Windows 11 (22621) with 16GB physical RAM

Connected account of : Hans Looman


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 1 folders
Library database path: C:\Users\Infigo\AppData\Local\Packages\Audirvana.Audirvana-4118-9684-d80dbb7827cd_q3nymrkmej12j\LocalCache\Local\Audirvana\Audirvana\AudirvanaDatabase.sqlite

Local audio files fingerprinting
Tracks with no MBID: 5233

Remote Control server:
Listening on 2001:569:f05b:5800:6407:5a31:d053:2caf on port 49716

Qobuz: Connected as Qobuz Society

=================== AUDIO DEVICE ========================

Active method: Local

Max. memory for audio buffers: 2054MB

Local Audio Engine: KernelStreaming

Preferred device:
Method (Combo384 Amanero)
Model UID:USB\VID_16D0&PID_0A23&REV_019;&MI_00

Currently playing in Integer Mode:
Device: 2ch 32bits Integer, 8 bytes per frame 352.8kHz

Active Sample Rate: 352.8kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:Method (Combo384 Amanero)
Manufacturer: Microsoft
Model name: Combo384 Amanero
Model UID: USB\VID_16D0&PID_0A23&REV_019;&MI_00
UID: \?\SWD#MMDEVAPI#{}.{a41bb3d6-3cba-4864-aaee-4ffa2699c2b2}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
USB Vendor ID: 0x16d0
USB Product ID: 0x0a23
Kernel Streaming capable

10 available sample rates up to 768000Hz

Volume Control
Physical: Yes
Virtual: No
Max volume alert: Enabled

MQA capability
Auto-detect MQA devices: No
Not a MQA device, user set to not MQA
DSD capability: DSD via PCM 1.1

Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: No

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch Integer PCM 32bit little endian 705.6kHz
2 ch Integer PCM 32bit little endian 768kHz

Local devices found : 2
Device #0: LC43LBU591C -2 (2- HD Audio Driver for Display Audio)
Manufacturer: Intel Corporation
Model UID: HDAUDIO\SUBFUNC_01&VEN_8086&DEV_281A&NID_0001&SUBSYS_00000000&REV_1000
UID: \?\SWD#MMDEVAPI#{}.{df43fa9b-2daf-4a78-8c18-2ce49a427915}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
Model name: HDAUDIO\SUBFUNC_01&VEN_8086&DEV_281A&NID_0001&SUBSYS_00000000&REV_1000
Device #1: Method (Combo384 Amanero)
Manufacturer: Microsoft
Model UID: USB\VID_16D0&PID_0A23&REV_019;&MI_00
UID: \?\SWD#MMDEVAPI#{}.{a41bb3d6-3cba-4864-aaee-4ffa2699c2b2}#{e6327cad-dcec-4949-ae8a-991e976a79d2}
USB Vendor ID: 0x16d0
USB Product ID: 0x0a23
Model name: Combo384 Amanero


UPnP devices found : 1
Device #0: [LG] webOS TV UN7300AUD
UID: uuid:47bd4dff-2ee9-7bc8-85d4-820e1a7e4858
Manufacturer: LG Electronics.
Model name: LG TV


Chromecast devices found : 2
Device #0: Den TV
ID: DnsSd#Chromecast-6375934262deb297c52c367567158400._googlecast._tcp.local#0
Model name: Chromecast
Device #1: Basement TV
ID: DnsSd#Chromecast-855511503e9cf4e8e5a09df3f53dd4da._googlecast._tcp.local#0
Model name: Chromecast

Built a second unit, set it up without fidelizer installed yet, can confirm the problem is reproducible running only Audirvana, nothing else.
DAC connected directly to PC via USB.
W11, 8Gb ram in this PC, kernel streaming. Changing the kernel streaming optimization in the DAC menu settings changes the amount of time of the track that gets repeated on pause for DSD content.
I am sure more people out there should be able to reproduce this behaviour…
I hope it can be fixed, as kernel streaming simply sounds the best in this setup.

Version 2.5.0 still shows the same behaviour for DSD windows kernel streaming.

Hi @hlooman,

We will look at this issue but it’s a complex one, I can’t tell you when it will be fixed.

1 Like

Version 2.6.3 fixed it. Thank you so much!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.