Latest updates 2.2.1 and 2.2.2 no DSD upscaling or Mequalizer display

Audirvana 2.2.0 allowed me to upscale to DSD 128 (maximum for my Uniti Atom) but the latest updates, both 2.2.1 and 2.2.2, the DSD option is greyed out using UPNP connection to the Atom? Also I can no longer see MEqualizer at all, all I see is a black/blank screen and have to press ESC to get out of this screen? I’m also noticing on some songs that they end abruptly about 2/3’s of the way through and then switches to the next song? Hope there is a 2.2.3 update coming soon…

Hello @edzed,

Can you send us a copy of the “Debug Info” when you have this issue? You can get it in Audirvana Settings>My account

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message.

I just noticed on the DAC Input dialogue box that “no DSD” was selected. I accessed this by clicking on the gear next to the output device. After changing this to 128 I am able to upscale to DSD128 using the bufferized upsampling box. I’m sure this setting was the default before the last two updates but I’m not sure. In any case DSD scaling is now working. Can Audirvana detect and set the maximum available upscaling including DSD via UPNP? If so it did not set DSD correctly for my Uniti Atom.

I’m not sure I’ll use upscaling going forward as I’m not sure I hear any significant difference but just interesting to play with this while I’m on my free trial.

I will most definitely use EQ going forward as this has made a huge difference in sound quality to my Spendor A7’s. The Atom/Spendor sounds near perfect flat (no EQ) for acoustic stuff, female voices etc. but the combo does lack just a little weight in the low end for music where you expect to hear/feel more bass. Boosting the low frequencies ~3db and taking just a little off the mids (1-2db) is a game changer for this combo and still sounds great for the acoustic stuff. I’m using the free trial version of MEqualizer which is very nice but I can only access the EQ screen when I’ve selected output on my main computer. I can not see the EQ screen when the ouput is set to a UPNP device?

It’s the device that is telling this to Audirvāna. If the PCM or DSD max sample rate is not correct, you can change it in the device settings.

You can’t see the EQ in real time but we are working on improving this and bring this feature in the future.

Great, thanks for the response and glad to hear these things will be fixed. On the EQ and other DSP stuff please make this accessible on the remote software as well. As a first step even being able to turn on/off various settings EQ/DSP settings previously created/saved on my PC would be great. Of course being able to control the EQ/DSP directly in the remote would be first prize.


Says in blurb that device specific settings are saved… not on my mac. still have to switch settings for each device.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.