Library not syncing under Mojave

Can anyone confrim this?
Since i upgraded to Mojave my library isn’t sysncing anymore.
I even deleted the local database and tried to rebuild it.
But unable to do so from my NAS (Folder is Volumes/music)
Please help.

Best Regards


I have the same problem I Sync from iTunes and it just hangs. I’ve used this method for years. The new albums are there but the syncing function never ends???

My library will not add anymore music , i’ve tried everything it doesn’t sync anymore .
This program is about done in my view , If they can’t fix this then they just rip me off that’s about it

Can you check the database integrity using the command in the Maintenance section of the preferences page?
Note that launching 3.5 and an older version simultaneously can damage the database.

Will run that again today

Says tree page referred to second page
Various out of order

I hope your software engineers are looking at this issue .
Could be a dealbreaker for a lot of people

No problems at all with syncing under Mojave.
More than 150.000 tracks.

@Macgeek: this means your database file has been damaged (by running simultaneously 3.5 with an older version?).
And this explains your issues.
The solution is then to restore from a backup, or delete the file AudirvanaPlusDatabaseV2.sqlite to restart from scratch.
It is located in ~/Library/Application Support/Audirvana
To access ~/Library with the Finder, you can use its Go menu while pressing the option (or alt) key. This reveals the Library command in this Go menu.
Please note that if you have manual playlists, you’ll want to save them by exporting them, for reimporting them after having synched your audio files folders.

1 Like

Hi Damien,
I may have the same problem…not sure. I have the latest version of Audirvana, after having had used your software for years. I’ve just today removed my old monitored folder in settings and have directed Audirvana to sync to a new external harddrive with the same music files (about 2.5 Tb).
The sync seems to be hung. The green bar is just about at 100% and the main screen continues to say “loading”. This has taken about 3.5 hours syncing .

Any help is appreciated.

I still having the same issue since I installed Mojave. Impossible to sync my NAS library or to connect to qobuz…

The technical support is always sending me the silly same automatic answers asking to delete the audirvanaplusdatabase but it’s not working… impossible to locate the file. Even when I’m deleting all the audirvana file and reinstall the application… not working…

And all this just after the update to Mojave…

Does anyone have a solution? It’s annoying to pay 80 euros for this software and not being able to use it…


It’s not the software. I have no problems at all, I have 4 NAS drives with music.
Are the drives present in Finder before you start Audirvana?