Library syncing quite slow: where can I find the log to understand what's going on?

Dear all,

I’m posting this here as I might have have put it initially at the wrong location.

Following some problems with library syncing, I decided to create a new network volume on top of the first one that was getting too big.
On the new network volume, I discovered that adding new files using the Finder while AS was up and running, immediately triggers a scan but limited to the new files: that was impressively fast!
I decided to give it a try on the old network volume (whose size has been reduced by transferring some files). It did not work as expected: it run during hours, without any visible progress, and AS crashes. I restarted the whole process two times: it lasted during more than 10 hours and crashed.
This is pretty strange as I managed to synchronise it in less than 5 hours before, with a larger number of files.
Can someone tell me where I could find the log information on Mac, as I did not see anything particular on console.

In addition, I do not see much disk activity on the NAS and AS does not eat more than 20% of CPU. I’m a bit lost I have to admit.


Run all night and ended up with a crash (At least one thread crashed) but syncing not ended.
Restarted network switches, Mac and NAS, and relaunched AS. Will see.

But still painful to understand without access to a log…

Anyone, any idea?

And by the way, I do not understand why:

  • Some posts appear (including mine) in light grey while others are in black.
  • My post does not appear in the New ones

Just to understand…

Black is unread. ‘New’ probably also means unread. And you must have read your own post.

Hi Jakob.
Are you sure? I see several posts in black with lots of “Views” or “Replies”.

By the way, any info on the location of some logs on Mac?

The only way to get some is to open the console of MacOS, use the search with the term “Audirvana” and then open it.

You will see logs of Audirvana after doing this.

Yes, this is what I do. But I did not see any clear indication of what AS is doing.
Surprisingly, AS does not eat a lot of CPU (Currently around 20%) and I do not see a big network activity (1.6M0 of data sent) and no significant disk activity on the NAS side.
So, I’m just wondering what AS is doing.

Last night I saw multiple crashes of thread 65, 66 and 72. Don’t know what it means.

I though I solved all those syncing problems but now I’m not that sure.

What matters is whether you have read the latest Posts. Not the rest of the world

Ok, thanks, got it.

1 Like

I saw on Console the following error messages but I don’t think this should be a real concern:

|Audirvana Studio|Error getting volume uuid for /Volumes/Copies de sauvegarde Time Machine retrying once|
Audirvana Studio|Error getting volume uuid for /Volumes/Recovery retrying once|

After 4 hours of processing, CPU usage raised to max 24% and is now around 10%. No significant activity on network or on disk.
What AS is doing if it do not use much CPU and is not sending/receiving data over the network? Is it blocked waiting for I/O devices (But which ones)?

I don’t understand and don’t know what to do.

Any idea?

Update: I transfered part of the files from the NAS shared directory to a new one but to no avail.
The import process starts on the old directory but never end.

No significant error message found in the log. I’m stuck here…

Maybe I will finally try Roon…

Ok, there should be a (several) file(s) blocking the process, but without any log, and without any help from the support, it’s hard to tell…
It’s business as usual: you pay, you fix!

Ok, I paid, I fixed it!!
Now it’s working, after 3 days of efforts, but I don’t understand the root cause. I did not remove or update any file, I simply moved some of them.

I thought it was part of best practices in SW engineering to trap any error and to have the capability to switch a debug mode on with the production of a log file.

Apparently, those best practices did not percolate everywhere on earth…