Lockup on restart after synching in Windows

I’m seeing an intermittent lockup / race in Audirvana 3.5.10 on Windows Professional 10 (x64).

Steps to reproduce: add some new music to a scanned library folder with Audirvana not running. Start Audirvana and wait for sync to finish.

What happens: Sync finishes, but the display continues updating with progress bars on all the artists / albums flashing. The app is unresponsive and the close widget no longer works. Quitting from the Task Bar icon closes the interface but a process continues running in the background requiring the Task Manager to kill it. (end process)

Posted here because there’s no “Bug Reports” category.

end state of the bug looks something like this:

this is probably related to the unresponsive UI during library sync. Happy to provide more details en francais si besoin. :slight_smile:

Bonjour @robcee,

Pourriez-vous vérifier l’intégrité de la base de données en utilisant la commande située dans la section maintenance de la page des préférences ?

Si cela échoue, vous pouvez vouloir restaurer à partir d’une sauvegarde, ou supprimer le fichier AudirvanaPlusDatabaseV2.sqlite pour redémarrer à partir de zéro.
Il est situé dans ~/Bibliothèque/Application Support/Audirvana
Pour accéder à ~/Bibliothèque avec le Finder, vous pouvez utiliser son menu " Aller " tout en appuyant sur la touche option (ou alt). Cela révèle la commande Bibliothèque dans ce menu " Aller ".

Attention : en supprimant le fichier AudirvanaPlusDatabaseV2.sqlite, vous perdrez toutes les playlists que vous avez créées dans Audirvana.
Vous pouvez néanmoins les sauvegarder en les exportant avant de supprimer le fichier base de données.
En revanche, toutes les métadonnées modifiées sont enregistrées dans les fichiers audio.

Pouvez-vous aussi désactiver l’option de syncrhonisation des dossiers au démarrage pour voir si le problème persiste?

Allo Damien! Merci pour votre réponse. Je suis un utilisateur de Windows, allors vos destinations fichier sont “~/AppData/…”.

J’ai vérifié l’integrité de ma base de données et je n’ai eu aucun erreur.

Je suis très réticent de réinitialiser ma base de données, mais on peut réserve ça pour un solution au dernier recours.

Quand même, je vais désactiver le synchronisation des dossier pour la prochaine commencement. Peut-être ça c’est provoquant un condition de course durant démarrage.

merci beaucoup!