Long, long sync time

Audirvana is taking a huge amount of time to sync my library. This morning, it’s taking an hour and a half, but most days an hour is typical. And while it’s syncing, the program is using more than 90 percent of my CPU’s capacity, meaning that every other task is very slow, if it works at all. That’s really not acceptable. I’m using the latest version of Audirvana on a 2017 MacBook Pro. I do have a large library–258,000 tracks–but I would expect the program to be able to handle that.

Actually, this brings up a second problem: this total number of tracks includes duplicates of the entire library, duplicates that will not load or play. They just sit there taking up space in the program and, perhaps, causing the slow syncing. I have no idea how they got there or what will happen if I delete them.

In case you don’t have a backup… you can redo your database…

If you have Playlists that are important export them first to desktop and save them in a folder… when Audirvana is reset, you can re-import them back in one shot. sadly to this day, the folders they were in if so, are not back, you have to do them again…

Apple hide the Home Folder in User Library at some time depending on OS System… When you have clicked your Home Folder, and cannot see the Library Folder in there, just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom… click Show Library Folder and then you’ll have access to the rest forever.

If you continu and trash the database, you will lose also the play count number of how many times you played those songs… if important to you or not.

Go to Audirvana preferences panel and delete with - sign your music folder(s) there.
Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…
Trash All the files in that folder (that is your database of music, back it up! or not)

Restart Mac.

Restart Audirvana, add a music folder when asked or go to prefes again and add one with + sign. LET IT SYNC, even better don’t try to adjust windows or edit files, even playing music while it is not finished… you’ll see the progress bar going… Could be long the first time depending on how large your library is, and Mac is fast or not… go to sleep if it is too long.

Then when finished, close Audirvana, yes close it before playing a song…
That way you will have your database from scratch saved without crashing or bugs.
Then copy the .sqlite file to somewhere else in a folder as a backup for today.
Do this as often you can, if you do many edits in your library or add many CDs,
that way if a bug comes back, you’ll have an not so far library to put back in
the same place without bugs.

After, reopen Audirvana, and play a song.

Thanks! That solved the duplicate album problem. But the very slow syncing is still going on.

Have you tried the three maintenances step for the database in the preferences, might help ?

I tried that when this problem first started, some months ago, but I haven’t tried it since cleaning up the duplicate files. So that will be next. Thanks!

@Cherrington
This is the same issue many of us face at
https://community.audirvana.com/t/audirvana-always-sync-at-startup/

For large libraries it is syncing “for ever” at restart or “on demand” even if there is no change not releasing memory and swapping memory on the hard disk. You Mac becomes not usable anymore with the blue spinning wheel. I have detailed those issues to support already a few months ago. It can take hours before you can control Audirvana. This issue started after I rebuilt the database following the duplicate issues.
This is happening for any sync and on top of that it will sync even if there is nothing to sync.
You have 2 solutions

  • stop using Audirvana and find another software
  • reduce your library and keep using Audirvana for the moment

In the meantime the more we are to write, we may get some kind of acknowledgment of this issue and eventually getting it fixed…