Long long sync time

Hi,

So…I just paid 99€ only to ind this thing not working at all.

I have Catalina 10.15.7, on my mac-mini and 8GB RAM

40.000 tracks in my iTunes and Audirvana seems to keep on syncing.
Sync-bar is fully blue; soo I guess done syncing, still horribly irresponsive.

Whenever I try to click on audirvana window it is s-l-o-w-l-y responsive : rainbow cursor

Whenever. Itry to switch tracks : s-l-o-w : rainbow cursor

i have 44,500 tracks… on a MacMini 2012… but 16gb of ram… (8gb is low, but could work)
Clicking sync, takes me about 15 seconds to finish…

PLEASE forget iTunes if you are new to Audirvana…
don’t put your music in an Apple Folder or iTunes (Music) now…
Open Audirvana in stand alone application…

So… if all your music is in iTunes folder copy it somewhere else, better on an external hard drive,
then delete that music in iTunes folder or keep it if you have place…

Since your are new with Audirvana i guess you don’t have playlists already…
Start fresh Audirvana by deleting those files…

If you have Playlists that are important export them first to desktop and
save them in a folder… when Audirvana is reset, you can re-import them back in one shot.
sadly to this day, the folders they were in if so, are not back, you have to do them again…

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Go in Audirvana preferences panel, then remove your database(s) there
(all the folder(s) of music you have there) delete them with minus sign.

Close Audirvana.

Go to User… Home Folder… Library… Applications Support… Audirvana Folder…

Trash All the files in that folder (that is your database of music, back it up! or not)

Restart Mac.

Open Audirvana, choose a music folder… not the Apple one, at first it will sync in top middle of main window… LET IT GO, even better don’t try to adjust windows or edit files, even playing music while it is not finished… you’ll see the progress bar going… Could be long the first time depending on how large your library is, and Mac is fast or not… go to sleep if it is too long :slight_smile:

Then when finished, shut down Audirvana, yes close it before playing a song
That way you will have your database from scratch saved without crashing or bugs.

Then copy the .sqlite file to somewhere else as a backup in a folder with today’s date,
then open Audirvana, and try to play a song.

You got brand new interface and new sound… Go to Audirvana menu and select preferences…
look at them all, then click on speaker icon in the bottom right main window…
select your DAC, then the arrow right of it and look at all the preferences there too…

Thank you for your extensive answer. I will let me be led by the hand. Will let u know how things turned out
Thx already for ur effort

since you are here… if you can install more ram… that will help for sure…
don’t try upsampling with 8gb :slight_smile:
Stay basic the first time, then when you are set, and have some backups of your .sqlite…
then play with others things like upsampling if you want…

then when you have your new database or all things setup, do the three steps in the maintenance tab for your library in the Audirvan preferences… then, close Audirvana and save again that .sqlite as a perfect backup.

Whenever i do changes in my tags and add new CDs, i close and backup the .sqlite…
don’t trust Apple and Audirvana also :slight_smile:

You don’t want to lose that hard work you have done…

Your Playlists when you will have some, are stuck in the .sqlite… so if you trash it, you lose those playlists… but not if you have a recent backup… playlists can be right clicked and exported also to a remote folder on your mac for future importing… Have fun :slight_smile:

Sorry… it’s me again…
also in your Home folder… preferences folder… you have two prefs for audirvana…
com.audirvana.Audirvana-Plus.plist
com.audirvana.Audirvana.plist
when all your things are setup like you want, save them in the same folder with your .sqlite
of the day… or week or whatever, but remember if things fu*ked up, when you replace the faulty database with your backup database, you will be right on like it was as the backup date you put in… so, if you don’t want to lose a week of editing… :slight_smile:

Supper’s ready!! ok i come :slight_smile:

Hello there,
I’m new to Audirvana and evaluating the possibility of purchasing it.
I’ve tried Audirvana with a fraction of my music collection and found it amazing.
Lately I tried to add my full library (large, approx15TB). The syncing has been on going for a few days and only a third of the library is now synced. Database size has reached 23Gb. I’ve stopped my anti-virus and tried various things to speed up the process but to no success. If I stop and restart Audirvana, the sync starts over again. Any tips for me? Tried the 3 steps database maintenance, didn’t show any results. Recommendations and help welcome.
Win 10, Xeon CPU, 64 Gb ram. Audirvana doesn’t use more that 3 to 4% of the CPU resource.
Audirvana UI really slow, nearly unresponsive.

Hi, I’ve only a 4 TB music database on a Synology NAS and a Ryzen 7 laptop SSD to run audirvana and it works smoothly. Gigabit ethernet between NAS and server. My database is under 1GB. And when I add an album, a refresh of the database is around 2-3 minutes long.

The fact is that the first database scan may be long but the following ones should be much faster.

Is your database local ?
How many tracks / albums / artists / composer do you have in your DB ?
Do you have big albums pictures (over 1 Mb) ?
Do you store other album arts pictures at the same level as music files ?

Hi Laurent,
The database is local and both, OS and database are on a NVram disk. Albums are on an internal 18 TB disk.
Album art is indeed at the same level as music files, some of the artwork can be larger than 1Mb.
Roughly 500’000 titles.

My library is around 3.5 tb on a external usb disk of 4 tb…
around 45000 titles… sqlite weight 2.73 gb…
When i sync to refresh it, it is all done in 20 seconds maybe…

You have 10 times more titles then me! you think you’ll ever be able to listen to all :slight_smile:
NVram disc … is it working as hard as a real internal ssd disc for example?

Maybe in Audirvana window for the database, you should make smaller folders, maybe could help when one is synced it will left it alone and check the next folder to sync after??

I’m just letting it finish. A couple more days I guess.
Sorry wrote nvram but in fact is nvme disk. Nvme is connected via pcie bus that is much faster than sata (two to three times faster that a regular sata ssd)…
Doing some stats, 663 albums (6115 titles) scanned in 4h25. That is roughly 2.7 albums scanned/mn.
Have any of you tried to estimate the average time it takes to sync an album?
Hopefully the scan will finish before the end of the trial period :wink:

@Alexciara

Check this thread
https://community.audirvana.com/t/audirvana-always-sync-at-startup/
Your database is too big. It will sync for hours all the time and it will resync each time you start so you cannot use Audirvana basically; you have the rainbow cursor and/or your computer is getting very slow or even freezing with the memory not properly released…
As you can see in this thread we have tried hard but Audirvana support has made as if the problem was not existing…
I have moved to Roon for the moment like other people in this thread. @Remco_van_der_Wegen

Good luck with the support.
philoouu

@philoouu
Thanks, I had already read this thread.
Basically, this means that those that have a large music collection can’t use Audirvana until the syncing issue has been fixed. That’s a real pity …
@Manuel
Is there something we can do to make this happen?

@Alexciara
As you can see no news in more than 2 weeks…
No comment.

I’m having the same problem–Audirvana always syncs when it starts, despite my having unchecked the box that tells it to do that, and the sync usually takes anywhere from 30 to 40 minutes. To make matters worse, Audirvana uses most of my CPU while it’s syncing, so for those 30 or 40 minutes, it’s almost impossible to use my computer for anything else–my job, for example. My library has 20,000 albums, but I can’t imagine that is the problem since Audirvana’s main function is to be a music library manager. I see that many other people are having the same issue, but the replies from Audirvana are few, and never seem to include a solution to the problem. It’s extremely frustrating. I put up with it because I love the sound that Audirvana gives me, but I wish there was a way to fix this.

I wonder if the new Audirvana Studio is solving this issue…
Did they have a new way to scan files in the new software?

@Damien3 could you communicate about that finally?