Mac OS Monterey and Origin 2.2.5

I am running Monterey on a late 2015 MBP and can’t upgrade to Ventura. Origin 2.2.5 is running fine in legacy mode, but I can no longer access the main Origin page, (settings/dashboard) anymore. On my other newer Mac with Ventura, Origin runs as expected.

I can’t find any info that says Monterey and the latest Origin download aren’t compatible. Any thoughts?


Hi @Tonkhobie,

You mean you have this mode enabled?

Yes, it works well in this mode. However, I can’t access the non-Legacy mode with settings screen or the Audirvāna playlists anymore.

Which is normal, you need to deactivate it to see all of this again.

The purpose of this mode is to use it with the Music app. You won’t see Audirvāna settings or playlists in this mode.

Yes, I realize that. When I deactivate it, I see nothing. I don’t get the audirvana playlists or settings page at all. Nothing shows up on the computer screen.

Have you tried to quit and restart Audirvāna?

Multiple times. I even deleted the app and downloaded it again.

That’s strange tho,

I can’t reproduce this behavior on my MacOS Monterey 12.6.3.

Can you remove your AudirvanaDatabase.sqlite file?

To go to it with the Finder:

  1. Open its Go menu
  2. Pressing the option (or alt) key, and maintain it pressed. This reveals the Library command in this Go menu.
  3. Click on this Library command
  4. In the Finder window that opens, navigate into Application Support, then Audirvana
  5. You’ll find there the file AudirvanaDatabase.sqlite

After doing this, when you reopen Audirvāna Origin, are you able to see the interface?

That worked! Thank you very much😺

1 Like