Media Key support - macOS?

Can you take a look at your Security & Privacy>Privacy setting in your MacOS ? Does Audirvana is enabled in Accessiblity?

Yes, on my system Audirvana is enabled in Accessibility.


just to mention, when I press the command key + left or right arrow everything is work properly. the only problem is with the media keys (next/previous). pause/play media key is working.

Do you have iTunes or Spotify opened while you try to use it?

No - it doesn’t appear to make any difference to the issue if iTunes is open or closed.

no, the only program that works is Audirvana.

my computer is connected to a DAC via usb.i can control my amplifier with a small remote that works exactly like the media keys on the keyboard.
when Spotify works the remote can run the next or previous track, pause/play.
with Audirvana the remote can only pause/play. next/previous track not function.

When you use Spotify, are you using Spotify connect?

I’m trying to reinstalling macOS (pure, without any other apps). After that fresh install of Audirvana demo.

my MacOS is after a new fresh install. double click on Audirvana_3.5.41.dmg and gave hotkeys permission. restart Audirvana enter my tidal account.
only play/pause is working. next/previous track not function.

okay, you didn’t answered my question above, does your DAC use Spotify connect when you use Spotify on your computer or smartphone?

No, the dac works separately

okay so Spotify is embedded directly in your DAC, that’s explain why you can use your DAC remote to control your playback with Spotify.

It’s working also with tidal official app and Apple Music.
I have tried to listen through the Mac speaker (without the usb) and the issue with next/previous is the same. So I think that it’s something in Audirvana software.

I realise that this is probably a pointless activity, but it would be excellent to know a couple of things relating to this ongoing issue:

  • Is it yet one that is accepted by Audirvana as an issue that needs to be resolved?

  • Is anything at all being done to resolve this issue?

It seems such a small thing - I really don’t understand why we have to try so hard to raise awareness of it, or why it is so difficult to fix :frowning:

1 Like

Same issue here, play/pause buttons are the only ones that work. Next/previous does not. Using a MacBook Pro with a Logitech keyboard. (Note: the keyboard is connected through the unifying receiver) The only time the next/previous keys work is while using the keyboard attached to the MacBook.

This truly is a deal breaker. How can an app that focuses on media reproduction, cannot perform this normal function. I see that this issue is going for so long. So I think it’s fair for all to ask those questions @glawrie, we need to know if someone is trying to fix this, or we are just wasting our time posting the issue here.

Thank you, this is a great app but this problem is annoying.

Hello everyone, I understand your concern about the media key support on MacOs, we don’t know how Logitech have implemented the media key support of Apple but we do support media keys when it comes to official Apple product. We didn’t tried with media key of every keyboard available but if your issue is here only with Logitech keyboards, we will see what we can do.

1 Like

This is simply not true. See this message from a while back… which noted that the issue appears with Apple, Logitech and Satechi keyboards connected via USB, wireless and bluetooth.

I’m tired of this obfuscation of the issue. The original issue (now 18 months old) is that there are problems with the media keys and Audirvana on macOS machines. It is great to know that finally it is being considered as something that might actually need fixing, disappointing that the information being provided to help narrow down the issue is being ignored.

The idea that there might be some weirdness in Logitech’s handling of keyboard drivers that is not shared by any other keyboard is a mystery - if such was true I’d expect to see copious online discussions about how to get media keys to work specifically with logitech keyboards (as there are many many logitech keyboards, and many apps that use media keys) - but these issues are not reproduced when using other media apps on macos (at least all the media apps on my system except Audirvana seem to work fine with the keys). Do you think that each of these has custom code within to ‘fix’ support for Logitech devices?

Bonjour Damien,

J’ai toujours le même problème avec mon clavier: j’utilise Mojave 10.14.6, mais si je désactive l’option «Utiliser les touches multimédias», les commandes avant et arrière fonctionnent toujours, tout comme Stop. Mais pas la lecture / pause via la barre d’espace.
Si j’active «Utiliser les touches multimédias», alors chaque fois que je lance Audirvana, on me demande d’ouvrir les Préférences Système. In veut que je «coche» la case dans Accessibilité. Il n’y a pas de case à cocher ici, c’est dans Automation. Cela peut-il être changé?

Merci, Chris