Merging Anubis Premium - No DSD supported

I’m having some trouble getting my Merging Anubis recognized as a DSD device. I tried trashing the old Audirvana-Plus prefs and it’s still not working. I’m on 10.13.6 with the latest core-audio Ravenna driver.

I am about to get the Anubis Premium as well.
Are the Audirvana>Anubis recognized when playing PCM files over ethernet?

On my old Mac-Pro with El Capitan the Anubis was indeed recognized as DSD supported but I was unable to get DSD playback. PCM played back fine. On my newer MacBook Pro with High Sierra, the Anubis was not recognized as DSD supported so DSD was converted to PCM and so I get playback. My suspicion is that the previous Audirvana-plus preferences are causing the problem on the MacBook Pro as they did for my iFi Nano idsd. However when I went looking for them to trash them I couldn’t find them where they were supposed to be. More troubleshooting is necessary.

Are you sure the Anubis DSD support files are working.
I already ordered the Anubis last year and have been following the progres since.
I think the seller told me that even the Premium would not work with DSD right away.
But should come on a later update.
How is the Anubis sounding with PCM?
Right now my setup is microRendu>RME adi dac, but need 4ch out.

Yes, you are correct. No DSD support in the current firmware. Even in the following firmware, which Merging has pulled from their website, DSD is listed as not-supported yet. Hopefully it will be soon in a future update.