MQA and DSD playback issues

I seem to have a problem when streaming MQA where the song will stutter/hiccup randomly and have random popping sounds. This happens with any MQA file and nothing in the settings seems to fix it. With DSD, when I play local files, the songs also have popping noises that aren’t there when I play them through foobar. This issue seems to be PC side as it has happened with two different DACs.

Any help is appreciated.

Hello @BMoreira,

Can you send me a copy of the “Debug Info”? You can get it in Audirvana Settings>General>Debug Info

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

Audirvana 3.5.44

SIGNAL PROCESSING:

Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

UPSAMPLING:
SoX with Power Of Two upsampling
SoX filter parameters
Bandwidth at 0dB = 95.0178
Filter max length = 30000
Anti-aliasing = 100
Phase = 0

AUDIO VOLUME:
Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

LIBRARY SETTINGS:
Sync list: 1 folders
AUTO: F:\Music
Library database path: C:\Users\morei\AppData\Local\Audirvana\AudirvanaPlus\AudirvanaPlusDatabaseV2.sqlite

ACTIVE STREAMING SERVICES
TIDAL: Connected as HIFI

=================== AUDIO DEVICE ========================

Max. memory for audio buffers: 5592MB

Local Audio Engine:ASIO 2 driver version 1280

Preferred device:
Vinshine DENAFRIPS USB DAC
Model UID:Vinshine DENAFRIPS USB DAC
UID:Vinshine DENAFRIPS USB DAC

Active Sample Rate: 192kHz

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
Vinshine DENAFRIPS USB DAC Manufacturer:
Model UID:Vinshine DENAFRIPS USB DAC UID:Vinshine DENAFRIPS USB DAC

17 available sample rates up to 45158400Hz
44100
48000
88200
96000
176400
192000
352800
384000
705600
768000
1411200
1536000
2822400
5644800
11289600
22579200
45158400
Volume Control
Physical: No
Virtual: No
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to MQA Decoder
DSD capability: Raw DSD (MSB)
Device audio channels
Preferred stereo channels L:0 R:1
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1
2 ch Integer PCM 32bit little endian 44.1kHz
2 ch Integer PCM 32bit little endian 48kHz
2 ch Integer PCM 32bit little endian 88.2kHz
2 ch Integer PCM 32bit little endian 96kHz
2 ch Integer PCM 32bit little endian 176.4kHz
2 ch Integer PCM 32bit little endian 192kHz
2 ch Integer PCM 32bit little endian 352.8kHz
2 ch Integer PCM 32bit little endian 384kHz
2 ch Integer PCM 32bit little endian 705.6kHz
2 ch Integer PCM 32bit little endian 768kHz
2 ch Integer PCM 32bit little endian 1411.2kHz
2 ch Integer PCM 32bit little endian 1536kHz
2 ch DSD 8bit big endian in 8bit chunk 2822.4kHz
2 ch DSD 8bit big endian in 8bit chunk 5644.8kHz
2 ch DSD 8bit big endian in 8bit chunk 11289.6kHz
2 ch DSD 8bit big endian in 8bit chunk 22579.2kHz
2 ch DSD 8bit big endian in 8bit chunk 45158.4kHz

Local devices found : 2
Device #0: USB DAC ASIO Manufacturer: Model UID: USB DAC ASIO UID: USB DAC ASIO
Device #1: Vinshine DENAFRIPS USB DAC Manufacturer: Model UID: Vinshine DENAFRIPS USB DAC UID: Vinshine DENAFRIPS USB DAC

UPnP devices found : 0

Have you tried disabling upsampling?

It happens no matter what I do.

Reduce the pre-load cache to 2000MB.

So I tried reducing the cache to 2000MB to no avail. I think I did fix it though. I turned off the option to use non-MQA devices as MQA decoder.

That might mean that your computer is underpowered. What processor and much RAM you have on the PC?

By setting it manually to MQA decoder, you‘re losing the first „unfold“.

When I re-read this, I’m not sure I understood what you did. Did you set it manually to non-MQA or MQA decoder?

I changed the setting from MQA decoder to non-MQA. My pc is definitely not underpowered… I’m running a Ryzen 2700X with 16GB 3000MHz ram.

I’m thinking the issue may be specifically related to ASIO. When I use WASAPI, I don’t have any issues.

我播放 TIDAL 的 MQA ,设置为非 MQA ,DSD over PCM 1.1 升频 DSD 256 给 DAC,都会在正常播放很短时间后变成杂音,这时候只要手动拖一下进度条就恢复正常了。 切换到第二首歌时这种情况又出现了。

如果我设置推给 foobar2000 的 UPNP,会出现 :解码失败在 1:06.918 (Requested Range Not Satisfiable (416)):
http://192.168.31.161:49152/audirvana/audio_1_24.wav

怀疑还没转换好就推流了。

另外我为啥要推给 foobar2000? 因为 audirvana 的 UPNP 不支持 native DSD,我的 DAC 永远是 PCM 而不是 DSD。