No files in Library after new installation

Hello. New to Audirvana. I installed the trial on my Mac Mini (Intel) running MacOS Big Sur. In the preferences I pointed to my music folders stored on a Synology NAS. After doing so the Audirvana Library pane shows “Loading…”. It never changes from this message and no music is listed. I have about 20,000 ffiles stored on the NAS. The size of the Audirvana library in Application Support never changes from 256 KB. I let the application stay at “Loading…” for over an hour before shutting it down. Apple Music is also pointed to this music location and works fine. Any help is appreciated.

Hello @pete2021,

Can you try to synchronize a specific folder in your Sinology with Audirvana? Does it works?

Thanks for replying. Yes, if I select a folder containing the tracks from one album, it works. Also if I select a folder containing all the albums from one artist it also works. If I select the networked share on the Synology drive called Music, this does not work. The Finder and Apple Music have no problems accessing that network share by it’s name.

Okay, you probably have a file path not properly recognized that use a special character. To find it out, you will need to open the Console app of MacOS,use the search bar in console to search Audirvana. After doing this, sync your folder, you will see a line that should point to the folder.

Thanks for your reply. I am not sure what you want me to search for in the Console, but I searched all entries with a keyword “Audirvana” and nothing remarkable was returned. It seems unlikely that there are any special characters in the folder path name. Your preferences window shows the path as /Volumes/music . When synching did work the path was /Volumes/music/folder . So the first part of the path is the same in any case.

I am appearing to have the same problem. Whilst new files are being added to Audirvana, I can see them in Playlists, the Library screen is saying ‘Loading…’. I have opened Console and in the System log there is are 2 error which reads

Audirvana[748]: getattrlist failed for /Library/GPUBundles/AppleIntelBSWGraphicsVADriver.bundle/Contents/MacOS/AppleIntelBDWGraphicsVADriver: #2: No such file or directory

Audirvana[748]: getattrlist failed for /Library/GPUBundles/AppleIntelBSWGraphicsVAME.bundle/Contents/MacOS/AppleIntelBDWGraphicsVAME: #2: No such file or directory

I am running a MacBook Pro with BigSur 11.2.3. My music files are stored on a WD My Cloud Mirror.

That seems to be a different issue to what I am having. In my case nothing is added to Audirvana and the size of the library database never goes past 256 KB. I searched the System Log and the only entries for Audirvana are application startup messages. I have noticed that the Finder identifies the location where my music is stored as a type “Remote Volume” or “Sharepoint”, while the folders inside that location are identified as “Folders”. Perhaps Audirvana can’t resolve or deal with remote volumes.

It can since it would not work with any NAS if it wasn’t the case. The main issue that appear when you sync a lot of folder is that one of the folder path is not properly recognized because there is special character in it, this is why we asked you for the Console. In your case, it may work with /Volumes/music/folder if the folder (and the folders in it) do not have special characters in it but this means you have a folder no properly recognized by Audirvana in /Volumes/music that block the synchronization.

Damien,

Thanks for your reply. You are probably correct. As I stated I did not find anything searching with the Console, but one of the folders in the Synology music share is called “#recycle”. This is how the NAS deals with files that may be deleted by mistake. I am not willing to turn this function off. It seems that Audirvana should be able handle this or give the user the option to have certain folders be ignored. If you can think of another way to get this working let me know. Otherwise I’ll remove the app.

There is not option to avoid this folder. The workaround is to deactivate this option in your Synology but if you don’t want to do this then we can’t help you furthermore about this.

Recycle folder is at the root of every shared folder. You can move the content you sync one folder up in the hierarchy and map that forlder to Audirvana.

Damien,
Thanks for your reply. I understand. Another idea I might try is to disable the recycle bin function for that share, import the music into Audirvana and disable “rescan network folders at each start”, then turn the recycle bin back on. Do you think this would work?

Bitracer,
Thanks for your reply. Yes I believe that would work, but it would also require me to rebuild my Apple Music library, DLNA library on the NAS, and my cloud backups. I’m not willing to make those concessions to try Audirvana. Perhaps this will be fixed in the future.

I understand. Maybe you can copy a subset of your music collection to a folder upper in hierarchy and test with that.

Bitracer, thanks for your reply. I think I have already shown this to work. I pointed the Audirvana library to a folder inside my Music share at the same level as the #recycle folder. This folder had multiple album folders in it and Audirvana added them to the library. I’m just not willing to drag all of the 12,000+ album folders into a new folder and deal with the circumstances of doing that in other apps. I could “shift” click all the folders in my Music share and add the whole lot of them to Audirvana with one entry, but if anything ever changes they can only be removed on at a time from the library folder list.

We have just tried this on our Synology and it worked.

Damien,

I also was able to get it to work using the above procedure. Thanks again for your assistance.

It does work. That is how I’ve organised my Synology NAS - map to a directory/ folder that does not include the #recycle sub folder.