Playback glitches with Rose RS130 - update

I’ve been having issues using Audirvana with the Rose RS130 where every few tracks the first second or so of the track would be repeated and occasionally playback would freeze on track change.

The issue seems to be specific to the combination because Audirvana works flawlessly with other endpoints and other DLNA streamers work happily with the Rose. It affects both the Mac and Linux versions.

After many attempts to troubleshoot the issue I finally tried the Universal Gapless switch in Audirvana. I hadn’t tried this before because gapless playback worked well. Much to my surprise this seems to have stopped the problem from happening! The downside is that the Rose display no longer shows the track/album/artist information but just “Audirvana Gapless Playback” and the track playback bar isn’t updated.

Hopefully this information will help @Damien identify and fix the issue. If that’s not possible, would it be possible to update the display when in this mode.



Hi @the_bat,

Have you already talked about this with ROSE?

Hi @Antoine I did a while ago, but got no response and most recently told them not to bother. I suspect they’e just integrated a standard Android DLNA package and have no ability to bug fix that so unless or until they update it there won’t be any change at their end. I’m not holding my breath :grinning:

Other products, including JPlay, work properly with the Rose implementation in this regard but have other issues, so i far prefer Audirvana.