Pops/click when playing some flac music files

I have a topping d90 mqa dac, when using audirvana playing some flac files, there will be pop/clicks, this only happens with wasapi, if I switch to asio, then all the pops/clicks are gone.

I’ve also tried with foobar, with foobar’s wasapi both event/push don’t have this pop/clicks, I mean pops and clicks when during the play, not switching from flac to dsd or vice versa.

I’ve also tried with mac version, when I enable the integer mode there will be pops and clicks, but if I turn off this mode, the pops/clicks are gone.

this only happens when I play some specific flac files, not all of them. and only happened with audirvana with wasapi and mac with integer mode. So I’m pretty sure this is audirvana’s problem.

How can I help to identify the problem or fix this? this pops/clicks are very annoying.

I’ve just tried these music files with vox on mac, it also don’t have this pops/clicks.

It looks like you have a solution. On a Mac use with integer mode off. This has no impact on the sound quality. On Windows just use ASIO, it’s recommended way in any case. If the manufacturer provides a driver, it’s best practice to use it.

@Damien3 I’ve googled about the integer mode, it says integer mode is an essential option to bitperfect, but now with this option on, I’ve got pops/clicks, both mac/windows have pops/clicks on exact same time during play some flac.

but other flac players don’t have this problem.

I have similar issue on Topping D50S. Mine only pops only on Windows version of Audirvana and only when playing DSD files during STARTUP or when a STOP is pressed, then hit play again. But only on DSD’s. @Damien3 was very helpful initially but I think he gave up and blames it on the driver (even when Foobar2000) never pops. I"ve seen postings here with other brands of DAC’s pop-ing.

Their solution is to do DoP/ WASAPI (ala MacOS version of Audirvana) and pop’s do go away. BUT, it also means that DSD512’s will not play natively as DSD512. DSD64, DSD128, DSD256 are fine. I guess it’s a matter of compromising.

It is frustrating hence I have not committed to Audrivana. Everything else about it works great but one other thing: DSD Tracks with file size of 2GB (?) of more will not show up on Windows version of Audirvana but shows up on Mac version !

Trying JRIVER soon as that is what one authority on DSD files told me, in confidence.

Make shore that jou have the latest firmware installed on your Topping DAC and also that the latest driver software is installed in your PC.

I always use latest operation system, latest firmware, latest software.

This is the Audirvana oversampling. Disabled and no more clic, crack, pop, wizzz :slight_smile: