Progress bar stop and show nothing

Yes, there must always be some maintenance. :slightly_smiling_face: I installed minimized Ubuntu Server LTS (Long Term Support) on my mini-PC, which means there is only an OS version upgrade every two years, and a minimum amount of software to take care of. I also have Ubuntu installed on my desktop (along with another Linux distro and Windows), so whenever I feel like updating Ubuntu on the desktop, I ssh into the mini-PC and do the same, which is no more than:

sudo apt-get update
sudo apt-get -with-new-pkgs upgrade

And if necessary:

sudo aptitude safe-upgrade

And that’s it.

This is of course all a matter of personal preference. For me, to perform this brief update operation as seldom or often as I would like feels preferable to waiting for a manufacturer’s compatibility/bugfix update that may never come.

Thanks @Jud for your willingness to help. I will continue, my quest for an issue-less enjoyment of Audirvāna :blush:

1 Like

Hi AnoNom,

If you are looking for USB to SPDIF(Coaxial), aka DDC(Digital to Digital Converter), there is plenty of products on the market.
I myself also use one before, but terms of SQ, aka Fidelity, there is no more “affordable”.
e.g. System clock, there must be many investment needed, such as external clock generator, you have to choose TCXO, OCXO, and then with good power source, SMPS, Linear power, etc, maybe you will find yourself interest battery powered system, etc, etc.

You can find many DLNA/Open source complaint client software such as moode, Kodi, miniDLNA, etc. But it is painstaking process for develop your own streamer, you need to invest not only money but also sweat and lots, lots of time, and also will confront many fails and unknown issues, which have to be solved by your own and try to find solution by countless googling.

If you through all of this, of course you will satisfied by its SQ, but it is really painstaking process as I said, and there is more, Raspberry is just board PC, have to find good casing, design, etc, etc… endless to do list on your front :grin:

And, of course, you have to have at least certain level of “Talent” of design, program, etc because it is not a just install-and-done system, you have to start from scratch. There is no one who can teach you what to do from the start to end, of course someone can give you idea or tell you the way roughly, but that’s just, I would say, just scratch on the empty paper only. I don’t try let you down or discourage you but tell you the fact.

That’s why finally I drop this and use “Complete Device” from manufacturer… I am sick with endless take care of device and always focus on the system, I am too old to do that, I want just enjoy audio without hassle.

But my way to rest is blocked by trying find good stream controller. I’ve tried Roon, JRiver, JPlay, mConnect, BubbleUPNP, etc, all of it not satisfied me by certain points. This one has this problem, and that has that problem, I need program which gathers only good things from each program.
At this very moment, I am focusing on Audirvana. Perhaps I have to give some points up and enjoy music itself… :grin:

I’m going to gently disagree, because I’m not a Linux expert, did not have to spend huge amounts of money, did not find the task especially difficult, and came up with a very reliable solution that I think sounds very good. I will describe what I did, and then everyone is free to tell me I am wrong about money, difficulty, good sound, or whatever. :slightly_smiling_face:

The center of the solution is a mini-PC called the Fitlet3, with optional SFP+ optical Ethernet input. The optical Ethernet input provides an extremely reliable connection and galvanic isolation. The SFP+ input allows use of 10G specification optical Ethernet, not because the speed is needed but because that specification includes a requirement for very low jitter. As I configured it, with an Intel CPU, reasonable memory and storage, and optical Ethernet input, it cost a little over $400 US. It is built like a tank and has been completely reliable in my usage.

Unless you already have an optical Ethernet connection to your system, in order to take advantage of the Fitlet3’s optical Ethernet input you will need something like the QNAP QSW-2104-2S, which is $125 US on Amazon. It’s an unmanaged switch, so there is no fiddling to be done with it, it just works. Again, completely reliable. A couple of SFP+ transceivers and a length of optical fiber are perhaps another $50, so everything together is about $600 US.

That is all the hardware, and all the money, involved in the streamer. I have some nice power supplies and an optical USB cable (purely optical, no copper connection) that I think help with the sound, but that’s another topic. So then, on to the software for the streamer.

The operating system I installed on the Fitlet3 is minimized Ubuntu Server LTS (Long Term Support). It installs a minimal amount of software, there is no GUI to cause extra electrical activity, and it is supported for two years before a version change, which means the pace of updating is slow and so there is less maintenance. It has been utterly reliable with no bugs, as a Linux server OS should be.

And then the other piece of software is the UPnP renderer, upmpdcli. It’s used by other UPnP solutions such as moOde, streamers such as the Rendu series, etc. But I don’t want anyone else controlling the upmpdcli version or configuration and I don’t want any extra software, so I just installed upmpdcli itself (with its dependencies, including mpd). Upmpdcli presents a “plain vanilla” UPnP interface to Audirvana, so there are no problems with some manufacturer’s or developer’s tweaks to the standard. Mpd and upmpdcli each have a single sensible configuration file, so configuration is quite straightforward. The software has been just as completely reliable as the hardware, and works perfectly with Audirvana, without any problems in many months of use.

That’s it - a mini-PC, an unmanaged switch, a fiber connection, a server OS, and a UPnP renderer, $600 and easy to set up and maintain.

Thanks for your suggestion, optical LAN I missed also on my post.
I said invest and money - will not need much invest if use simple system like your configuration alone.

All people has different “greed” which, in my case, eager to archive more perfect SQ and reliable power, also good GUI system.
Just use USB is not un option for AnoNom, he needs SPDIF - so need DDC. If I use DDC, of course I want internal or external clock - as SPDIF need good clock for minimize jitter and sync, maybe result is not that different compared with just simple DDC but as I said, “greed” kicks in - need quite amount of money - and power supply, I want reliable linear power supply, or batter power bank, so let’s say at least over 3K USD, i.g. use SOtM DDC and external clock, linear power.

Of course it is perhaps just in my point of view, so please understand.

I myself, has no problem with no GUI system. just CLI prompt is ok, but many people has no knowledge of Linux - not even CLI environment, even DOS, nowadays.
I myself also hate to use just CLI system, even if there is no need to do anything with graphics, want GUI - like xwindow on linux. When everything is done, and no need much attention, then it is ok. But from the start to that end with none-professional’s hand is another story…

Yes, I agree with you that, its no need much invest, if not greedy. Just use simple system and with help from someone step by step installation and configuration. However, you know, it is not that simple, there will be long list of questions most of the times, and it is just, to be honest, very tired, I would say. I am not bad guy, but helpful person, however I want try to do myself if I have to do something, hate to ask others - because I know that is really disturbing if it continues, even from my own brother - haha :grin:

1 Like

I just forget, I didn’t know this fitlet3 system, it looks promising. Is it possible to install Windows 10? I use HP EliteDesk 800 G3 mini with i7-7700T CPU / 16GB / 256GB SSD for run Audirvana. It has very small form factor with no monitor, so I use VNC to remote control.

Edit - It can install Windows 10 Pro on fitlet2. Good, but has small CPU power for run Audirvana with it. hummm. good information though.

1 Like

Thanks @vcastceo and @Jud :+1:
To be honest @Jud 's description looks quite overwhelming to someone who last held a soldering iron many many years ago. Before embarking on such a project I will first try to explore the off-the-shelf DDC market a bit more. I came across devices like Gustard U18, Topping U90, Singxer SU6, etc. Their marketing blurb looks impressive but because it’s such a niche market I haven’t been able to find reliable user reviews yet. And they’re typically not available from the brick-and-mortar hifi stores close by.

1 Like

Thanks for your comments, @vcastceo and @AnoNom. Sorry I haven’t been able to reply until now - busy day!

You both make the very good point that for someone who hasn’t run Linux and isn’t familiar with the command line, this little streamer project is daunting. I agree, it probably shouldn’t be a newbie’s first exposure to Linux (though I know some people who’ve done similar things). I will say, for anyone who does have even a little familiarity with Linux, if I could do this you should be able to as well. :slight_smile:

Regarding CLI vs GUI, I think this fits your description of the situation when everything is done and it doesn’t need much attention, @vcastceo. I want this streamer to just work without requiring anything much from me, and luckily that is what it does. Typing a few lines into a terminal every couple of weeks or so to keep things updated isn’t much work at all. I think manufacturers’ streamers tend to need more attention than this one does.

@AnoNom, if I happen to run across anything like a review, user impression, or complaint regarding any of the DDCs you mentioned, I will let you know. :+1:

Thanks @Jud, much appreciated!

I have emailed an online dealer to get more info on these DDCs.

If you don’t mind me drawing on your knowledge a bit further, i continuously see these types of errors logged

image

Googling the error numbers I’m pointed in the direction of UPnP protocol details, port forwarding, etc…, not my cup of tea really.
Is it worth investing my time to learn this stuff or would you say this is not the right direction?
Also I did notice that on my ISP-provided router the UPnP switch is off. Could this a be cause for the issues I’m having?

Cheers!

Ah, it must be @Antoine who can explain what happen on your side and what you should try this and that. Most of the time it can solve if you have luck. So wait some time until he kicks in here and answer, if not, you can make new thread to show this particular error and ask.

vcastceo is right about this being something that is better for Antoine to look into. That said, I have a couple of random very much non-expert thoughts.

First, my familiarity with port forwarding is when one needs to send information between two different networks, such as between your local home network and the Internet. For UPnP, you shouldn’t have to do this. Both the sending computer and receiving streamer should be on your local home network. I’m guessing you don’t have two separate Ethernet networks at home, correct? So you shouldn’t need to do port forwarding.

Second, do you have a software firewall, such as Windows Firewall or one that comes with an antivirus program? Try turning that off - just the software firewall, not the entire anti-virus application. (But beforehand, make sure you have an excellent password for your router, if you have the ability to access it with a password. If your ISP is in control of it and you can’t access it, that’s OK.)

Edit: And yes, the UPnP switch being off could also be the problem, but it may not. You don’t want UPnP open to the outside world, only available on your local network. See if you can find out on your ISP’s website or by contacting them what the function of that switch is. My guess is that it would only affect local network traffic, but best for you to confirm this.

Hello @Antoine
I found some “rule” that when seekbar is stop working, it is always same track.
For example, there is 4 tracks on the list.
1st track start, seekbar working.
1st end, track change to 2nd, seekbar working.
2nd end, track change to 3rd, seekbar stop.
When it stops, then all the way to the end of the track, seekbar no more working.
For this example, 2nd to 3rd track change has something wrong.
Even I start from 2nd song, 3rd song seekbar is not working.

Another example, 5 tracks on the list.
1st - 2nd - 3rd working, 4th track seekbar stop working. In this case, no matter which track I start, it always 4th track seekbar not working.

So I make sample playlist, that 1st, 2nd track is from other playlist which never has seekbar problem. 3rd track is come from another playlist and this song seekbar is always not working. With this playlist, 3rd track seekbar is always stop working.(depends on device - I will explain on the last)

Next links are Tidal playlist that I made. For me, I have 2 UPNP compatible devices, Melco N1A/2EX and OPPO UDP-203. Oppo does not have this seekbar stopping problem, never. Only Melco has this problem… however others also report this issue, so their UPNP player also might have same issue with these playlists, maybe not, but worth to try.

https://tidal.com/playlist/56745002-5dd1-44e6-819e-38777d8717c0

https://tidal.com/playlist/6d12cf87-c840-468d-9ba1-1c58e4512f32

Add this playlist to your own Tidal account, and restart your Audirvana. Then these playlist will appear on your playlist - Tidal section. This problem is not only with Tidal but Qobuz and Local library as well. But Tidal playlist is easy to share with anyone, so I create 2 playlist for test purpose.
Play this with Audirvana mini player. And wait until 2nd track is finish. When track is just change to 3rd, you can see track length indicator - on right side of seekbar - will show something wrong number like -4095. Normally it must be track time. If this track has 3:20 length, it must shows 3:20 but it shows -4095 for example.

See the screenshot:


First image is from Qobuz playlist.
Second image is from Tidal playlist.

I now understand that it is not an issue with Audirvana alone, but as @Jud describes, it is UPNP compatible issue with certain UPNP devices. However it is not only device’s fault but also Audirvana has less compatibility with some devices, I might add.

I don’t know Audirvana could solve this problem for work with almost “Every” UPNP devices from all manufacturers, sound impossible. :scream:

However, if this issue is reported not only from me but many users, Audirvana development team should check it about it seriously, so make Audirvana to be “almost general UPNP devices compatible software” :wink:
Finger crossed!

1 Like

Just for your information, the progress bar disappearing issue is not limited to UPnP. Attached is a screenshot where the progress bar (in waveform view) has disappeared whilst playing tracks. As you can see from the screenshot I am using USB output to a Chord Hugo2. Happens irrespective of whether I play USB to a DAC or UPnP to some KEF speakers. Not track specific but in my case I only see it when playing DSD files. The waveform view will come and go. AS 2.6.5 on macOS 14.3 (RC). I should add this has occurred on every version of AS since macOS 14.0.

For me this not a high priority for a fix. All DSD files play without issue. On an annoyance scale of 0-10 probably doesn’t even reach a 1.

That is something else, about disappearing whole progress bar…! My DAC also Chord TT2 + M-Scaler but I don’t use direct USB connection though. Also my system is Windows 10 latest update version.
Weird, because as I mentioned, using OPPO as my UPNP playing device, there is no such progress bar/seekbar issue at all.
I believe that it was just for UPNP related issue with some devices…
There might have some root issue on the progress bar process on Audirvana…!
Thanks for your info, it should help to issue related people of Audirvana…!

Hi @Jud

Yes, both PC and streamer are on the local home network.
I run Bitdefender as antivirus and that takes care of the firewall.
Audirvana has been allowed all necessary access, so I don’t suspect any issue there

image

The ISP router manual I found is very concise on the UPnP switch: “Switches UPnP on or off in your network” :roll_eyes:

I did switch it on and will see if that changes anything.

Thanks again for your support :+1:

1 Like