Release 1028 - Synching issue

Comme dit précédemment, les répertoires situés sur le PC sont synchronisés. Toutefois, tous les albums situés sur mon disque dur externe ne sont pas synchronisés. La synchronisation reste bloquée.

J’ai installé et réinstallé audirvana sans succès.

Idem pour moi, La synchronisation reste bloquée (Nas Synology), le probleme n’existé pas sur l’ancienne version, donc impossible d’ecouter de la zik pour l’instant. Damen trouvera sûrement un solution rapidement :smiley:

I might unfortunately be lucky as I’ve just tried to reproduce the issue with my RAID5 QNAP NAS. I’ve browsed the network folder directly without having to assign it a letter, and then added the subfolder containing all its music.
It has synched all at once successfully…

So now, I need to understand what is different in your setups that makes it fail.
It can be either:

  • A file that makes the sync process fail/crash (e.g. damaged audio file, non audio file with same extension, like the .iso one used by SACD ISO
  • Some differences in the SMB protocol of the server

For the point 1., you can find up to where it has stopped synching by moving to 1st the “file location” sort criteria for the tracks view (in settings page), and then open Libray, tracks view, and scroll to the bottom.
As synchronization is done in alphabetical order, it’ll be the last file synched.
Then, try to drop the folder containing this last file on to the play queue (after having emptied it). And check if all the files in the folder are shown.
If not, then you get the culprit there.

For point 2, can you give me more details about your SMB share (NAS? PC? OS?), and do you add the share folder itself, or a subfolder?


Sorry Damien

I don’t fully understand the instructions.

How do I ‘Drop the folder on to the play queue’?


Hi Damien!

Importing a folder from my WD MyCloud NAS without assigning doesn’t work for me. And I don’t think it has something to do with the SMB protocol ( it worked well in 1027…so what have you changed in the code? ).
Windows 10 is using SMB 2/3 or SMB Direct…

BTW. it would be a good idea to provide a rollback option. I can’t use the 1028 and I wish I could use 1027 again…

I also cannot sync directly to a network location. I must first map a network drive. If I try to add a UNC location It just ignores the attempt and adds nothing.

I am using a windows 10 pro workstation with Audirvana, and the music is on a windows 2012 server which is both file server and domain controller. All users have full domain administrative authority. SMB connection shows as version 3.0.

I’ve spent the evening investigating and I cannot find anything consistent about the behaviour. Using the method outlined, I have determined that removing a problem album from the library sometimes allows the sync to move further on, but sometimes the sync will stop at an earlier album which was not previously a problem. it looks as thought the underlying connection to the share is being lost but I have no way of finding out of that is the case.

I think I have reached the end of my ability to explore and experiment!

Repeated attempts at re-synch after removing the albums which had previously caused trouble resulted in the synch stopping at a different place, sometimes an album later in the sort order but sometimes before (an album which had not previously caused trouble).

I then split my library into three folders (A-I, J-P and Q-Z) and mapped them to R:, S: and T: on my workstation. The first folder synched consistently, the second and third both stopped at approximately the same percentage complete but at different albums.

This seems to suggest that it is NOT a matter of a ‘bad’ file or folder.

Another issue (perhaps by design?) is that once I have added a mapped network drive to the library, I am unable to add a second drive thereafter.

All further assistance will be greatly appreciated.

Thanks for this continued investigation.
I’ve fixed the issue preventing to add a shared folder without first assigning it a letter.
For the stopping sync, I’m still trying to reproduce it.


Take the code for sync from 1027…the last version that worked…simple soulution :wink:

Jouez hautbois, resonez musettes!!!

Ca marche!

Release 1029 has fixed the sync problem. I used the UNC folder location and it syncs without issue. I am now going to try the mapped network drive and I suspect it will fail!

I think that the handling of file requests to a mapped drive is different from a UNC file request. I reckon it could be a Microsoft issue.

Marvellous - and thanks for all the work.

You’re right…mapped drive fails to sync…

Yep - just finish my attempt. Failed sync with mapped drive.

UNC = Good

Mapped = Bad


Pour moi la Release 1029, ne corrige pas le probleme de synchro :frowning: :frowning: , Bloque sur “Starting Synchronization”…

Can you sync if you put your library on a local disk? If it is on a network disk, have you used the unc path to access it and NOT a mapped drive? What is your storage hardware? Have you tried with the Windows firewall disabled?

I’ve just reproduced this issue that is linked to folders with no access permission. I’m working on it now…

pieronip, sur le disque local ça marche, mais pas en reseau (Nas), avec la build 1027 c’etait parfait au niveau de la synchro

With the arrival of version 1029, synchronization does not work (.
The trial period of the program will end soon

Are you experiencing slow/stopping sync or will the sync not start? If the latter, then Damien’s access permissions fix might be needed. It is not clear if this is in the new 1030 release but you should try this release anyway.

Damien has said to contact him if you need an extension of trial period.

In version 1030, synchronization worked. Hooray)))