Remote does not load library

Yesterday in a last effort I did an entire re-install of the Mac Mini (late 2014, Catalina 10.15.5) that we use for playing music plus a re-install of Audirvana. I already had Remote re-installed on both iPhone and iPad. None of this solved problem (i.e. Albums were not displayed, while Tracks displays all Tracks)
The Remote works well on my iMac, however Remote does not work well with said Mac Mini.

I am using Audirvana ‘headless’ so as you may understand, this a deal breaker for me. I really enjoy Audirvana but if I cannot find a solution for this, I will have to look for an alternative. I would appreciate any help in this respect.

AVM / Fritzbox has changed the firmware three month ago. maybe there is an issue

Thank you very much for reaching out.
@Damien3 suggested something like that too. However, in that case I wouldn’t understand why it works with my iMac connected to same network (hence via same router).

For security reasons, to me - as a layman - I would not tend to install previous firmware (regardless whether I would be able to ly my hands thereon).
Thanks anyway!

Since you have 2 endpoints connecting to the Same Library of Musik . Wäre ist the Library file located ? Local? Or on the Same Location where the music is?

I run the Software on a .Mac and win 10 no issues ever. And this headless

The music libraries are in both cases located on two external harddisks each directly connected to a mac via USB 3.0. The harddisks are more or less copies of each other. (So the music is not streamed for the purpose of achieving the best possible sq.)