Reoccurrence of UPnP track truncation and playback stops

Interesting one came back in the last few days. During playback of local files some tracks stop a few seconds short of the end of the track and move on to the next one. Also playback of a play queue stops after 2, 3 or 4 tracks played with no record after the first track in the playback history.

Steps taken to correct issue;

  1. Checked if this occurs on other playback streams. USB to DAC and headphones - No. MacBook Pro speakers - No, Chromecast to endpoint (KEF LS50 WII) - No. UPnP to endpoint - Yes

  2. What has changed - updated from AS 2.3.2 to 2.3.4 and updated macOS to 13.4.1. No updates to firmware of router or KEF’s, both running latest versions

  3. Tried turning on options in config for UPnP to KEF’s (fix for devices with playback stops - did not solve. Universal gapless playback mode - did not solve… not surprised did not need them before!)

  4. Re-set KEF speakers to default, re-set up with KEF App - did not solve.

  5. Reset wireless network from scratch confirmed optimum throughput - did not solve.

Therefore assume this will be a longer than normal issue…

Options obviously to just use Chromecast to the KEF’s which works without problems but being an experimental soul decided to re-set up my computer from scratch and install Roon after reinstating a subscription and not installing AS. In the past I have despised the Roon UI and prefer the audio quality from AS. Will be interesting to see if tweaking the preferences for my equipment using MUSE will enable me to get close to AS sound quality from my ears perspective and whether forcing myself into a Roon only use regime for a couple of months will assuage my hatred of certain elements of the Roon UI…

Time will tell, still have my AS annual subscription so can revert back if my experiment fails!

What is your definition of optimum throughput in the context of your wireless network?

From the KEF support FAQ’s:

B2. What router should I use?

For better streaming stability, you are recommended to have a dual-band router. Streaming Hi-Res music files through a 5GHz Wi-Fi network with a router transmission speed of at least 1300Mbps will offer better performance. Below are detailed technical requirements.

  • Your wireless router must support IEEE 802.11a/b/g/n.
  • Security protocol WPA2, mixed mode WPA2/WPA, WEP and open networks. Open networks are not recommended for security reasons.
  • WEP is an old encryption and may lead to setup and streaming problems. The WPA2 security protocol is recommended. Please refer to the user guide of your router to select the encryption method.
  • Channel 1-11 (2.4GHz) and Channel 36, 40, 44, 48 (5.2GHz) or Channel 149, 153, 157, 161, 165 (5.8GHz, in Tai Wan ONLY) are supported. You are recommended to set the router on a channel with fewer overlapping networks as this will have less interference. Please refer to the user guide of your router to select the router channel.
B5. How do I improve streaming stability?
  1. We recommend streaming Hi-Res music files over a 5GHz Wi-Fi network with a router transmission speed of at least 1300Mbps.
  2. Signal interference from nearby Wi-Fi devices can weaken music streaming stability. Try using a Wi-Fi analyser app to analyse signal strength and look for a better signal channel. For details, please refer to the user manual of your router.
  3. Wi-Fi signals in different home environments vary. Speakers and mobile devices are recommended to be placed in an area with a good Wi-Fi signal.
  4. Minor interruptions during streaming are normal when there is a weak Wi-Fi signal or heavy network traffic.
  5. A heavy streaming workload due to other Wi-Fi devices in the home is one of the common reasons for this issue. To maintain quality streaming, avoid downloading or uploading files during music streaming.
  6. Disabling “Gapless Control” on media players (e.g. BubbleUPnP) may solve some playback stability issues.
B6. Why is my wireless streaming sometimes interrupted?

Minor interruptions during streaming are normal, especially when there is a weak Wi-Fi signal or heavy network traffic. A heavy streaming workload due to other Wi-Fi devices in the home is one of the common reasons for this issue. To maintain playback quality, we recommend avoiding downloading and uploading files during music streaming.

Signal interference from other nearby Wi-Fi devices can also weaken music streaming stability. If this happens frequently, try using a Wi-Fi analyser app to detect the signal strength and look for a better signal channel. For details, please refer to the user manual of your router.

B16. Does LS50 Wireless support Gapless playback?

LS50 Wireless does not support gapless playback.

I am running a wifi 6 router that facilitates 4.2 GBS throughput. Using channel 40 with a channel width of 80 MHz on the 5Ghz channel, not crowded (only 1 other network using this with a signal strength of 5% so not an issue) Router is a/n/ac/ax.

The KEF’s are capable of much lower throughput but on the KEF speed test I get 63 MBPS which is way higher than a requirement for the HiFi service stated by KEF by a factor of 6. Internet uploads and download speeds are 989 MBPS download and 500 MBPS upload which is way more than sufficient.

Thanks for the input but seems unrelated to wifi this time. Switched to Roon already for my “extended” experiment in training my brain to accept it so any more diagnosis is not possible as Audirvana was removed via a clean install of the OS.

1 Like

It would be a salient test, to see how the Ethernet UPnP connection performs… It’s hard to draw conclusions without trying the Ethernet/UPnP connectivity of the system…

If you are serving your network wirelessly from the computer, it would make sense to connect the computer and the speakers via Ethernet, in-order to get a baseline determination of the UPnP performance, and to isolate from where the problem emanates…

:notes: :eye: :headphones: :eye: :notes:

You are correct, the KEF’s were connected to the main router (Mesh system with 2 satellites) via Ethernet but I did not connect the MacBook Pro to the router via ethernet. I did however run wireless diagnostics on my mac which confirmed 1200 mpbs link speed and everything was working normally.

Additionally the family are on a holiday in Europe at the moment so the wifi network during the occurrence of the issues over a two day period only had 2 devices connected, a phone and my MacBook Pro so the system was hardly being taxed. I have had no such issues with AS over the last year or so even with the family present and 10 devices connected with multiple users streaming audio and video at the same time as I was using AS to the KEF’s

As stated previously, have now removed AS and experimenting with Roon so will leave it for now… Thanks again for your input.

It may have nothing to do with throughput bandwidth… How will you detect spurious data-flow interrupts on the network that may be precipitating these things? UPnP protocol does not have digital-audio error-correction.

It seems that we’ll never get rid of this issue :cry:
I can’t check with my system for now as I’m abroad, so I don’t even know if the fix from the later Audirvana releases have any positive effect on my system or not, but I only know your problem too well…
By the way, are you playing FLAC or ALAC ?

Mix of Apple Lossless and Flac plus the odd DSD128 files. As I stated I do not have issues when wireless streaming to the KEF’s using chromecast so has to be a UPnP issue. Since removing AS and installing Roon have used both native and also upsampled files with no issues but probably using Roons transfer protocol not UPnP.

To be fair to AS I had this issue initially but was resolved for me for over a year. Just reappeared a couple of days ago. Giving Roon an extended go to see if my annoyances with the UI fade and I can ‘unhear’ the improvement in SQ I perceive when using AS.

Oh yes this is totally a UPnP issue and there are many threads here talking about this. The symptoms are always the same : tracks cut before the end, tracks being jumped over in the playlist, incorrect track name sent to the UPnP device, playback stops in the middle of the playlist. All happening randomly, sometimes fixed by rebooting the computer (memory management issue ? who knows).

We don’t know where the problem comes from (and Audirvana’s team don’t seem to be able to fix it either — their statement usually is a faulty UPnP implementation from the receiving device and they struggle to fix it on their end). I’ve been experiencing it since 5 years now on a Yamaha WXC-50. One day, it went away, for a few months. Then, it came back from nowhere, impossible to know why. I’m using Ethernet and stream very high bitrates of video content without any problem so I’d rule out network issues.

I asked if you use FLAC or ALAC because one member here had a theory about the problem coming from ALAC. As you probably know, Audirvana first translates the file through PCM before sending it to your UPnP device, and there could be a problem with the ALAC module. I only use ALAC so I don’t know how it behaves with a FLAC-only UPnP playback.

If you ever find a solution, please share as those who haven’t given up on their setup yet are waiting for any improvement on the situation.

1 Like

When I first had the problem over a year ago I had nothing but ALAC files. However in he last year also bought a significant number of Flac and DSD files. Does seem to occur to both Flac and ALAC

My only issue these days is that sometimes when I listened to radio streams and change to album or vice versa the Audirvana studio core app loose connection with my Naim NDS streamer/dac and I have to manually toggle the source inputs so the NDS initialise upnp again. Then after a minute or two Audirvana studio finds the NDS and it’s happy times again. No idea why this happens but it’s only when I switch between radio and albums. Never happens if I skip between albums or skip between radio streams.

I’d had this problem (stopping after 2 tracks, UI only shows first track) with a vendor’s UPnP implementation. When I substituted a mini-PC with my own plain vanilla UPnP implementation (upmpdcli with standard configuration settings running on Linux), the problems stopped. So I do think what we often hear from Audirvana regarding the problem being with non-standard UPnP implementations is true, and unfortunately these can take time and effort to resolve, if they are solvable at all.

1 Like

I agree totally with your comment. I believe this is an issue between KEF’s implementation of UPnP when used with Audirvana’s implementation. I went back and looked at my own notes from a year ago with my issues with UPnP to the KEF’s of track truncation and problems with play queues being terminated. I resolved the issue previously by turning on upsampling to the KEFS’s. The manipulation of the file via upsampling corrected the issue that would cause the KEF’s to stop playing a couple of seconds before the end of the file (it was only a few but unfortunately much loved tracks that would truncate).

I think in this case when I updated macOS to 13.4.1 I did what I always do and used an Apple Silicon mac restore file (total erase and restore to just the operating system with updated firmware). When I re-installed AS I may have forgotten to turn on upsampling in AS. I will check this if and when I give up on Roon (my experiment in retraining my brain to ignore my UI distaste and inferior SQ perception is not going well).

It clearly is an issue between KEF and Audirvana’s UPnP implemetation. However it would be impossible for Audirvana to produce UPnP code that took into account all of the different nuances of many and various manufacturers implementations. This is why the “Plays with Audirvana” programme is so important. The only way we will all have a satisfactory experience with UPnP will be when the manufacturers test their implementations with Audirvana to ensure full functionality and update their firmware where appropriate.

This is not an issue of Audirvana but one of the manufacturers not seeing a value in ensuring their equipment works with Audirvana as they do with Roon via the Roon Ready program. Probably due to their perception of market size of users that use Roon versus Audirvana.



Prompted by @Jud and @Yohmi posts (thanks) and my digging back into old notes for a workaround to this issue as detailed in the previous post, I re-installed AS and conducted a series of tests UPnP wireless streaming to the KEF’s again as follows;

  1. Created play queue with tracks that “truncated” previously.
  2. Set AS with upsampling off - tracks truncated when played. One playback queue termination
  3. Turned on upsampling (R8 Brain, power of two) - no track truncation played to end of file.
  4. Repeated steps 2 and 3 three times. Each time tracks truncated playing the native file, tracks did not truncate when upsampled.

Will take a while longer to ensure that playback queue termination is no longer occurring but am confident this work-around will work with my audio files and Audirvana / KEF’s implementation of UPNP. I do not expect this workaround will be successful for others with similar problems with UPnP who have different file formats and equipment/manufacturer UPnP implementations.

A case of old guy having to re-learn lessons he previously learned a year ago but forgot! Only cost me a $119 Roon Subscription, a day spent on messing with software and equipment and two days of relative discomfort trying to come to terms with Roon…


Hi guys, I get your comments on this UPNP issues about KEY and Yamaha for example. You are right to talk about PWA in those cases, they are part of the brands we aim to target and get the certification. The main thing is having them responding to our requests. Giving they have other priorities, we are not the top one for them but I really hope at some point we can get the certification for their devices.

I don’t know if their support team is in direct contact with the dev team but if it’s the case, it’s always good to send them requests of support when you have such issue so we can became their top priority.


Hi Yohmi, Just for your information. Was bored last weekend so did some testing to try and solve the track truncation issue, I tested all the tracks that previously truncated a few seconds before the end of the track only when streaming UPnP wirelessly to KEF speakers. They all truncated with upsampling off but did not truncate when upsampled. All were indeed 16/44.1 ALAC files.

So spent a few hours re-downloading the albums purchased from my Qobuz account as 16/44.1 FLAC and 16/44.1 ALAC files. Newly downloaded ALAC files truncate (the same rare tracks as previous) , newly downloaded FLAC files do not. As such it does, in my case, appear to be related to ALAC files.

Now I can turn off upsampling and play bit perfect via UPnP wireless without any truncation. Prefer to play files without upsampling so a minor niggle with UPnP wireless streaming to KEF speakers appears to be solved in my case.

1 Like

Thank you for your input !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.