RPi and iOS questions

Hi. Wonder if anyone can help. I have just bought a year subs to Audirvana and would really like to get it up and running with all my gear. It is installed on NUC running Windows 11 and this is connected to the network via Ethernet. Audirvana finds my BOSE wireless speaker and my Cambridge Audio CXN V2 fine (the latter also connected via Ethernet) but it just can’t find the RPi4 end points that I have which run Ropeeei (I know it’s for Roon first and foremost but it also includes UPNP capabilities). I had this problem when I tried JRiver, but when I put J River on my MacBook it found my RPi endpoints fine. So I suspect it is something to do with Windows and a setting I need to alter maybe, but puzzled as to why just the RPis.

Another quick question which I think I know the answer to. Can I get Audirvana to actually play to my iPhone/iPad rather than just as control points?

Did you install the RoPieee XL version?

Thanks both for the suggestions but yes Ropieee XL and it is working with UPNP fine from my MacBook and Audirvana. And OpenHome support is turned off - had trouble with that in the past so its permanently turned off. It’s got to be a Windows issue - as I say JRiver and Audirvana can both see my RPis running RopieeeXL not problem, but from my NUC - nothing! I was hoping someone else might have had the same problem and found a solution.

Turn off the firewall.

Check your Windows network type, it can be Public or Private … must be set to Private

Yep tried the firewall but not made any difference. Also checked the network and is set to private.

I did figure out what is going on and feel I should share it should anyone else find this thread. It seems this is a well known problem with powerline network adapters. I just could not figure out why my iMac and MacBook installs of Audirvana could “see” the RPi endpoints but my Windows NUC install could not. Then it dawned on me….they connect to my router via wifi and the RPi end points via Ethernet powerline adapters. At first I did not consider this as a problem because Roon on the NUC could see them fine, but of course Roon uses RAAT and Audirvana uses DLNA.

A quick internet search and there they were….loads of stuff on TP-Link power line adapters and DLNA blocking. Seems they are not simple, network pass through devices. So my solution is now long lengths of Ethernet cable and network switches, and all is good.