So many pops/clicks when playing flac using 3.5.39

I don’t know why this keeps happening, the foobar2000/jriver never has this pops/clicks during the music plays, now with 3.5.39 version, there are much much more pops/clicks than old version.

this pops/clicks happened when the music files are playing, both happens a lot under windows and mac.

because these pops/clicks happened so frequently, now I can not even use audirvana to play my musics.

please, @Damien3, please fix this annoying pops/clicks, If you need to investigate this problem, I can give you some of my music files to test this problem.

It looks like it’s related to your setup. I never had issues with pops and clicks.

Are you connected directly via USB cable to the DAC or you’re streaming using UPnP?

both mac/win, and both of my computer’s have this problem.

and both of my dac have these problem.

connected by usb cable.

Which DACs do you have? Have you tried with a different USB cable? This could also be a networking issue.

I have a topping d90 mqa version, under windows/mac, both system have this problem, and both running 3.5.39.

I also have a hilidac, which is a dac for smartphone, when used with computer, both mac/windows have this problem.

No, It’s definitely a problem of audirvana, because I also tested with Swinsian/foobar2000/vox/jriver trial on same computer, same dac, same music files, they all don’t have this pops/clicks.

By exact same setup, I mean, when audirvana have pops/clicks during play, then I click stop, and switch to another player app, play same music, and the pops/clicks are gone.

and this pops/clicks are not random, they appear at exact same time, with some music files, and only appear in hi-res flac files, no pops/clicks when play any dsd files.

Hmm, it looks like it’s more an issue with the files. I have many higher than CD resolution FLAC files up to 24/192. None of those manifested similar anomaly.

What’s the resolution of the files in question? What’s the source of those files, from where you got them? Have you checked if the exclusive access/hog mode are enabled?

How much memory did you allocated in Audirvana? … and what is is the ram installed on Mac and pc?
Are you upsampling or playing bit perfect?

I have 16GB RAM and I allocated 1024MB for preloading. It’s a Mac computer.

I’m always playing bit-perfect, no upsampling, no EQ.

The question was for @steve3d

Oops, sorry. I thought he was asking me, you have similar colour icon.

I have 32g memory, both computer, and the mem settings for audirvana is max,

also, I don’t have any eq, nor upsampling.

and the strange thing is, althought there are pops/clicks at fixed positions when playing with audirvana, but when I change to asio under windows, the are no pops/clicks.

and I’ve tested so many other music player apps, the audirvana is the only one which have this pops/clicks.

Well there you go. What’s the problem with switching to ASIO?

Have you tried to set the preload memory to 1024 or 2048 MB? Try to experiment a bit with the preload memory size. I know it’s counterintuitive but it works.

That could be the problem … the OS needs some memory to work … try to reduce the Audirvana allocated memory to 8gb or less … I’m using 4GB

i had the same problem with memory pre-loading set at Max Rate on a Mac. Set it to 4Mb and that should do it. I even had issues on Youtube if Audirvana was open with Audirvana set to Extreme Priority and Max Rate but changing the buffer down to 4Mb cleared this all up.

OK, tonight I’ve tested multiple option combine to find out what is the source of this pops/clicks.

First, this has nothing to do with the memory pre-loading, in my understanding, this preloading only loads current, and might load the next and previous track. so only if you are listening dsd512/1024, then this options might consume all your system memory. I have some dsd512 sample, and when playing the audirvana only use 3-5G memory.

and second, the output setting have replay gain setting, if I set this to keep album dynamic, then under windows with wasapi, no matter what, some music will always have pops/clicks at fixed position, and all this positions will have a huge dynamic. and under mac, with this option set to keep album dynamic, the result are similar to windows with wasapi, still pops/clicks when music comes to a huge dynamic position. set this settings to any other option won’t have this pops/clicks.

so this keep album dynamic is the real cause of this pops/clicks. tomorrow I will ask other people to test this.