Sonarworks Reference VST Plugin Does Not Work

Is this not compatible? This is the product I am trying to use:

Hello @cynics, I just download the free trial and this plugin is not a typical VST3 or AU since it will be displayed in the DAC section.

Do you know if support for these types of plugins is planned? This type of plugin is supported by MusicBee and foobar200 and is a critical feature for me.

I didn’t said it is not supported, you’ll not find it in the VST3 section in your DAC audio settings but it will be displayed as another DAC. Use the free trail and you will see that you can use it in Audirvana.

You are referring to the systemwide DSP, which is unstable for me at times. I would prefer to use the VST plugin with ASIO.

It seems that they don’t have a VST3 version for this plugin. It kinda odd since the version 3 of this plugin had a VST3 plugin in it. If they plan to make a VST3 version of Reference 4 then you’ll be able to use it in Audirvana, otherwise you won’t be able to use it in our software.

I tried the Sonarworks software last weekend. On a Mac I see the plugin in the DAC section and it seems to work. Unfortunately I can’t use it from there to stream to DLNA speakers.

I can see the plugin on the same Mac also under the Network section. There I can turn it on for example for my DLNA speakers. It seems to work, but after about 30 seconds the playing stops. Not sure what the reason could be. I am using on the Mac test versions for both Audirvana and Sonarworks but I don’t think that that is the reason. Another explanation could be that the Mac is 5 years old and might be too slow for real time processing of the sound.

On my W10 server where I have the Audirvana license installed, I can’t see the plugin at all. In the folder C:\Program Files\VSTPlugins I only find the file Sonarworks_Reference4_x64.dll. My suspicion is that Audirvana is looking for a vst-file and can’t handle the dll-file. I would really like to get this up an running on the W10 server.

If you are using DLNA connectivity you wont be able to change your settings while listening to your music, you then need to change it before playing your music. For the Windows version it’s totally normal that you can’t use it since it need to be a vst3 plugin to be able to be used inside Audirvana.

Thank you Damien. Any idea why the music stops playing after about 30 seconds when I run the music through the plugin on the Mac?

I tried running Reference 3, and that does not work either.

Hello, I was in a similar position but finally got Sonarworks to work with Audirvana. It’s not at all intuitive but easy enough to do once you know.

If you contact Sonarworks support they will provide you with a .vst3 file of the package, that’s something they don’t do by default but seem willing to do if contacted. Then you put that file into this folder: C:\Program Files\Common Files\VST3 For me, I had to create the folder which was easy enough to do. That’s it.

I have used Sonarworks for a number of years. It absolutely transformed my Sennheiser HD800’s into another realm, and I have used it for room correction in a couple of listening spaces. Whatever I listen to I really must get Sonarworks working with it. Now I can use it with Audirvana, Roon is going to get used a lot less.


Hello @24bitbob, thank you for sharing the info :smiley:

Hopefully Sonarworks will make a VST3 for Reference 4 to use ist in Audirvana.
Imam on a .Mac with Sonarworks and Audirvana and Miss the Integration of Sonarworks into Audirvana.

On a Mac, the offered solution seems not to help.

I was wondering: Audirvana supports AU presets, Sonarworks Reference 4 (in my case the Headphone edition) provides an AU file. This file was indeed installed in the standard folder on my Mac.
Does this help in any way? I could find the file in Finder, but not in Audirvana under where the other AU presets can be found…

I just set up Sonarworks for the first time. Using Audirvana Studio 1.10.2 on a MacBook Pro (2015). At first it was all crashing and buggy.

So I just used Rogue Amoeba Audio Hijack to route Audirvana → SoundID Reference AU → Output.

Within Audirvana I have the output also set to SoundID.

Can you send us a copy of the “Debug Info” when you have this issue? You can get it in Audirvana Settings>My account

Note: By clicking on the Debug Info button, Audirvana automatically copies all its content, all you have to do is paste it in response to this message

I use Audirvana 2.2.2 on an M1 Mac / Ventura 13.1
Now I want to test Sonarworks.
Run the current Sonarwork Plugin with Audirvana 2.2.2 without problems?

Once you get the plugin working, it is far more transparent that using the system-wide virtual driver, and also auto-switches sample rates according to the source. The plug-in is and sounds like it’s only the tiniest bit of extra software, after not using Sonarworks, and seems more like much more strictly just the EQ.