Strange behaviour: disks messed up, missing tracks and other things

Dear all,
I tried to insert into my library a collection of several CDs (a complete boxset) and observed multiple strange behaviour:
1- In AS, under a given album title, I do not get the same list of tracks as found in the folder on my NAS.
2- Some tracks, present in a folder on the NAS, cannot be found through the search feature in AS.
3- Some tracks are not correctly numbered: one album starts numbering tracks at “9” instead of “1”.

I suspect that the mess originating from the simultaneous presence in each sub-folder of:
1- A set of tracks, belonging to independant WAV files
2- A cue file
3- A m3u file

I plan to remove the cue and M3u files and I guess that things will be back to something cleaner.

But I would be curious to understand the logic behind the Sync process:

  • Does it privilege the cue file when present?
  • What does it do with m3u file, if it does not simply ignore it?
  • is there a risk of mixing up different source of input (File metadat, cue file, m3u file)?

Thanks for any advice

Hi @patifr

I have had this happen with my cds extracted by XLD.

My solution was to completely redo the operation. Then go into editing metadata (I do this in Audirvana.) That’s where I can see any anomalies.

This has worked for me.

Double CDs were comicated and I resolved it my renumbering each track into correct order.

Hope you resolve this.



Many thanks for this, Phil.

What I find very strange in my case is to have one track belonging to a specific album with a given title and pointing to an audio file with a totally different title…

I have my audio file extracted with Exact Audio Copy and it seems to be a total mess.

When you say 'Redo the operation", you mean ‘redo the sync’ I presume and not ‘redo the audio extraction’ from the CDs?


I know! I know! I know! I know!

What I mean is I don’t know why this sometimes happens. I don’t know how to fix it. I only know that I tried all kinds of tricks to get it right.

Yes. I do mean a complete new extraction. Usually, by-the-way, whenever I have any kind of hitch in my computering I turn everything off. Wait one minute. Start up again.

I know! I know! I know! I know!

Noogic or reason. This may not work for you.

Send a message to with your log and one of the team may be able to help you better.

All best


Oh! Important I think from my experience. One thing I’ve learned is not to do anything, especially metadata editing while the new album is syncing.

Thanks Phil,
OK, I think you are right: there is a need to redo the audio extraction, again…
I tried removing the cue files and other stuff: no change.
I checked the metadata inserted in the audio files: OMG! What a mess! All the mess is coming from that initial tagging which comes from really, … don’t know what to say.

And regarding your warning about syncing new albums and doing parralel things, I always try to follow that wise principle, not trusting the multi-threading SW architecture…

Thanks again. I think I have some work to do…

Take care


Hi Eric

I think you know more than me… “multi-threading SW architecture” …? What’s that. I n~d Mr google I think.

There’s a big thing going on in metadata during extraction.

I’m now using PS Audio Directstream Junior which reads the CD Red Book layer unbelievably “deeply” reviling info ife never heard before.

So now, although I prefer a high resolution file I have happily purchased 16/44 and get a great sound.

So, my days of XLD are probably neay over. I’ve still got a few cds I haven’t processed.



Hi Phil,
By this “multi-threading” thing, I meant that normally most of the activities in AS can be done in parallel (Sync process, track playing, library browsing) without any interaction due to this multi-thread architecture (Activities that can be run in parralel as if they were separated applications).
But, what makes the whole thing a bit more complicated than parallel applications is the sharing of some data (Same library for example) that creates interaction points.
Hope I managed to clarify this a bit…

Regarding my problem with that boxset, I found the cause of all of this mess: some albums in that collection (fortunately not all) were very badly tagged by EAC. Tagging was done automatically from an internet DB somewhere that contains data perhaps valid but in another context.
I managed to retrieve or rebuild the correct data and now everything seems ok.
So, AS was not the one to blame in that case.

So, a good advice is to check metadata especially when they are collected from an internet DB. Sometimes, the search process mixes different tracks altogether and insert wrong data.


Hi Eric

Yes. Yes.

So, AS was not the one to blame in that case.”

Audirvana only works with what it is given…

Everyone says use Yate or another metadata program but with care I think I can do all I need in Audirvana.

Thanks for your info.



Oops, sorry, forgot to mention something important! While looking for a solution to correct the metadata on some of the audio files, I found a nice and efficient tool named AudioRanger. I tried it and finally bought it (19€ is ok).
There are probably plenty of nice and efficient tools to to that but I found that one simple, intuitive and efficient.

1 Like