Studio Performance Adversely Affected By Streaming Service

For those of us with a local library who only occasionally use a streaming service for discovery or for the album reviews and artist bio’s the performance hit when clicking on an album or artist in our local library until display whilst waiting for the information loaded from the streaming service can be annoying.

With the service disconnected clicking on a local album instantly loads the album art/tracklist or list of albums when clicking on an artist. With the service connected it can take anything from 2-10 seconds depending the speed of the internet routing or streaming service load. For 4 hours today it was taking over 10 seconds to load album or artist details despite my internet humming at 980 Mbps download and 506 upload.

Is it not possible to display the local library and album information first and then update the display with streaming service albums bios etc when available?

The current behavior of waiting to display the local library information can make Studio look like a performance snail when in fact it is a thoroughbred racing stallion. As subsea internet cables and streaming services are increasingly becoming a target for nefarious actors this would be helpful. Not such a problem for those living in Europe or the US no doubt but waiting to display information loaded from Qobuz from Malaysia can be a pain at times.

1 Like

Decided to resolve this the easy way. Cancelled my subscription to Qobuz. At least now I can navigate my library at speed without waiting for Qobuz data to arrive. Qobuz streaming service seems quite poor to me. Often slow and when using the app on my iPhone caused the phone to heat up excessively. Will still use Qobuz download store which is as good as any,

Good day,
I’m asking for help again, yesterday I updated my Mac to version 14.4, consequently launching AS I found an update from 2.7.0 to 2.8.0
I ran the update, everything seems to work but starting is painful, the application window stays fixed for about 70/80 seconds, and then starts normally.
If it helps, I noticed that in “OFFLINE MODE” startup is instant!
I deleted everything and then reinstalled again but nothing has changed :-((

Does it only happen to me?

thank you all!

Once you get logged in have you tried disconnecting from your streaming service then re-connecting. I would also do an internet speed test to check if your network/internet connection is not slow. A reboot of the internet modem and router is a simple step to try and improve.

It could also be a problem with the routing you are funnelled through to your streaming service server or a problem on their end (DDOS attacks on streaming services can occur, one happened recently to Qobuz which meant slow service or inability to access the service for some users but not all) Also the Audirvana server may be slow. In both cases the other end will need to resolve the situation.

I also noticed some connections to the iCloud service have been slow after updating to 14.4, something which did not occur with 14.3.1. Maybe there is an issue with 14.4?.. However using Audirvana has been fine but then as noted above I am no longer using Audirvana Studio with a streaming service but the connection to the Audirvana servers to verify the licence and load the list of Radio stations and Podcasts seems to be OK for me. Hopefully someone else using a streaming service with AS can chime in to say whet he is seeing.

1 Like

Thanks Djm1960
I think I have done all the necessary tests and I have gone even further…
including uninstallation and subsequent reinstallation of AS.
The network is perfect!
The problem is to be found elsewhere and having updated Mac OS, I’m starting to have big doubts.
There is one thing I don’t understand though, if I deactivate the network and go to OFFLINE mode, AS starts in less than a second. What does all this mean??

When you first open AS it will check your subscription is valid and sign in to your streaming service (if you use one) with the username and password stored on the Audirvana server. This connection may be causing the issue. In Offline mode AS will not conduct a subscription check but will require you log on online at least every 30 days for a subscription check.

I also have doubts about 14.4 due to my issues logging on to iCloud, going to peruse macOS forums to see if anyone else is having problems with the login management framework in 14.4. If so may downgrade to 14.3.1 after downloading an installer and creating a USB boot installer

1 Like

Thanks again,
I’m tempted to try a Mac OS downgrade (from 14.4 to 14.3.1)
the operation is not exactly simple, but if it were worth it I would be willing to do it right away.
Do we have any other feeds on this topic??

I would try and connect first. If it succeeds even with a delay I would disconnect from streaming service in the settings/streaming tab and try again with just the streaming service disconnected and see if it starts ok. It should then just check your licence and connect to the radio services. If this is ok you know it is not the connection with the Audirvanla server for a licence check that is the issue just the onward connection to a streaming service.

If all good would then reconnect to the streaming service and try again to see if it works ok.

Yes downgrading macOS is a time consuming pain……. To only be attempted if other options fail in my opinion.

So far have not seen posts saying that logging on to internet services is a problem with 14.4 but it is early days for this release. I definitely had major issues logging into iCloud, very slow and unresponsive when first setting up after a clean install of 14.4 but managed eventually to turn on all the services. (After force quitting the frozen iCloud system settings page and turning on services individually and waiting ages for each service to connect)

1 Like

I finally solved it, it was my network problem (proxi)
No problems related to Mac OS or even AS 2.8.0

Everything started working great again.

Thanks for all the advice received :slight_smile:

1 Like

That’s great! Enjoy

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.